Bug 69889

Summary: WMV3/VC-1 garbled output with VDPAU
Product: Mesa Reporter: Pierre Ossman <pierre-bugzilla>
Component: Drivers/DRI/R600Assignee: Default DRI bug account <dri-devel>
Status: RESOLVED DUPLICATE QA Contact:
Severity: normal    
Priority: medium    
Version: 9.2   
Hardware: Other   
OS: All   
Whiteboard:
i915 platform: i915 features:

Description Pierre Ossman 2013-09-27 18:29:03 UTC
I've been trying out the new VDPAU support for Radeon cards, and it works fine except for two issues:

 1. Occasional system lockup (haven't found what triggers this yet)

 2. No WMV3/VC-1 files will play whatsoever.

For every file I get the same thing, mostly black with a few lines of green/purple junk at the top.

mesa-libGL-9.2-1.20130919.fc19.x86_64
libvdpau-0.7-1.fc19.x86_64
kernel-3.11.1-200.fc19.x86_64

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Turks PRO [Radeon HD 6570/7570] [1002:6759]


Is it possible to get the driver to stop claiming VC-1 support so that I can enjoy the H.264 acceleration until a fix is in place?
Comment 1 Christian K├Ânig 2013-09-27 18:50:32 UTC
Well known problem, only VC-1 advanced profile (as found on Blueray disks) is supported by the hardware.

*** This bug has been marked as a duplicate of bug 65611 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.