Bug 76499

Summary: udpsink fails on windows 7 (0.10 2013.6 and 1.0 1.2.3)
Product: GStreamer SDK Reporter: dudi017
Component: Windows SDK DistributionAssignee: bugs
Status: NEW --- QA Contact:
Severity: blocker    
Priority: high    
Version: 2013.6   
Hardware: Other   
OS: Windows (All)   
i915 platform: i915 features:

Description dudi017 2014-03-23 08:57:00 UTC

I am trying to output RTP stream over the network with windows 7. 

it seems that udpsink doesn't transmit not even a single packet (I tested it with Wireshark). I tried to run the pipelines on 0.10 (2013.6) and 1.0 (1.2.3) version and I got the same response.

I tried allot of combination to check if im doing something wrong, but after all of my attempts and after reading about it in the network, I found out that there is a problem with udpsink and windows. 

this is the basic pipeline I have been trying to work with: 

gst-launch-1.0  videotestsrc ! x264enc ! rtph264pay ! udpsink host= force-ipv4=true port=5000 

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Redistribute latency...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock

(the status stays on this stage and there is no packet streaming)

gst-launch-1.0 udpsrc uri=udp:// caps="application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264, payload=(int)96" ! rtpjitterbuffer latency=1000 , do-lost=true ! rtph264depay  ! avdec_h264 ! autovideosink 

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock

(the client waiting to receive stream. 

please, correct me if Im doing something wrong here, but it just refuses to work. 


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.