Bug 79862

Summary: Driver crash while playing YouTube video (flash)
Product: DRI Reporter: nucrap
Component: DRM/RadeonAssignee: Default DRI bug account <dri-devel>
Status: RESOLVED MOVED QA Contact:
Severity: normal    
Priority: medium CC: nucrap
Version: unspecified   
Hardware: Other   
OS: All   
i915 platform: i915 features:
Description Flags
crash log
possible fix none

Description nucrap 2014-06-10 02:27:15 UTC
Created attachment 100782 [details]
crash log

While watching a YouTube video (flash player) I experienced a driver crash, the monitor went black but recovered.

I attached the error log of the radeon driver.
Comment 1 nucrap 2014-06-10 02:27:54 UTC
Damn, forgot to add:
Graphics card: MSI R7 260x
Comment 2 Alex Deucher 2014-06-10 02:29:55 UTC
What GPU is this?  How are you playing back the video?  Were you using UVD?  Please attach your full dmesg output and xorg log.
Comment 3 nucrap 2014-06-10 13:24:33 UTC
Created attachment 100817 [details]
Comment 4 nucrap 2014-06-10 13:26:50 UTC
Created attachment 100818 [details]
Comment 5 nucrap 2014-06-10 13:31:17 UTC
It just happened again with the same video: http://www.youtube.com/watch?v=d-Cc6j2ZBwk in 360p, firefox.

I don't know if I use UVD, but I don't think so (I guess this would require hw accelaration through gstreamer, but I don't have the corresponding packages installed).
Comment 6 Alex Deucher 2014-06-10 13:56:58 UTC
flash plugin will use vdpau (and hence possibly UVD if you have the radeon vdpau driver installed) if you enable acceleration support in you adobe mms.cfg.
Comment 7 nucrap 2014-06-10 15:03:12 UTC
Thanks for the hint :)
The radeon vdpau driver is installed on my system but hw accelaration was of course disabled in my mms.cfg file.

I will try with UVD enabled but anyways this should be fixed.
Comment 8 Alex Deucher 2014-06-10 15:05:44 UTC
(In reply to comment #7)
> I will try with UVD enabled but anyways this should be fixed.

Right.  I just want to figure out where the issue may be (UVD or 3D).
Comment 9 nucrap 2014-06-10 18:23:47 UTC
Appears the bug is independent of UVD enabled or not.
At least with UVD enabled I have got an additional error in dmseg:

[  236.334117] radeon 0000:0b:00.0: GPU fault detected: 146 0x0ee6480c
[  236.334121] radeon 0000:0b:00.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x000010F7
[  236.334123] radeon 0000:0b:00.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x0604800C
[  236.334126] VM fault (0x0c, vmid 3) at page 4343, read from 'TC2' (0x54433200) (72)
Comment 10 nucrap 2014-06-10 20:31:51 UTC
Now this is interesting:
Only compton and compiz are affected by this bug.
I tested it with Kwin and xfwm4 with compositing enabled but it just doesn't happen. Also this bug can only be reproduced once - after that I need to restart my PC to trigger it (relogin is not enough).

Hope this was helpful.
Comment 11 Alex Deucher 2014-06-10 20:44:37 UTC
Created attachment 100841 [details] [review]
possible fix

Does this kernel patch help?
Comment 12 nucrap 2014-06-10 20:49:31 UTC
Thanks, I will try the patch!

In case somebody has my graphics card (or a HD 7790 or maybe others too??) I found a definite and easy way to reproduce it:

1. Start a lightweight DE with e.g. openbox or xfwm4 (compositing disabled)
2. Install and start "compton" from a terminal
3. Play this youtube video from firefox with flashplayer: http://www.youtube.com/watch?v=d-Cc6j2ZBwk (happens on others too, but this video is definately affected)
4. The bug should occur in less than 1:30 minutes
5. If it doesn't occur the first time just reload

This should definitely trigger the bug.
Comment 13 nucrap 2014-06-15 16:32:59 UTC
Nope, unfortunately it doesn't help :/
I also get the bug on other occasions e.g. when I leave the PC and meanwhile the  screensaver starts, I mostly find my computer in in a frozen state when I come back and need to do a hard reset. My journal is spammed by those same error messages then, until the journal log is full and stops logging...
Comment 14 nucrap 2014-07-02 11:41:52 UTC
Ok some updates:

1. I do not notice any difference with the patch or without

2. In contrary to my prior statements this bug is reproducable on any DE (even openbox) and is independent of compositing being enabled or not (although my impression is that it's easier to reproduce with compositing enabled).

3. It's independent or VDPAU.

4. It happens on any flash video, even on low quality.

5. Apart from playing flash videos the bug also happens on other (random) occasions or when the screensaver is active.

6. The system mostly successfully recovers from the crash *unless* a video is played in fullscreen (same for screensavers).

7. Out of some reason, it only happens *once* every restart. After the crash, I can successfully use my system and watch videos without any further crashes.

8. It's extremely annoying. I switched to Windows for the time being.
Comment 15 nucrap 2014-09-07 23:34:18 UTC
Ok, I think the Heading is not really correct anymore. I'm on Linux 3.16.1 now and still get this misbehaviour even without watching yt videos (maybe because of some KDE effects).

It is extremely annoying and I basically cannot use Linux productively. In fact I am not even sure if this is a software issue. I also got some Problems on Windows with this card even though this is already my second one (from RMA).

And I am not the only one having issues. In fact, everybody using OC versions of the R7 260x has severe issues. It's a shame. The first company so far solving it was ASUS: They updated the firmware and it appears they just reduced the GPU clock and voltages.
Also see http://vip.asus.com/forum/view.aspx?id=20140427164821450&board_id=9&model=R7260X-DC2OC-2GD5&page=1&SLanguage=en-us
Sapphire also updated their firmware. MSI appears to don't care.

I don't know if this is related, but considering the poor state even on Windows, one never knows...
Comment 16 Martin Peres 2019-11-19 08:50:34 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/504.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.