Bug 80506

Summary: Video failed on resume from suspend - G94 / GeForce 9600 GT, 10de:0622 , kernel 3.16 rc2
Product: xorg Reporter: Adam Williamson <adamw>
Component: Driver/nouveauAssignee: Nouveau Project <nouveau>
Status: RESOLVED FIXED QA Contact: Xorg Project Team <xorg-team>
Severity: major    
Priority: medium CC: pierre.morrow, sirdeiu
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: All   
i915 platform: i915 features:
Description Flags
journalctl from a 3.16 rc2 boot that reproduces the issue
drm.debug=14 log: boot at 18:01, suspend at 18:02, resume at 18:03 none

Description Adam Williamson 2014-06-25 00:38:49 UTC
Created attachment 101708 [details]
journalctl from a 3.16 rc2 boot that reproduces the issue

This is kind of a follow-up to https://bugs.freedesktop.org/show_bug.cgi?id=77599 , but the behaviour seems different now and we're on kernel 3.16, so I figured we'd best start from scratch.

With kernel 3.16 rc2, resuming from suspend on my GeForce 9600 GT (10de:0622) *always* seems to fail. Screens never come out of power-saving mode, can't ssh in. This differs from 3.15, where it sometimes succeeded and sometimes failed, and never seemed to fail if I just booted, quickly suspended, and quickly resumed - with 3.16 rc2, doing that causes it to fail every time.

I'll attach journalctl with drm.debug=15 from a boot where I booted to gdm, suspended, resumed, left the system sitting for a while, then forcibly rebooted.

This is on Fedora Rawhide, with:

Comment 1 Adam Williamson 2014-06-25 00:40:44 UTC
note - suspend was almost 100% reliable with 3.14 (and back through pretty much the whole 3.x series), then partly worked in 3.15, so this is a two-release regression: 3.15 worse than 3.14, 3.16 worse than 3.15 :/
Comment 2 Adam Williamson 2014-06-25 01:19:08 UTC
Created attachment 101709 [details]
drm.debug=14 log: boot at 18:01, suspend at 18:02, resume at 18:03

Ben asked for a drm.debug=14 log (apparently 15 is too noisy), so here you go. Boot is at 18:01, suspend is at 18:02, resume is at 18:03 (obviously some early post-resume messages may be mis-timestamped, those were the actual real-world times when I pushed the buttons.)
Comment 3 Adam Williamson 2014-07-21 23:11:02 UTC
any news on this? my desktop is currently contributing heavily to climate change ;)
Comment 4 Andrei Amuraritei 2014-08-19 17:02:26 UTC
Hello, I'm getting this also with an NVIDIA GTX 570 - NVC8 GF110 card with kernel 3.16.0-1-desktop on openSUSE Factory on x86_64.

Suspend works ok. Resume doesn't. Screen blank. If press Ctrl Alt F2 and then Ctrl Alt Del PC does reboot.

I've tried with NVIDIA pro. driver 320.24 and beta 343.13, those work OK.
Comment 5 Adam Williamson 2014-09-15 16:16:57 UTC
This could very well be https://bugs.freedesktop.org/show_bug.cgi?id=83550 (thanks to Hjulle for the bisect). Both my monitors are connected by DVI-D.
Comment 6 Ilia Mirkin 2015-10-22 07:48:28 UTC
Adam, are you still seeing this? Testers of the other bug seemed to be happy with the current state of things.
Comment 7 Adam Williamson 2015-10-22 15:04:02 UTC
no, it's fine now.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.