Bug 83992

Summary: [NVE0][NVF1] regression, linux 3.17 causes gpu lockups
Product: xorg Reporter: Tom Englund <tomenglund26>
Component: Driver/nouveauAssignee: Nouveau Project <nouveau>
Status: RESOLVED FIXED QA Contact: Xorg Project Team <xorg-team>
Severity: critical    
Priority: medium CC: david
Version: gitKeywords: bisected
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
i915 platform: i915 features:
Description Flags
dmesg of cs:go lockup
dmesg of x lockup
patch for lockups. none

Description Tom Englund 2014-09-17 13:06:33 UTC
Created attachment 106428 [details]
dmesg of cs:go lockup

im getting a regression with 3.17 gpu lockups instantly i launch wine/cs:go and at random times with just normal X usage. i bisected the kernel twice and ended up on same commit http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f331a15f84a94dce6f12cf0b7012174b4a6bf804 

this is on a 780ti.

attaching dmesg of wine/csgo lockup on 3.17-rc5 and X lockup with the bisected kernel at that commit.
Comment 1 Tom Englund 2014-09-17 13:07:33 UTC
Created attachment 106429 [details]
dmesg of x lockup
Comment 2 Tom Englund 2014-09-17 13:58:37 UTC
however reverting e887377338f and 67cfbfdfec9fa so f331a15f84a cleanly reverts i still get the X lockups
Comment 3 Tom Englund 2014-09-17 15:47:42 UTC
checking out a2d58c33a doesnt make X nor cs:go lockup however it artifacts badly, and spams dmesg with this https://gist.github.com/anonymous/f53c93768a9ba1ca0ee0 .

tried setting drivers/gpu/drm/nouveau/core/engine/graph/ctxgk110b.c bundle_token_limit to 0x7c0 instead of 0x600 but no dice.

screenshot of it artifacting http://i.imgur.com/HLb8I6t.png and the artifacts isnt contained to cs:go they go out on X aswell as you can see on dropbox systray icon and garbles some text everywhere.
Comment 4 Ben Skeggs 2014-09-17 23:03:55 UTC
What's the last commit where everything works properly?  We should start from there.

You mention you still get X lockups even after reverting f331a?
Comment 5 Tom Englund 2014-09-19 17:43:32 UTC
(In reply to comment #4)
> What's the last commit where everything works properly?  We should start
> from there.
> You mention you still get X lockups even after reverting f331a?

yea that is the weird thing reverting those 3 commits it still lockups but going cleanly to its parent it only artifacts, after some bisecting the first bad commit with artifacts is 694c6caf92615828dbfd3fc30e937c8f54d2ac93 , so the first commit where everything works is ac9738bb3e5374495908ad236285f69cfd405f8e
Comment 6 Tom Englund 2015-01-12 16:43:05 UTC
seems to be working now with kernel 3.18.2
Comment 7 Tom Englund 2015-01-18 05:27:33 UTC
Created attachment 112412 [details] [review]
patch for lockups.

thanks to xexaxo from #d3d9 on freenode.
Comment 8 Tom Englund 2015-04-26 02:09:55 UTC
fixed in linux 4.0 , https://github.com/torvalds/linux/commit/404ba3f79089a01c1ebacccafa08a5db4a4cd2af

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.