Bug 85916

Summary: 0408:3003 [Packard Bell oneTwo (PW.U6C)] Touch-screen used to work 2011 but no longer works since 2012
Product: xorg Reporter: Paddy Landau <paddy>
Component: Input/evdevAssignee: Peter Hutterer <peter.hutterer>
Status: RESOLVED MOVED QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium CC: paddy, peter.hutterer
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Paddy Landau 2014-11-05 12:29:12 UTC
This was originally reported for Ubuntu, but apparently it is a regression in the Linux kernel:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/998546

My touch-screen, Quanta Computer OpticalTouchScreen, used to work on Ubuntu 11.04. It has since stopped working.

As far as I can tell, kernel 3.15 worked and kernel 3.4 onwards did not (see previous link for relevant comments).

Monitor: 0408:3003 Quanta Computer Inc.

Tested on Ubuntu versions 11.04, 12.04, 14.04 (currently on kernel 3.13.0-39).

I am not technical, so please either ask what extra information you need from me or refer to the previous link.
Comment 1 Peter Hutterer 2014-11-06 00:07:31 UTC
If it's a kernel bug, please file it with the kernel. This is the bugzilla for the xorg evdev driver, if replacing the kernel makes the device work again the bug is unlikely to be in the evdev driver.

Can you confirm: did it work with kernel 3.15 and kernels since? If so, then Ubuntu needs to backport the matching patches.
Comment 2 Paddy Landau 2014-11-06 13:16:49 UTC
@Peter Hutterer: Thanks for the comment. I posted to this place because I was advised to do so; being non-technical, I don't understand completely what I'm doing :(

It worked on kernels 3.15 and earlier, but not on 3.4 and later.

Can you tell me how to file this with the kernel, please?
Comment 3 Peter Hutterer 2014-11-06 21:41:09 UTC
fwiw, version numbers aren't decimal numbers, they are two or more separate digits. So you get 3.4, 3.5, .... 3.9, 3.10, 3.11, ... and 3.15 which is the newest of the bunch. development cycle at the time of writing this comment is for the 3.18 kernel. Main takeaway: 3.15 is newer than 3.4 by 9 versions.

What this means is that if the device doesn't work on 3.4 but does works on 3.15 then it has been fixed since. If it doesn't work on 3.13 then the fix was in 3.14 or 3.15.

That aside, can you please define "has stopped working" in more detail? in the launchpad bug there is talk of gestures stopping, does yours not work at all?
Comment 4 GitLab Migration User 2018-08-10 20:54:13 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-input-evdev/issues/5.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.