Bug 88967

Summary: Black textures Radeon m HD 5650
Product: Mesa Reporter: Grimdoll <worm-jim>
Component: OtherAssignee: mesa-dev
Status: RESOLVED NOTABUG QA Contact: mesa-dev
Severity: normal    
Priority: medium CC: b.bellec
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
i915 platform: i915 features:
Attachments: Rangers with xorg driver

Description Grimdoll 2015-02-04 15:42:30 UTC
After installing Linux Mint KDE 17.1 automatically was used xorg driver and textures in games such as X3 Terran Conflict, Star Conflict is black.
With proprietary driver fglrx 2:13.350.1-0ubuntu2 textures looks fine, but shockwave flash works bad (freezes and other).
Current version of xorg driver is 1:7.5.99+git1501140731.c80ea1~gd~t.
My videocard is ATI Radeon mobility HD 5650.
I don't know what to do.
If I need to attach something, please discribe how to do it, thanks.
Comment 1 Sven Arvidsson 2015-02-04 18:17:53 UTC
Sounds like you might need to install libtxc-dxtn0 for S3TC support.

See http://dri.freedesktop.org/wiki/S3TC/
Comment 2 Grimdoll 2015-02-04 19:33:46 UTC
My system already have latest libtxc-dxtn-s2tc0
Comment 3 Grimdoll 2015-02-04 19:40:53 UTC
When I launching X3TC game through console, after appearing of game menu, in console I just see something like "can not to load texture, using dummy... can not load dummy..." and this message repeating infinitely.
Comment 4 Benjamin Bellec 2015-02-04 19:54:50 UTC
I guess X3TC is a 32-bit game. Do you have the libtxc-dxtn-s2tc0 32-bit version, and not only the 64-bit one ?

Also, what give this command:
$ glxinfo |grep "GL_EXT_texture_compression_s3tc"
Comment 5 Grimdoll 2015-02-04 20:37:31 UTC
How to check version of libtxc-dxtn-s2tc0 ?
grimdoll@grimdoll-Aspire-5740:~ > glxinfo |grep "GL_EXT_texture_compression_s3tc"
    GL_EXT_texture_compression_rgtc, GL_EXT_texture_compression_s3tc, 
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map, 
And I have no idea, what does it mean, sorry, but thanks for help.
Comment 6 Grimdoll 2015-02-04 20:42:40 UTC
I would like to show what's happening in console while I'm running Star Conflict, but this game runs through steam, and don't show any usefull info in console, just only about steam.
Comment 7 Benjamin Bellec 2015-02-04 21:21:08 UTC
How did you install the s2tc lib ?
Comment 8 Grimdoll 2015-02-04 21:32:08 UTC
To be honest, I do not know. I try so many guides to install xorg drivers, to install proprietary drivers. May be it was installed during installation of Linux Mint.
Comment 9 Benjamin Bellec 2015-02-04 21:44:18 UTC
Could you tell us what reports these commands :
$ file /usr/lib32/libtxc_dxtn.so
$ file /usr/lib/libtxc_dxtn.so
$ file /usr/local/lib32/libtxc_dxtn.so
$ file /usr/local/lib/libtxc_dxtn.so

And also :
$ glxinfo |grep "OpenGL core profile version string"
Comment 10 Grimdoll 2015-02-04 21:58:01 UTC
"ERROR: cannot open `/usr/lib/libtxc_dxtn.so' (No such file or directory)" for all of those commands
grimdoll@grimdoll-Aspire-5740:~ > glxinfo |grep "OpenGL core profile version string"
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.5.0-devel (git-6fd4a61 2015-02-04 trusty-oibaf-ppa)
Comment 11 Benjamin Bellec 2015-02-04 22:08:27 UTC
I should have ask you this instead :
$ whereis libtxc_dxtn.so
Comment 12 Grimdoll 2015-02-04 22:28:31 UTC
grimdoll@grimdoll-Aspire-5740:~ > whereis libtxc_dxtn.so

I dont understand, what wrong with it =)
Comment 13 Michel Dänzer 2015-02-05 00:55:26 UTC
What does this say:

locate libtxc_dxtn.so | xargs file

Or, you can just try

sudo apt-get install libtxc-dxtn0:i386

which should either install the 32-bit version of the library or tell you that it's already installed.
Comment 14 Grimdoll 2015-02-05 07:56:16 UTC
Ok, thanks, now I installed it and:
grimdoll@grimdoll-Aspire-5740:~ > locate libtxc_dxtn.so | xargs file
/usr/lib/x86_64-linux-gnu/libtxc_dxtn.so: symbolic link to `/etc/alternatives/libtxc-dxtn-x86_64-linux-gnu'
Comment 15 Grimdoll 2015-02-05 08:04:30 UTC
Thank you all very much, it solved my problem, I will write down this command for the future.
Comment 16 Grimdoll 2015-02-05 09:17:15 UTC
Created attachment 113190 [details]
Rangers with xorg driver

Can someone tell what is wrong with it? With proprietary driver all works fine.
Comment 17 Pavel Ondračka 2015-02-05 10:24:20 UTC
(In reply to Grimdoll from comment #16)
> Created attachment 113190 [details]
> Rangers with xorg driver
> Can someone tell what is wrong with it? With proprietary driver all works
> fine.

There are some failing shaders in the log, this might have been fixed by some register spilling work in the llvm, you may try to get a never llvm and mesa from some ppa (dunno how that works on Mint), or compile them yourself.

Also I'll give you few hints how to write better bug reports so people can help you more ;-)

1) One problem per bug, e.g. don't recycle old bug reports for new problems as you did in comment 16, open a new bug.

2) For 3D stuff such as games, the most important component isn't the xorg driver, but the mesa (3D driver), llvm (for Radeons) and kernel. It is important to always post which version of those components you have installed.

3) Always describe exact steps how to reproduce the issue. This means full name of the program, version, download links if available so people can reproduce it and help you. 

3) Posting screenshot is also a good idea. Another interesting info is output of glxinfo (this shows your mesa and opengl version and extensions), dmesg (kernel output), but usually developers can ask for those. 

4) If your versions of mesa, llvm or kernel is lower than latest versions, it is possible that your problem was already fixed in the latest version (which also may be the case in this bug). In that case try to get latest version via your distro or some ppa or compile it by yourself and test it before filling a bug. This could save developers a lot of time, by not having to look at already fixed issues. 

Sidenote: also pay extra attention to the 32bit vs 64 bit stuff, 32 bit programs (most Steam games and closed source games) need 32bit mesa, libdrm, llvm, libtxc-dxtn etc... so always double check that you indeed have the right components installed or that you upgraded the right ones.
Comment 18 Pavel Ondračka 2015-02-05 10:35:34 UTC
Ah, sorry about the llvm confusion, I didn't realize its r600, so it doesn't need llvm for graphics.
Comment 19 Grimdoll 2015-02-05 11:00:06 UTC
1) It is true, but this thread have some info about my system, and peopole no need to ask it twice. And I though that second bug had relation to first one.
2) All asked info about system is in this thread
3) Name of the game is Space Rangers HD - A War Apart, launching with wine 1.7.34,
with proprietary drivers fglrx 2:13.350.1-0ubuntu2 no issues with this game. Steps: Launching game, start planetary battle. I see blinking screen between normal grafic and black screen repeating infinitely. Info about this process in console.
4) I don't know, have I latest versions of libs or not, I just install it by:
sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get dist-upgrade
Comment 20 Grimdoll 2015-02-05 15:14:09 UTC
Created attachment 113203 [details]
Comment 21 Grimdoll 2015-02-05 15:14:33 UTC
Created attachment 113204 [details]
Comment 22 Grimdoll 2015-02-05 16:55:06 UTC
So what component I need to check for Gallium r600?
Comment 23 Sven Arvidsson 2015-02-06 16:47:22 UTC
So, a few things you could try:

The bug could be in Wine (different drivers can lead to different behaviour), the game (Mesa sometimes follows the OpenGL spec better than other drivers and exposes bugs in apps) or in the driver.

You could try different options in Wine and in the game to see if it changes the behaviour.

You seem to be using a snapshot of Mesa, you could try the latest stable version to rule out a regression.

Ask others who play the same game using Mesa drivers if they have the same problem (even better if they use another driver, noveau or i965)

Lastly, you could use the apitrace tool to create a trace of the game and upload it somewhere and link it to the bug report.
Comment 24 Grimdoll 2015-02-06 17:19:44 UTC
1) This game works with option d3dx9 libs setted as native, with builtin it would not work at all;
2) I don't know how to use stable mesa, I tried to revert to standard Ubuntu drivers by:
$ sudo apt-get install ppa-purge
$ sudo ppa-purge ppa:oibaf/graphics-drivers
But it didn't help. Drivers remain the same;
3) I have no friends with Linux;
4) Please describe how to use apitrace.
Comment 25 Timothy Arceri 2018-03-07 09:39:32 UTC

The first issue was missing libtxc-dxtn-s2tc0 which will never be a problem again \o/. Then the user started posting about a completely different game, which could have been a wine bug. Please open new bug reports for different problems.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.