Bug 90390

Summary: [NV98] Modesetting causes blank screen because of INVALID_STATE [UNK0B] chid 1 mthd 0x0080 data 0x00000000
Product: xorg Reporter: Dmitry Potapov <analizer>
Component: Driver/nouveauAssignee: Nouveau Project <nouveau>
Status: NEW --- QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
kernel log
none
vbios.rom gathered using nvagetbios
none
kernel config
none
kernel log for 3.14.41-gentoo none

Description Dmitry Potapov 2015-05-10 19:53:30 UTC
Environment:
Video card: GeForce 9300M GS (laptop)
Kernel: 4.0.2-gentoo

Steps to reproduce:
1. Boot
2. modprobe drm_kms_heloper
3. modprobe nouveau

Expected result:
Framebuffer initialization
Actually after dozen attempts I had framebuffer initialized once, background was red, foreground was black and I never was able to achieve this again.

Actual result:
Blank screen. Still able to process keyboard input, so kernel log can be gathered and system can be safely rebooted.

Results with various parameters:
With `nouveau.noaccel=1` I'm getting black screen instead of blank screen and system is not responsive to keyboard input.
With `nouveau.modeset=0` nothing happens after `modprobe nouveau`, this makes me think this is a modesetting issue.
Comment 1 Dmitry Potapov 2015-05-10 19:54:06 UTC
Created attachment 115668 [details]
kernel log
Comment 2 Dmitry Potapov 2015-05-10 19:54:32 UTC
Created attachment 115669 [details]
vbios.rom gathered using nvagetbios
Comment 3 Dmitry Potapov 2015-05-10 19:54:51 UTC
Created attachment 115670 [details]
kernel config
Comment 4 Ilia Mirkin 2015-05-10 19:58:24 UTC
FYI, modeset=0 == disable nouveau entirely, so it makes sense that you don't get any issues.

Looks like PDISP hangs almost immediately on initialization. Another user was able to bisect to a specific commit that came into 3.16, but on fairly different hardware (bug 90276). Is this a new issue, if so what was the last known working kernel?
Comment 5 Dmitry Potapov 2015-05-10 20:14:19 UTC
Unfortunately nouveau never worked for me.
I've tried to migrate to nouveau from nvidia proprietary drivers earlier on 3.16 and 3.18 kernels and probably on older kernels, and the result was the same: blank screen (not sure, probably is was a black screen)
Comment 6 Dmitry Potapov 2015-05-10 21:14:51 UTC
Created attachment 115671 [details]
kernel log for 3.14.41-gentoo

Checked against kernel 3.14.41
Symptoms are same, but the error message is a bit different although I used the same drm.debug=15

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.