Bug 92420

Summary: X crash when with 2nd display connected via Display Port
Product: xorg Reporter: J <rhbugzilla>
Component: Driver/nouveauAssignee: Nouveau Project <nouveau>
Status: NEW --- QA Contact: Xorg Project Team <xorg-team>
Severity: critical    
Priority: medium    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
dmesg.display_port_problem.4.2.3-300.fc23.x86_64
none
vbios.rom none

Description J 2015-10-10 22:46:16 UTC
Created attachment 118807 [details]
dmesg.display_port_problem.4.2.3-300.fc23.x86_64

I get a flood of kernel events from nouveau when connecting and disconnecting my 2nd display via the display port cable.

Events start with this:

nouveau E[   PDISP][0000:01:00.0] INVALID_VALUE [UNK84] chid 0 mthd 0x0700 data 0x00052002


modinfo nouveau -n
/lib/modules/4.2.3-300.fc23.x86_64/kernel/drivers/gpu/drm/nouveau/nouveau.ko.xz

lspci -v | grep -i vga
01:00.0 VGA compatible controller: NVIDIA Corporation G92GLM [Quadro FX 2800M] (rev a2) (prog-if 00 [VGA controller])

Errors come and go with connection/disconnection of the Display Port cable.  So long as I stay running in init 3, the primary laptop LCD continues to function.  Once I go init 5, X appears to start, and then just hangs.

I've attached dmesg output for boot-up, when I connect the display port, and when I disconnect the display port.

Please let me know if I can help in any way.
Comment 1 J 2015-10-10 22:47:49 UTC
I should also add - I do not have this problem when running CentOS 7 - 3.10
Comment 2 Ilia Mirkin 2015-10-10 22:53:29 UTC
Please attach your VBIOS as well (you can retrieve it from /sys/kernel/debug/dri/0/vbios.rom )
Comment 3 J 2015-10-10 23:08:30 UTC
Created attachment 118808 [details]
vbios.rom

vbios.rom as requested.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.