Bug 94103

Summary: [i915] External monitors lose connection after suspend, or don't return from sleep
Product: DRI Reporter: Derek Yerger <dy>
Component: DRM/IntelAssignee: Dhinakaran Pandiyan <dhinakaran.pandiyan>
Status: CLOSED WORKSFORME QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: normal    
Priority: medium CC: dy, intel-gfx-bugs
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
i915 platform: HSW i915 features: display/DP, display/HDMI, power/suspend-resume
Description Flags
xorg crashing on intel-drm-nightly, dmesg
xorg crashing on intel-drm-nightly, xorg none

Description Derek Yerger 2016-02-11 21:09:07 UTC
Created attachment 121690 [details]

This is on a Dell XPS 9333 (Haswell) with a mini-displayport to dual HDMI hub.

Linux version 4.5.0-040500rc3-generic (kernel@gomeisa) (gcc version 5.2.1 20151010 (Ubuntu 5.2.1-22ubuntu2) ) #201602071930 SMP Mon Feb 8 00:34:43 UTC 2016
Distro: Ubuntu 15.10
Also affects mainline Ubuntu kernel 4.2.0-27-generic.

When entering display standby (either by timeout or xset dpms force off) , one of three things happens:
1) After 30s, the monitors come back on by themselves, one monitor goes to low-resolution or is disabled.

or, 2) Monitor configuration stays the same, but on resume, the two externals fail to resume from standby state. Note that xrandr reports the same configuration as before, and the mouse can be moved to the (still blank) monitors.

or, 3) Resume from standby within 10 seconds and the issue doesn't occur.

The workaround is to unplug/replug the mini-DP. Sometimes this results in hang or X restarting.

Additionally, one of the monitors occasionally (~30 minutes) blanks for a half-second, and comes back.

This issue occurs regardless of one or two monitors on the hub, or two entirely different monitors. It didn't occur with a non-MST, single miniDP to HDMI.

I have tested the hub with another XPS 9333 running windows, and the issue doesn't occur.

Attached logs: short - for case (3) above
longresume-blanked - for case (2) above
what was left of the system log - freeze
all with drm.debug=14 switch

I'll test with drm-intel-nightly again in a few.
Comment 1 Derek Yerger 2016-02-11 21:10:16 UTC
Created attachment 121691 [details]
Comment 2 Derek Yerger 2016-02-11 21:10:47 UTC
Created attachment 121693 [details]
Comment 3 Derek Yerger 2016-02-11 21:40:34 UTC
The latest drm-intel-nightly as provided from http://kernel.ubuntu.com/ results in a segfault. This is regardless of the external monitor. Attached is an Xorg log, followed by dmesg after this occurs.
Comment 4 Derek Yerger 2016-02-11 21:41:54 UTC
Created attachment 121694 [details]
xorg crashing on intel-drm-nightly, dmesg

Linux version 4.5.0-994-generic (kernel@tangerine) (gcc version 5.2.1 20151010 (Ubuntu 5.2.1-22ubuntu2) ) #201602102100 SMP Thu Feb 11 02:02:36 UTC 2016
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.5.0-994-generic root=UUID=9f068afb-074c-4838-b5be-f3a75fef7999 ro persistent quiet splash vt.handoff=7 drm.debug=14
Comment 5 Derek Yerger 2016-02-11 21:42:14 UTC
Created attachment 121695 [details]
xorg crashing on intel-drm-nightly, xorg
Comment 6 Dhinakaran Pandiyan 2016-06-29 05:06:35 UTC
Thanks for reporting the bug.

Can you try the latest drm-intel-nightly kernel? 

I tried suspending to memory with a dual DP MST hub connected to one display, the display came up as expected set to the right resolution.
Comment 7 Derek Yerger 2016-07-07 23:01:38 UTC
I tried the latest nightly:


a display suspend came back with the same issue (both external monitors off but appear on to the OS).

Running `xrandr` froze the system.

The behavior also occurs with one monitor only.

Since filing this bug report I have also tried different HDMI cables as well. I'm going to buy another hub of the same make to confirm it isn't the hardware (mind that windows OS was able to use this device fine)
Comment 8 Dhinakaran Pandiyan 2016-11-08 00:43:52 UTC
We have had some MST fixes that have gone in since July.

Can you try the latest drm-intel-nightly @ git://anongit.freedesktop.org/drm-intel?

If that doesn't fix, can you try this patch - https://patchwork.freedesktop.org/patch/120259/ ?
Comment 9 Dhinakaran Pandiyan 2017-01-04 00:10:43 UTC
Please create a new bug if the issue can still be reproduced.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.