Bug 9458

Summary: Firefox autoscroll graphics => garbage
Product: xorg Reporter: Michael Monreal <michael.monreal+bugs>
Component: App/compizAssignee: David Reveman <reveman>
Status: RESOLVED DUPLICATE QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: high CC: aplattner
Version: 7.2 (2007.02)   
Hardware: x86 (IA32)   
OS: Linux (All)   
i915 platform: i915 features:
Description Flags
Screenshot none

Description Michael Monreal 2006-12-27 03:06:04 UTC
First off, I'm running xorg 7.2 from Ubuntu Edgy and latest compiz from git.

Problem: when I use autoscroll in Firefox (has to be activated in preferences,
then press the wheel button and move mouse up/down) the autoscroll graphic is
duplicated all over again and not "cleared" from the screen.

I'll attach a screenshot to illustrate the problem.
Comment 1 Michael Monreal 2006-12-27 03:07:20 UTC
Created attachment 8225 [details]

This is how the webpage (compiz forums) looks like after scrolling up and down.
Comment 2 Daniel Stone 2007-02-27 01:35:20 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 3 Aaron Plattner 2007-05-03 09:02:29 UTC

*** This bug has been marked as a duplicate of bug 8871 ***
Comment 4 Aaron Plattner 2007-05-03 12:29:44 UTC
You said in bug 8871 that you "cannot reproduce the bug reported here, but I still get the autoscroll garbage I originally reported (tested with latest git compiz)."  Which server version did you test with?
Comment 5 Michael Monreal 2007-05-03 13:42:09 UTC
I'm running Xorg 7.2, the one shipping with Ubuntu Feisty (Version: -ubuntu11)
Using the NVidia (beta?) binary driver 100.14.03 though... but I ran various stable versions before that, and I noticed this bug ever since I occationally used Compiz (which is for a year now).

I should note that the bug reported here does not occur on every webpage. It happens on this bugzilla page for example.
Comment 6 Aaron Plattner 2007-05-03 14:02:29 UTC
The change that I suspect fixed this was to the server in the master branch.  I wouldn't expect it to work on xorg 7.2.

Comment 7 Michael Monreal 2007-05-03 15:14:44 UTC
Awww... didn't notice the other bug was an xorg bug, I thought you were refering to a change in compiz.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.