Bug 95046

Summary: Vulkan fails to build with Wayland errors
Product: Mesa Reporter: Nanley Chery <nanleychery>
Component: Drivers/Vulkan/intelAssignee: Nanley Chery <nanleychery>
Status: CLOSED NOTABUG QA Contact:
Severity: normal    
Priority: medium    
Version: git   
Hardware: Other   
OS: All   
URL: https://www.allassignmenthelp.com/us/
Whiteboard:
i915 platform: i915 features:

Description Nanley Chery 2016-04-21 00:03:05 UTC
With commit 3caf2e89aa1711e80db80d2056e0a44663d9c7d2
 anv: fix build without Wayland platform 

I can no longer build Mesa. I get the following error output:

  CC       libvulkan_intel_la-anv_allocator.lo
In file included from anv_private.h:60:0,
                 from anv_allocator.c:37:
anv_entrypoints.h:164:73: error: unknown type name ‘VkWaylandSurfaceCreateInfoKHR’
          VkResult (*CreateWaylandSurfaceKHR)(VkInstance instance, const VkWaylandSurfaceCreateInfoKHR* pCreateInfo, const VkAllocationCallbacks* pAllocator, VkSurfaceKHR* pSurface);
                                                                         ^
anv_entrypoints.h:1120:65: error: unknown type name ‘VkWaylandSurfaceCreateInfoKHR’
 VkResult anv_CreateWaylandSurfaceKHR(VkInstance instance, const VkWaylandSurfaceCreateInfoKHR* pCreateInfo, const VkAllocationCallbacks* pAllocator, VkSurfaceKHR* pSurface);
                                                                 ^
anv_entrypoints.h:1121:66: error: unknown type name ‘VkWaylandSurfaceCreateInfoKHR’
 VkResult gen7_CreateWaylandSurfaceKHR(VkInstance instance, const VkWaylandSurfaceCreateInfoKHR* pCreateInfo, const VkAllocationCallbacks* pAllocator, VkSurfaceKHR* pSurface);
                                                                  ^
anv_entrypoints.h:1122:67: error: unknown type name ‘VkWaylandSurfaceCreateInfoKHR’
 VkResult gen75_CreateWaylandSurfaceKHR(VkInstance instance, const VkWaylandSurfaceCreateInfoKHR* pCreateInfo, const VkAllocationCallbacks* pAllocator, VkSurfaceKHR* pSurface);
                                                                   ^
anv_entrypoints.h:1123:66: error: unknown type name ‘VkWaylandSurfaceCreateInfoKHR’
 VkResult gen8_CreateWaylandSurfaceKHR(VkInstance instance, const VkWaylandSurfaceCreateInfoKHR* pCreateInfo, const VkAllocationCallbacks* pAllocator, VkSurfaceKHR* pSurface);
                                                                  ^
anv_entrypoints.h:1124:66: error: unknown type name ‘VkWaylandSurfaceCreateInfoKHR’
 VkResult gen9_CreateWaylandSurfaceKHR(VkInstance instance, const VkWaylandSurfaceCreateInfoKHR* pCreateInfo, const VkAllocationCallbacks* pAllocator, VkSurfaceKHR* pSurface);
                                                                  ^
anv_entrypoints.h:1125:74: error: unknown type name ‘VkWaylandSurfaceCreateInfoKHR’
 VkResult anv_validate_CreateWaylandSurfaceKHR(VkInstance instance, const VkWaylandSurfaceCreateInfoKHR* pCreateInfo, const VkAllocationCallbacks* pAllocator, VkSurfaceKHR* pSurface);
                                                                          ^
Makefile:1401: recipe for target 'libvulkan_intel_la-anv_allocator.lo' failed
make[5]: *** [libvulkan_intel_la-anv_allocator.lo] Error 1
make[5]: Leaving directory '/home/nchery/repos/fdo/mesa/src/intel/vulkan'
Makefile:1658: recipe for target 'all-recursive' failed
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory '/home/nchery/repos/fdo/mesa/src/intel/vulkan'
Makefile:838: recipe for target 'all' failed
make[3]: *** [all] Error 2
make[3]: Leaving directory '/home/nchery/repos/fdo/mesa/src/intel/vulkan'
Makefile:550: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/nchery/repos/fdo/mesa/src/intel'
Makefile:690: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/nchery/repos/fdo/mesa/src'
Makefile:639: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1
Comment 1 Nanley Chery 2016-04-25 19:46:23 UTC
This problem was fixed after deleting anv_entrypoints.{c,h} and re-running make. It is unfortunately not reproducible.
Comment 2 JeanetteSchmeler 2019-07-18 07:14:25 UTC
That was the most intimidating and irritating bug for me. I contacted some professionals of relevant field to remove that bug and https://www.bestaustralianessays.com/ was them who cleared that bug from my device and made me happy.
Comment 3 shawn kemp 2019-07-23 08:07:31 UTC
I clearly stumbled upon your weblog and favored to mention that I’ve truely loved reading your blog posts. anyhow I’ll be subscribing in your feed and that i wish you submit https://www.topcelebrityjackets.com/ryan-gosling-blade-runner-2-long-leather-fur-coat once more quickly. Please keeps it top posting! thanks you a lot, I recognize your work.
Comment 4 ThomasRayner 2019-08-01 11:26:12 UTC
I have recently tried this on a clean introduce and saw a similar issue. I have never gathered my examples with Wayland, and it appears those xdg header documents were put into an off-base catalog. I changed the CMake files to place them into the real form catalog, and with that change, it's working! http://www.essayempire.co.uk/custom-essay-writing-service
Comment 5 Ali Hassan 2019-08-20 09:31:29 UTC
I have recently tried this on a clean introduce and saw a similar issue. I have never gathered my examples with Wayland, and it appears those xdg header documents were put into an off-base catalog. I changed the CMake files to place them into the real form catalog, and with that change
https://americasuits.com/guardians-of-the-galaxy-2-chris-pratt-jacket
Comment 6 susanrichard 2019-08-23 07:35:42 UTC
I hope this is just begin of your writing. If you want you can check my blog as well. Of course if you want. You have done a great job on this article. It’s very readable and highly intelligent. You have even managed to make it understandable and easy https://www.assignmenthelperuk.co.uk to read. You have some real writing talent. Thank you.
Comment 7 Brink-Bøgh 2019-08-29 08:20:59 UTC
Yes, Vulkan usually doesn’t fulfill your demand even after taking a lot of money from us. I think DirectX is very better than Vulkan because https://bbmlive.com/strategies-make-studying-fun-and-fast/ is smooth in working, never crashes and is affordable as well.
Comment 8 Kaitlyn 2019-09-14 09:29:03 UTC
I have read the bug report you have shared here http://ovaldiamondrings.com/cushion-cut-diamonds/a-buying-guide-for-cushion-diamond-rings/ . Even though I am not that good in this field the information you have provided here was so simple. I got an idea about the Vulkan bug shared here. Thanks.
Comment 9 Patricia Sperry 2019-10-11 13:18:55 UTC
I have also found this bug and it fails in configuring the software. I have found this bug in my website https://leatherchase.com/ . I am using ubuntu version 18.10. There is also not a solution available using wayland protocol package.
Comment 10 Adam Thomas 2019-10-14 06:50:11 UTC
AllAssignmentHelp.com is an online hub where Schoolboys help us create assignments for all subjects with the help of our experts. You will get 100% plagiarism free assignment. Expert counseling is also available for students. If they have any questions, they can contact our experts anytime.
Click https://www.allassignmenthelp.com/us/
Comment 11 john smith 2019-10-15 12:06:09 UTC
Hello, I have browsed most of your posts. This post is probably where I got the most useful information for my research. https://www.theacademicpapers.co.uk/dissertation-writing-services-uk.php

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.