Bug 9620

Summary: Windows disappear when window-shade goes the wrong way
Product: xorg Reporter: kronheim
Component: App/compizAssignee: David Reveman <reveman>
Status: RESOLVED WORKSFORME QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: high    
Version: 7.1 (2006.05)   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description kronheim 2007-01-11 13:31:03 UTC
Not sure if this is by design, but when "shading" and "unshading" windows (by
double-clicking the title bar), sometimes the bottom of the window rises up,
sometimes the top of the window rolls down, and sometimes both happen so they
meet in the middle.

A particular problem occurs with windows whose bottom edge is below the bottom
of the screen. Double-click the title bar, and sometimes the top of the window
rolls down to where the bottom is: so the entire shaded window is now invisible
and off screen. At this point, the window is also not represented in the task
bar, but it can be recovered by using the switcher to bring the window to focus
(still invisible) and then maximising it using a keyboard shortcut.
Comment 1 Daniel Stone 2007-02-27 01:35:38 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 2 Kristian LyngstĂžl 2009-02-03 12:39:30 UTC
Can't reproduce this in 2009 master. Please reopen at bugs.opencompositing.org if this isn't fixed for you in recent compiz versions.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.