Bug 98987

Summary: [RS690] BUG: soft lockup when radeon modesetting
Product: DRI Reporter: Václav Ovsík <vaclav.ovsik>
Component: DRM/RadeonAssignee: Default DRI bug account <dri-devel>
Status: NEW --- QA Contact:
Severity: critical    
Priority: high CC: carnil, vedran
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
logged using netconsole - 4.8.7 - NULL pointer
none
logged using netconsole - 4.8.7 - soft lockup
none
logged using netconsole - 4.9.0-rc7 - NULL pointer
none
logged using netconsole - 4.9.0-rc7 - soft lockup none

Description Václav Ovsík 2016-12-03 22:00:11 UTC
Created attachment 128323 [details]
logged using netconsole - 4.8.7 - NULL pointer

Dear developers,
I'm unable to boot into functional system with KMS radeon. When
radeon.modeset=0 on kernel command-line system it starts and run OK.
Without disabled modeset the kernel 4.7, 4.8, 4.9-rc7 with 90% probability locks or crash.
I'm running Debian unstable and tried Debian kernels 4.7, 4.8 from Debian and compile 4.9rc7 vanilla kernel.

Attached logs through netconsole.

Any idea what I can test?

Thanks
-- 
Zito

ref: debian bug #845382 - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845382
Comment 1 Václav Ovsík 2016-12-03 22:03:04 UTC
Created attachment 128324 [details]
logged using netconsole - 4.8.7 - soft lockup
Comment 2 Václav Ovsík 2016-12-03 22:07:04 UTC
Created attachment 128325 [details]
logged using netconsole - 4.9.0-rc7 - NULL pointer
Comment 3 Václav Ovsík 2016-12-03 22:08:28 UTC
Created attachment 128326 [details]
logged using netconsole - 4.9.0-rc7 - soft lockup
Comment 4 Václav Ovsík 2016-12-04 09:47:38 UTC
today I inserted into MB Asus M2A-VM HDMI PCI-E card HD7770. With HD7770 the modeset works OK without any crash/lockup. Xserver started OK too. Loaded was radeon driver. The bug in radeon driver is in a part specific to RS690 chip so.
Comment 5 Vedran Miletić 2016-12-04 20:03:52 UTC
Has KMS ever worked on that card for you? If yes, can you test older kernels?
Comment 6 Christian König 2016-12-05 08:10:32 UTC
Setting radeon.modeset=0 is not longer supported since the removal of UMS support, so setting this options just blacklists the driver completely.

That looks like a bug in the HDMI audio handling code, we had similar issues on other hardware generations as well. Maybe the handling routine for RS690 is still not in the correct order.

Anyway please try radeon.audio=0 as well.
Comment 7 Václav Ovsík 2016-12-05 15:36:33 UTC
Bing - HDMI audio is probably a source of problem.

I tried to add radeon.audio=0. I tested this before already, but I tried this time again with 4.9-rc7. No bug in console appeared, but kernel lock down (<Alt>-<SysRq>-B don't worked). I tried I think 3-times - no OOPS on console, only hang. Then I get idea to look into BIOS if HDMI audio is enabled there and really, HDMI was disabled completely. I enable HDMI in the BIOS and disable HDMI audio only  and system started normaly. I tried combinations:

BIOS	BIOS		radeon.audio=0
HDMI	HDMI audio
----------------------------------------------------------------
0	-		no			OOPS
0	-		yes			OOPS
yes	yes		no			OOPS
yes	yes		yes			OOPS
yes	no		no			OK

So to avoid problems with the radeon driver the HDMI audio must be disabled in BIOS and it is possible only if the HDMI connector is enabled, because otherwise the option (HDMI audio) is greyed.
I can't remember if I had this setting in the past, maybe yes. Disabled HDMI may be the result of BIOS "Load system default", because other flaws on this mobo with networking some time ago (.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.