Bug 99779

Summary: Lenovo Thinkpad E450 (Kaveri A6-7000 Radeon R4) Blank Screen after suspend (displayport link issues)
Product: DRI Reporter: Kyle Brooks <brookskd>
Component: DRM/AMDgpuAssignee: Default DRI bug account <dri-devel>
Status: NEW --- QA Contact:
Severity: critical    
Priority: medium CC: FD
Version: XOrg git   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
See Also: https://bugs.freedesktop.org/show_bug.cgi?id=90320
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
dmesg 4.9.8
none
Xorg log none

Description Kyle Brooks 2017-02-12 14:34:43 UTC
Created attachment 129527 [details]
dmesg 4.9.8

If I shut my laptop lit it suspends, then when opening the lid and resuming I get a blank screen and am unable to get the display to work again unless I reboot.  I can ssh into computer and I get displayport link errors in the attached dmesg log.

This issue does not occur if I use the radeon kernel module instead of amdgpu.

This seems very similar to bug 90320 but I filed this one because it is amdgpu not radeon:
https://bugs.freedesktop.org/show_bug.cgi?id=90320

I've also attached the Xorg.0.log but it does not have any errors indicated.  It indicates successful exit because I stopped the server over ssh and tried to restart gdm a few times which is why there are multiple displayport link status failed messages in dmesg.
Comment 1 Kyle Brooks 2017-02-12 14:35:36 UTC
Created attachment 129528 [details]
Xorg log

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.