Bug 102514

Summary: [BAT] igt@chamelium@dp-crc-fast failed assertion: eq
Product: DRI Reporter: Jani Saarinen <jani.saarinen>
Component: DRM/IntelAssignee: Mika Kahola <mika.kahola>
Status: CLOSED DUPLICATE QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: major    
Priority: high CC: intel-gfx-bugs
Version: DRI git   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: KBL i915 features: display/Other

Description Jani Saarinen 2017-09-02 08:28:56 UTC
On CI on KBL system igt@chamelium@dp-crc-fast gave dmesg fail:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3029/fi-kbl-7500u/igt@chamelium@dp-crc-fast.html

Out	
IGT-Version: 1.19-g5ce65a9a (x86_64) (Linux: 4.13.0-rc7-CI-CI_DRM_3029+ x86_64)
Stack trace:
  #0 [__igt_fail_assert+0x101]
  #1 [chamelium_assert_crc_eq_or_dump+0x64]
  #2 [test_display_crc.constprop.18+0x1cd]
  #3 [__real_main744+0x6a5]
  #4 [main+0x33]
  #5 [__libc_start_main+0xf0]
  #6 [_start+0x2a]
  #7 [<unknown>+0x2a]
Subtest dp-crc-fast: FAIL (8.347s)
Test requirement not met in function require_connector_present, file chamelium.c:90:
Test requirement: found
No port of type HDMI-A was found
Test requirement not met in function require_connector_present, file chamelium.c:90:
Test requirement: found
No port of type VGA was found
Err	
(chamelium:1427) igt-chamelium-CRITICAL: Test assertion failure function chamelium_assert_crc_eq_or_dump, file igt_chamelium.c:1059:
(chamelium:1427) igt-chamelium-CRITICAL: Failed assertion: eq
Subtest dp-crc-fast failed.
**** DEBUG ****
(chamelium:1427) igt-chamelium-DEBUG: Resetting the chamelium
(chamelium:1427) DEBUG: Waiting for DP-1 to disconnect...
(chamelium:1427) DEBUG: Reprobing DP-1...
(chamelium:1427) igt-chamelium-DEBUG: Plugging DP-1
(chamelium:1427) DEBUG: Waiting for DP-1 to connect...
(chamelium:1427) DEBUG: Reprobing DP-1...
(chamelium:1427) igt-kms-DEBUG: display: init {
(chamelium:1427) igt-kms-DEBUG: Setting Broadcast RGB mode on connector 58 to 1
(chamelium:1427) igt-kms-DEBUG: Setting Broadcast RGB mode on connector 64 to 1
(chamelium:1427) igt-kms-DEBUG: Setting Broadcast RGB mode on connector 67 to 1
(chamelium:1427) igt-kms-DEBUG: display: }
(chamelium:1427) igt-kms-DEBUG: display: DP-1: set_pipe(A)
(chamelium:1427) igt-kms-DEBUG: Setting Broadcast RGB mode on connector 58 to 1
(chamelium:1427) igt-kms-DEBUG: display: DP-1: Selecting pipe A
(chamelium:1427) igt-fb-DEBUG: igt_create_fb_with_bo_size(width=1920, height=1080, format=0x34325258, tiling=0x0, size=0)
(chamelium:1427) igt-fb-DEBUG: igt_create_fb_with_bo_size(handle=1, pitch=7680)
(chamelium:1427) igt-kms-DEBUG: display: A.0: plane_set_size (1920x1080)
(chamelium:1427) igt-kms-DEBUG: display: A.0: plane_set_fb(80)
(chamelium:1427) igt-kms-DEBUG: display: DP-1: set_pipe(A)
(chamelium:1427) igt-kms-DEBUG: Setting Broadcast RGB mode on connector 58 to 1
(chamelium:1427) igt-kms-DEBUG: display: DP-1: Selecting pipe A
(chamelium:1427) igt-kms-DEBUG: Setting Broadcast RGB mode on connector 58 to 1
(chamelium:1427) igt-kms-DEBUG: display: commit {
(chamelium:1427) igt-kms-DEBUG: display:     DP-1: SetCrtc pipe A, fb 80, src (0, 0), mode 1920x1080
(chamelium:1427) igt-kms-DEBUG: display:     SetPlane pipe A, plane 1, disabling
(chamelium:1427) igt-kms-DEBUG: display:     SetCursor pipe A, disabling
(chamelium:1427) igt-kms-DEBUG: display:     SetCrtc pipe B, disabling
(chamelium:1427) igt-kms-DEBUG: display:     SetPlane pipe B, plane 1, disabling
(chamelium:1427) igt-kms-DEBUG: display:     SetCursor pipe B, disabling
(chamelium:1427) igt-kms-DEBUG: display:     SetCrtc pipe C, disabling
(chamelium:1427) igt-kms-DEBUG: display:     SetPlane pipe C, plane 1, disabling
(chamelium:1427) igt-kms-DEBUG: display:     SetCursor pipe C, disabling
(chamelium:1427) igt-kms-DEBUG: display: }
(chamelium:1427) igt-chamelium-DEBUG: Chamelium needs FSM, handling
(chamelium:1427) DEBUG: Captured 1 frames
(chamelium:1427) igt-debugfs-DEBUG: CRC mismatch at index 1: 0xa751 != 0x779b
(chamelium:1427) igt-chamelium-CRITICAL: Test assertion failure function chamelium_assert_crc_eq_or_dump, file igt_chamelium.c:1059:
(chamelium:1427) igt-chamelium-CRITICAL: Failed assertion: eq
(chamelium:1427) igt-core-INFO: Stack trace:
(chamelium:1427) igt-core-INFO:   #0 [__igt_fail_assert+0x101]
(chamelium:1427) igt-core-INFO:   #1 [chamelium_assert_crc_eq_or_dump+0x64]
(chamelium:1427) igt-core-INFO:   #2 [test_display_crc.constprop.18+0x1cd]
(chamelium:1427) igt-core-INFO:   #3 [__real_main744+0x6a5]
(chamelium:1427) igt-core-INFO:   #4 [main+0x33]
(chamelium:1427) igt-core-INFO:   #5 [__libc_start_main+0xf0]
(chamelium:1427) igt-core-INFO:   #6 [_start+0x2a]
(chamelium:1427) igt-core-INFO:   #7 [<unknown>+0x2a]
****  END  ****
Environment	
PIGLIT_PLATFORM="mixed_glx_egl" PIGLIT_SOURCE_DIR="/opt/igt/piglit"
Command	
/opt/igt/tests/chamelium --run-subtest dp-crc-fast
Dmesg	
[  107.273037] [drm:pipe_config_err [i915]] *ERROR* mismatch in has_audio (expected 1, found 0)
[  107.273039] pipe state doesn't match!
[  107.273064] ------------[ cut here ]------------
[  107.273101] WARNING: CPU: 3 PID: 1427 at drivers/gpu/drm/i915/intel_display.c:11632 intel_atomic_commit_tail+0xc6d/0xf40 [i915]
[  107.273103] Modules linked in: snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic i915 x86_pkg_temp_thermal snd_hda_intel intel_powerclamp coretemp crct10dif_pclmul snd_hda_codec crc32_pclmul e1000e snd_hwdep snd_hda_core ghash_clmulni_intel snd_pcm ptp mei_me pps_core mei prime_numbers i2c_hid pinctrl_sunrisepoint pinctrl_intel
[  107.273188] CPU: 3 PID: 1427 Comm: chamelium Not tainted 4.13.0-rc7-CI-CI_DRM_3029+ #1
[  107.273190] Hardware name: GIGABYTE GB-BKi7(H)A-7500/MFLP7AP-00, BIOS F4 02/20/2017
[  107.273192] task: ffff88025bc4d0c0 task.stack: ffffc900004d4000
[  107.273228] RIP: 0010:intel_atomic_commit_tail+0xc6d/0xf40 [i915]
[  107.273230] RSP: 0018:ffffc900004d7a50 EFLAGS: 00010282
[  107.273234] RAX: 0000000000000019 RBX: ffff880250840000 RCX: 0000000000000006
[  107.273237] RDX: 0000000000000006 RSI: ffffffff81cf7754 RDI: ffffffff81cae606
[  107.273239] RBP: ffffc900004d7b00 R08: 0000000000000000 R09: 0000000000000001
[  107.273241] R10: 0000000000000000 R11: 0000000000000000 R12: ffff880250840718
[  107.273243] R13: ffff88025558d3d8 R14: ffff880263caae98 R15: ffff880263d9d3d8
[  107.273245] FS:  00007f9cb241da40(0000) GS:ffff88026dd80000(0000) knlGS:0000000000000000
[  107.273248] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  107.273250] CR2: 0000559febc1d920 CR3: 000000025233f000 CR4: 00000000003406e0
[  107.273252] Call Trace:
[  107.273265]  ? wait_woken+0x90/0x90
[  107.273303]  intel_atomic_commit+0x1bd/0x280 [i915]
[  107.273311]  drm_atomic_commit+0x4b/0x50
[  107.273316]  restore_fbdev_mode_atomic+0x197/0x200
[  107.273329]  restore_fbdev_mode+0x32/0x120
[  107.273336]  drm_fb_helper_restore_fbdev_mode_unlocked.part.19+0x2a/0x80
[  107.273341]  drm_fb_helper_set_par+0x43/0x70
[  107.273378]  intel_fbdev_set_par+0x1a/0x70 [i915]
[  107.273384]  fbcon_init+0x582/0x610
[  107.273393]  visual_init+0xd6/0x130
[  107.273398]  do_bind_con_driver+0x1cb/0x3b0
[  107.273406]  store_bind+0x145/0x1b0
[  107.273413]  dev_attr_store+0x18/0x30
[  107.273417]  sysfs_kf_write+0x45/0x60
[  107.273422]  kernfs_fop_write+0x124/0x1c0
[  107.273429]  __vfs_write+0x28/0x130
[  107.273432]  ? rcu_read_lock_sched_held+0x7a/0x90
[  107.273435]  ? rcu_sync_lockdep_assert+0x2f/0x60
[  107.273440]  ? __sb_start_write+0x10c/0x200
[  107.273447]  vfs_write+0xc8/0x1c0
[  107.273453]  SyS_write+0x49/0xb0
[  107.273460]  entry_SYSCALL_64_fastpath+0x1c/0xb1
[  107.273463] RIP: 0033:0x7f9caf9b54bd
[  107.273465] RSP: 002b:00007ffd064a1230 EFLAGS: 00000293 ORIG_RAX: 0000000000000001
[  107.273469] RAX: ffffffffffffffda RBX: ffffffff8148a453 RCX: 00007f9caf9b54bd
[  107.273471] RDX: 0000000000000002 RSI: 000055e68f23ae7b RDI: 0000000000000005
[  107.273473] RBP: ffffc900004d7f88 R08: 0000000000000000 R09: 0000000000000020
[  107.273476] R10: 0000000000000006 R11: 0000000000000293 R12: 000055e68f23ae87
[  107.273478] R13: 000055e68f23ae66 R14: 000055e68f23ae81 R15: 000055e69018a810
[  107.273484]  ? __this_cpu_preempt_check+0x13/0x20
[  107.273492] Code: ff 0f b6 d0 0f b6 f1 48 c7 c7 d0 58 2a a0 e8 2c d8 ef e0 0f ff 41 0f b6 4f 09 e9 34 f9 ff ff 48 c7 c7 f2 ad 28 a0 e8 14 d8 ef e0 <0f> ff e9 df f9 ff ff 80 3d 52 9a 0d 00 00 0f b6 ca 0f 85 1a 02 
[  107.273598] ---[ end trace 0bf6dd8c6afef742 ]---
Comment 2 Jani Saarinen 2017-10-11 11:37:17 UTC
Are these more Chamelium issues than driver / IGT issues?
Comment 3 Marta Löfstedt 2017-10-16 10:12:50 UTC
The issue described above has not been reproduced for a very long time. The last 10 times this test has failed it has always been a I2C issue:
	

(chamelium:1337) igt-chamelium-CRITICAL: Test assertion failure function chamelium_rpc, file igt_chamelium.c:302:
(chamelium:1337) igt-chamelium-CRITICAL: Failed assertion: !chamelium->env.fault_occurred
(chamelium:1337) igt-chamelium-CRITICAL: Chamelium RPC call failed: RPC failed at server.  <class 'chameleond.utils.i2c.I2cBusError'>:I2C access error
Subtest dp-crc-fast failed.

However, as discussed in BUG 102672, there appear to be an issue with Chamelium I2C communication.

Also, note linktraining issue in:
https://bugs.freedesktop.org/show_bug.cgi?id=102505
Comment 4 Jani Saarinen 2017-10-16 11:08:29 UTC
Dropping priority.
Comment 5 Marta Löfstedt 2017-11-16 13:26:37 UTC

*** This bug has been marked as a duplicate of bug 102672 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.