Bug 102672 - [BAT]igt@kms_chamelium@* - fail / warn - Chamelium RPC call failed: RPC failed at server. <class 'chameleond.utils.i2c.I2cBusError'>:I2C access error
Summary: [BAT]igt@kms_chamelium@* - fail / warn - Chamelium RPC call failed: RPC faile...
Status: CLOSED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: low normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 102514 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-12 07:25 UTC by Marta Löfstedt
Modified: 2019-01-16 11:29 UTC (History)
2 users (show)

See Also:
i915 platform: KBL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2017-09-12 07:25:10 UTC
On CI_DRM_3075 fi-kbl-7500u assert on I2C access error:

(chamelium:1396) igt-chamelium-CRITICAL: Test assertion failure function chamelium_rpc, file igt_chamelium.c:301:
(chamelium:1396) igt-chamelium-CRITICAL: Failed assertion: !chamelium->env.fault_occurred
(chamelium:1396) igt-chamelium-CRITICAL: Chamelium RPC call failed: RPC failed at server.  <class 'chameleond.utils.i2c.I2cBusError'>:I2C access error

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3075/fi-kbl-7500u/igt@chamelium@dp-edid-read.html
Comment 2 Marta Löfstedt 2017-09-21 06:15:28 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3111/fi-kbl-7500u/igt@chamelium@hdmi-hpd-fast.html

Note, on all other runs on the fi-kbl-7500u the igt@chamelium@hdmi-hpd-fast is skipped.

So, it appear that it is possible to get an assert from chamelium tests before checking that the test should be skipped. I.e. these tests need to be restructured otherwise they will produce noise.
Comment 3 Marta Löfstedt 2017-09-21 11:00:54 UTC
For the igt@chamelium@dp-edid-read case we don't know if the I2C issue also happened before even starting test or during execution.

Functions in igt_chamelium.c that are used to established if the tests can be run should not assert they should return an error code and let the actual test decide what to do.
Comment 4 Jani Saarinen 2017-10-11 11:37:07 UTC
Are these more Chamelium issues than driver / IGT issues?
Comment 5 Marta Löfstedt 2017-10-11 11:43:28 UTC
(In reply to Jani Saarinen from comment #4)
> Are these more Chamelium issues than driver / IGT issues?

It should be fixed in igt/lib/igt_chamelium.c. 
But it is slightly tricky, since we can't know when instabilities on I2C could start occuring.
Comment 6 Marta Löfstedt 2017-11-16 13:26:37 UTC
*** Bug 102514 has been marked as a duplicate of this bug. ***
Comment 7 Marta Löfstedt 2017-11-16 13:27:01 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_7136/fi-kbl-7500u/igt@chamelium@dp-crc-fast.html

(chamelium:1361) igt-chamelium-CRITICAL: Test assertion failure function chamelium_rpc, file igt_chamelium.c:302:
(chamelium:1361) igt-chamelium-CRITICAL: Failed assertion: !chamelium->env.fault_occurred
(chamelium:1361) igt-chamelium-CRITICAL: Chamelium RPC call failed: RPC failed at server.  <class 'chameleond.utils.i2c.I2cBusError'>:I2C access error
Subtest dp-crc-fast failed.
Comment 8 Marta Löfstedt 2017-11-22 08:04:57 UTC
Note, the chamelium test have changed name to kms_chamelium since CI_DRM_3369. Also, this issue was not reproduce after on the first 2 runs.
Comment 9 Marta Löfstedt 2018-01-09 13:35:09 UTC
Reproduced:

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3612/fi-kbl-7500u/igt@kms_chamelium@hdmi-hpd-fast.html

(kms_chamelium:3885) igt-chamelium-CRITICAL: Test assertion failure function chamelium_rpc, file igt_chamelium.c:302:
(kms_chamelium:3885) igt-chamelium-CRITICAL: Failed assertion: !chamelium->env.fault_occurred
(kms_chamelium:3885) igt-chamelium-CRITICAL: Chamelium RPC call failed: RPC failed at server.  <class 'chameleond.utils.i2c.I2cBusError'>:I2C access error
Comment 10 Marta Löfstedt 2018-02-09 07:24:33 UTC
Last seen CI_DRM_3612: 2018-01-09 / 211 runs ago
Comment 12 Jani Saarinen 2018-04-18 10:12:55 UTC
Still valid?
Comment 15 Martin Peres 2018-11-16 15:40:04 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5090_113/fi-kbl-7500u/igt@kms_chamelium@dp-crc-fast.html

Starting subtest: dp-crc-fast
Subtest dp-crc-fast: SUCCESS (8.582s)
(kms_chamelium:2846) igt_chamelium-CRITICAL: Test assertion failure function chamelium_rpc, file ../lib/igt_chamelium.c:303:
(kms_chamelium:2846) igt_chamelium-CRITICAL: Failed assertion: !chamelium->env.fault_occurred
(kms_chamelium:2846) igt_chamelium-CRITICAL: Chamelium RPC call failed: RPC failed at server. <class 'chameleond.utils.i2c.I2cBusError'>:I2C access error
Comment 16 Jani Saarinen 2019-01-16 11:29:31 UTC
Not seen lately: (1 month, 2 weeks / 614 runs ago). Resolving


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.