Bug 18640

Summary: [945GM/945G/G33 EXA] 2.5.1: intermittent X crash with "EQ overflowing"
Product: xorg Reporter: Damjan Georgievski <gdamjan>
Component: Driver/intelAssignee: Jesse Barnes <jbarnes>
Status: RESOLVED DUPLICATE QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: high CC: airlied, brandon, damir, eich, haihao.xiang, jirislaby, kent.liu, libv, ling.yue, mat, plaes, quanxian.wang, sndirsch, theholyettlz, vvk, zhenyu.z.wang
Version: 7.4 (2008.09)   
Hardware: Other   
OS: All   
Whiteboard:
Bug Depends on:    
Bug Blocks: 18858    
Attachments:
Description Flags
xorg.log
none
Xorg log with backtrace none

Description Damjan Georgievski 2008-11-20 09:37:19 UTC
Created attachment 20472 [details]
xorg.log

After some time using the computer the X server freezes. I can move the mouse, I can see the last picture on the screen, but nothing changes nor receives events.


This is on a Thinkpad X60s - i945 onboard video, i686 architecture, ArchLinux. 
Software components are:
xorg-server 1.5.3-2
xf86-video-intel  2.5.1 (compiled from source)
libpciaccess 0.10.5-1
libdrm 2.4.1-1
intel-dri 7.2-1
libgl 7.2-1
mesa 7.2-1

kernel is my own 2.6.26.8 (with tuxonice, tp_smapi, thinkpad_acpi patches)

attached is Xorg.0.log .. dmesg didn't show anything.
xorg.conf is the same as https://bugs.freedesktop.org/attachment.cgi?id=20259
Comment 1 Gordon Jin 2008-11-22 18:49:16 UTC
Lots of [mi] info in the log:
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
Comment 2 Gordon Jin 2008-11-22 18:51:04 UTC
*** Bug 18663 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Slaby 2008-11-23 01:00:27 UTC
So the original report is with mouse_drv. It means we have a general problem in input handling in X in cooperation with dri?
Comment 4 Stefan Dirsch 2008-11-23 03:20:16 UTC
I think Luc Verhaegen <libv@skynet.be> can explain best what the issue is here.
Comment 5 Gordon Jin 2008-11-25 17:04:23 UTC
Does this happen only with EXA, and fine with XAA?
Comment 6 Damjan Georgievski 2008-11-26 06:34:20 UTC
I can't say for sure, since it needs some time for this to happen, but it sure looks like it. With XAA enabled it hasn't happened to me.
Comment 7 Dave Airlie 2008-12-01 14:52:37 UTC
THis is an EXA bug, with GEM its much worse.

We are seeing it all over the place on Fedora, rh BZ 470314

The mouse backtrace is just debugging info

I'm going to switch 945GM to vesa in F10 if we can't get this fixed.
Comment 8 Eric Anholt 2008-12-01 18:31:45 UTC
the reporter of redhat #470314 is q35 (G965) not 945GM.
Comment 9 Dave Airlie 2008-12-01 19:06:52 UTC
*** Bug 18537 has been marked as a duplicate of this bug. ***
Comment 10 Dave Airlie 2008-12-01 19:07:04 UTC
*** Bug 18450 has been marked as a duplicate of this bug. ***
Comment 11 Dave Airlie 2008-12-01 19:07:10 UTC
*** Bug 18406 has been marked as a duplicate of this bug. ***
Comment 12 Gordon Jin 2008-12-02 05:46:16 UTC
*** Bug 18631 has been marked as a duplicate of this bug. ***
Comment 13 Skippy 2008-12-08 11:46:53 UTC
Created attachment 20905 [details]
Xorg log with backtrace

Same issue here. Complete Xorg log in attachment, abstracts here :
------------------------------------ 8< ------------------------------------
$ egrep 'EE|WW' /var/log/Xorg.0.log.old
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) Loading extension MIT-SCREEN-SAVER
(WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
(WW) intel(0): Register 0x61200 (PP_STATUS) changed from 0xc0000008 to 0xd0000009
(WW) intel(0): PP_STATUS before: on, ready, sequencing idle
(WW) intel(0): PP_STATUS after: on, ready, sequencing on
(WW) intel(0): Register 0x71024 (PIPEBSTAT) changed from 0x00000202 to 0x00000000
(WW) intel(0): PIPEBSTAT before: status: VSYNC_INT_STATUS VBLANK_INT_STATUS
(WW) intel(0): PIPEBSTAT after: status:
(WW) intel(0): ESR is 0x00000001, instruction error
(WW) intel(0): PRB0_CTL (0x0001f001) indicates ring buffer enabled
(WW) intel(0): Existing errors found in hardware state.
(EE) intel(0): underrun on pipe B!
------------------------------------ 8< ------------------------------------

------------------------------------ 8< ------------------------------------
[…]
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812bc5b]
1: /usr/bin/Xorg(mieqEnqueue+0x289) [0x810b379]
2: /usr/bin/Xorg(xf86PostMotionEventP+0xc2) [0x80d4262]
3: /usr/bin/Xorg(xf86PostMotionEvent+0x68) [0x80d43c8]
4: /usr/lib/xorg/modules/input//evdev_drv.so [0x192a8d]
5: /usr/bin/Xorg [0x80bcdb7]
6: /usr/bin/Xorg [0x80ac91e]
7: [0x110400]
8: [0x110416]
9: /lib/libc.so.6(ioctl+0x19) [0x298949]
10: /usr/lib/libdrm.so.2 [0x4ab16cf]
11: /usr/lib/libdrm.so.2(drmWaitVBlank+0x28) [0x4ab1e08]
12: /usr/lib/dri/i915_dri.so [0x5729e8]
13: /usr/lib/dri/i915_dri.so(driWaitForVBlank+0xd8) [0x572c08]
14: /usr/lib/dri/i915_dri.so(intelSwapBuffers+0x262) [0x582260]
15: /usr/lib/dri/i915_dri.so [0x572d82]
16: /usr/lib/xorg/modules/extensions//libglx.so [0x440504]
17: /usr/lib/xorg/modules/extensions//libglx.so [0x432cfe]
18: /usr/lib/xorg/modules/extensions//libglx.so [0x43663a]
19: /usr/bin/Xorg(Dispatch+0x34f) [0x8085e9f]
20: /usr/bin/Xorg(main+0x47d) [0x806b71d]
21: /lib/libc.so.6(__libc_start_main+0xe5) [0x1d36d5]
22: /usr/bin/Xorg [0x806ab01]
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[…]
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[…]
------------------------------------ 8< ------------------------------------
Comment 14 Skippy 2008-12-08 11:49:34 UTC
Hell, forgot hardware specs… Dell Latitude D620, dual screen config (ask xorg.conf if you think it's relevant).

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Fedora 10, BTW. Any workaround is welcome. ;-)
Comment 15 Skippy 2008-12-09 07:32:01 UTC
No issue since I have turned off compiz effects. Not sure it is related though, since problems occured mainly while I was playing with screen resolution and I'm not anymore. I'll keep effects off a few days, then if no bug turn them on again and see if it freezes again.
Comment 16 Brandon Philips 2008-12-09 09:30:49 UTC
(In reply to comment #15)
> No issue since I have turned off compiz effects. Not sure it is related though,
> since problems occured mainly while I was playing with screen resolution and
> I'm not anymore. I'll keep effects off a few days, then if no bug turn them on
> again and see if it freezes again.

FYI, I have compiz turned off and I have hit this bug.
Comment 17 James 2008-12-09 09:38:07 UTC
I encountered it a few seconds after login, no Compiz here either.

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e7a26]
1: /usr/bin/Xorg(mieqEnqueue+0x291) [0x4c8591]
2: /usr/bin/Xorg(xf86PostMotionEventP+0xc4) [0x491494]
3: /usr/bin/Xorg(xf86PostMotionEvent+0xa9) [0x491669]
4: /usr/lib64/xorg/modules/input//synaptics_drv.so [0x3060832]
5: /usr/lib64/xorg/modules/input//synaptics_drv.so [0x3062de2]
6: /usr/bin/Xorg [0x47a765]
7: /usr/bin/Xorg [0x46b307]
8: /lib64/libc.so.6 [0x39edc32f60]
9: /lib64/libc.so.6(cfree+0x62) [0x39edc7a442]
10: /usr/lib64/libdrm_intel.so.1 [0x56a6428]
11: /usr/lib64/libdrm_intel.so.1 [0x56a6867]
12: /usr/lib64/libdrm_intel.so.1 [0x56a6ed5]
13: /usr/lib64/libdrm_intel.so.1 [0x56a705f]
14: /usr/lib64/xorg/modules/drivers//intel_drv.so(intel_batch_flush+0x7f)
[0x1fd73cf]
15: /usr/lib64/xorg/modules/drivers//intel_drv.so [0x1fe1fae]
16: /usr/bin/Xorg [0x51cdb9]
17: /usr/bin/Xorg [0x4f7311]
18: /usr/bin/Xorg(BlockHandler+0x50) [0x44a320]
19: /usr/bin/Xorg(WaitForSomething+0x161) [0x4e4eb1]
20: /usr/bin/Xorg(Dispatch+0x7f) [0x4465ef]
21: /usr/bin/Xorg(main+0x45d) [0x42cd1d]
22: /lib64/libc.so.6(__libc_start_main+0xe6) [0x39edc1e546]
23: /usr/bin/Xorg [0x42c0f9]
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
Comment 18 Damir Islamov 2008-12-10 00:58:36 UTC
The issue takes place with radeon driver also, not only with intel.

X.Org X Server 1.5.3
xserver-xorg-video-radeon 6.9.0+git20081129.783cdb73
libdrm2 2.4.1+git+20081116+930c0e7

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x812f0fb]
1: /usr/bin/X(mieqEnqueue+0x289) [0x810e909]
2: /usr/bin/X(xf86PostKeyboardEvent+0xa7) [0x80d8c77]
3: /usr/lib/xorg/modules/input//evdev_drv.so [0xab55ceeb]
4: /usr/bin/X [0x80c1da7]
5: /usr/bin/X [0x80b1b5c]
6: [0xb7f1f400]
7: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb797ccb7]
8: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb797ce41]
9: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb79c7fab]
10: /usr/lib/xorg/modules//libexa.so [0xb77bfe8e]
11: /usr/lib/xorg/modules//libexa.so(exaComposite+0xb97) [0xb77c0c97]
12: /usr/bin/X [0x81722ca]
13: /usr/bin/X(CompositePicture+0x19a) [0x815acea]
14: /usr/bin/X(miGlyphs+0x3cf) [0x8156ecf]
15: /usr/bin/X [0x8172595]
16: /usr/bin/X(CompositeGlyphs+0xa2) [0x8157172]
17: /usr/bin/X [0x81629ae]
18: /usr/bin/X [0x815d8d5]
19: /usr/bin/X(Dispatch+0x34f) [0x808b79f]
20: /usr/bin/X(main+0x47d) [0x807143d]
21: /lib/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7b23455]
22: /usr/bin/X(FontFileCompleteXLFD+0x20d) [0x8070821]
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
...
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
...
Comment 19 Khashayar Naderehvandi 2008-12-11 04:44:00 UTC
I'm being hit by this bug too.
For me, it's definitely more likely to happen when compiz is running, although, it does happen without compiz as well but more seldom.
Comment 20 Jim McDonough 2008-12-11 16:06:42 UTC
Just FYI, I can recreate it pretty much at will running bzflag...with or without compiz.  switching from exa to xaa makes it go away.
Comment 21 Jesse Barnes 2008-12-18 13:10:31 UTC
Marking this as a dup, trying to reproduce on my Eee (the only 945 machine I have).

*** This bug has been marked as a duplicate of bug 17638 ***