Bug 2187

Summary: Lock ups w/ DynamicClocks
Product: xorg Reporter: MT <mrdc76>
Component: Driver/RadeonAssignee: Xorg Project Team <xorg-team>
Status: RESOLVED INVALID QA Contact:
Severity: normal    
Priority: highest CC: alexdeucher, erik.andren, osos, weppnesp
Version: 6.8.1   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description MT 2005-01-01 09:54:44 UTC
I have a IBM ThinkPad T40 laptop with ATI Radeon Mobility M7 LW [Radeon Mobility
7500] -vga. The problem is that with DynamicClocks enabled, X.org locks up
randomly when started after boot. I have tested it several times without the
DynamicClock enabled and it works. Also, when I run glxgears with the
DynamicClock enabled, it crashed after couple of minutes. 

At the moment I have Ubuntu "Hoary Hedgehog" distribution, but I experienced the
same phenomena with Debian Sarge and the X.org 6.8.1 sources downloaded from
www.x.org. 

This is quite a severe problem because without DynamicClocks the fan of T40 runs
all the time.
Comment 1 Geir Thomassen 2005-03-10 07:50:39 UTC
I see the same problem on an AOpen 1557GLS laptop with a mobility chip set.
Skype triggers this bug in a few minutes.

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon
9600 M10]
Comment 2 Geir Thomassen 2005-03-21 04:43:51 UTC
(In reply to comment #1)
> I see the same problem on an AOpen 1557GLS laptop with a mobility chip set.
> Skype triggers this bug in a few minutes.
> 
> 01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon
> 9600 M10]

It looks like the bug is still present with DynamicClocks disabled, it is just
much harder to trigger (every other day, instead of minutes). Sorry!
Comment 3 FreeDesktop Bugzilla Database Corruption Fix User 2005-07-06 11:38:39 UTC
I do have an IBM R51 with Radeon 7500 mobility card and do have the same
problem. Around 80% starups of x.org will crash my Linux completely.
Interestingwise the percentage of startup crashes drops drastically, if I do a
lot of keyboard input and mouse movement during start. In that case I manage
about 80% of startups to be successfull.

If I turn off the Dynamic Clocks feature, the systems seems to start every time
without any problem (but in that configuration the fan of my Thinkpad didn't
stop anymore).

Volker
Comment 4 Gilson Laurent 2005-07-23 21:55:57 UTC
Workaround:

use this little tool to underclock (and overclock) your radeon 7500 M
http://forums.gentoo.org/viewtopic-t-343029.html

But no dynamic clock switching. Tested it for 2 hours, no problems except on 
extreme underclocks.
Comment 5 Johannes Hessellund 2005-07-25 06:48:51 UTC
T42 2374-zep is also infected.

Run for several weeks with no problems... suddenly hangs on every boot with
dynamicclocks enabled.

Anyone working on a solution?
Anyone contacted IBM and/or ATI for help/specifications?

IBM seems to have helped out on those thinkpad problems before, hopefully they
will still after being Lenovo!!
Comment 6 Johannes Hessellund 2005-07-25 07:17:01 UTC
Does fixes in bug 3621 https://bugs.freedesktop.org/show_bug.cgi?id=3621
solve this? Anybody thried?
Comment 7 Alex Deucher 2005-07-25 23:54:47 UTC
I committed a small fix up of some errors in the dynamicclocks code.  The
changes are in xorg cvs.  It may help with this bug.
Comment 8 Johannes Hessellund 2005-08-17 07:24:08 UTC
(In reply to comment #6)
> I committed a small fix up of some errors in the dynamicclocks code.  The
> changes are in xorg cvs.  It may help with this bug.

Have been running the new code for a couple of days, no hangs.
BUT!!! It seems to have no effect on the powerconsumption anymore!? My Radeon
7500 on my Thinkpad T42 gets equaly hot with and without dynamicclocks on !

Any ideas?
Comment 9 Alex Deucher 2005-08-17 07:40:37 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > I committed a small fix up of some errors in the dynamicclocks code.  The
> > changes are in xorg cvs.  It may help with this bug.
> 
> Have been running the new code for a couple of days, no hangs.
> BUT!!! It seems to have no effect on the powerconsumption anymore!? My Radeon
> 7500 on my Thinkpad T42 gets equaly hot with and without dynamicclocks on !
> 
> Any ideas?

Did it used to make a difference when it was enabled?  If not it's possible the
BIOS already enables dynamicclocks, in which case, enabling it in the driver
will make no difference.

Comment 10 Alex Deucher 2005-08-17 08:33:47 UTC
*** Bug 2790 has been marked as a duplicate of this bug. ***
Comment 11 Johannes Hessellund 2005-09-07 03:30:59 UTC
(In reply to comment #8)
> Did it used to make a difference when it was enabled?  If not it's possible the
> BIOS already enables dynamicclocks, in which case, enabling it in the driver
> will make no difference.

The BIOS might enable some sort of powersaving. But if boot into Windows XP, the
GPU slows down as expected, and the fan stops running, Xorg driver keeps the GPU
hot and the fan keeps running... this is bad for a laptop.
Do we have the specs to enable what ATI calls PowerPlay ? And may I see them?
Comment 12 Alex Deucher 2005-09-07 05:39:06 UTC
(In reply to comment #10)
> (In reply to comment #8)
> > Did it used to make a difference when it was enabled?  If not it's possible the
> > BIOS already enables dynamicclocks, in which case, enabling it in the driver
> > will make no difference.
> 
> The BIOS might enable some sort of powersaving. But if boot into Windows XP, the
> GPU slows down as expected, and the fan stops running, Xorg driver keeps the GPU
> hot and the fan keeps running... this is bad for a laptop.
> Do we have the specs to enable what ATI calls PowerPlay ? And may I see them?


No, ATI has not released the specs to powerplay.  Just to be clear the
DynamicClocks code is not powerplay; all it does is set the various GPU clocks
to dynamic mode so they scale based on load.  Powerplay involves a lot more.

Comment 13 T. Hood 2005-09-25 04:11:25 UTC
MT: Is this fixed in the latest code?
Comment 14 T. Hood 2005-09-26 03:22:45 UTC

*** This bug has been marked as a duplicate of 1912 ***
Comment 15 Alex Deucher 2005-10-04 09:02:21 UTC
not a dup of 1912
Comment 16 Erik Andren 2006-04-12 07:24:07 UTC
Ping to the bug poster!
Comment 17 Erik Andren 2006-05-10 06:25:07 UTC
Closing this bug due to the lack of activity from the bug submitter. If the
problem still exists in a _current_ version of xorg, please reopen.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.