|Summary:||cairo_image_surface_create_for_png return values|
|Product:||cairo||Reporter:||Owen Taylor <otaylor>|
|Component:||png functions||Assignee:||Carl Worth <cworth>|
|Status:||RESOLVED FIXED||QA Contact:||cairo-bugs mailing list <cairo-bugs>|
|i915 platform:||i915 features:|
Description Owen Taylor 2005-04-11 08:58:20 UTC
Currently there are three returns from _create_for_png() Surface (return) width (out parameter) height (out parameter) The height/width out parameters should be removed and replaced by separate getters on cairo_image_surface() or cairo_surface() http://lists.freedesktop.org/archives/cairo/2005-April/003576.html [Somewhat related is the _for_png() name. I'd really like to see it renamed to from_png() as it was originally. The point of prepositions is to make the name work as english text ... and for_png() is just very different from create_for_drawable()]
Comment 1 Carl Worth 2005-05-10 14:41:43 UTC
Kristian fixed this a while back.
Comment 2 Carl Worth 2005-08-22 17:14:58 UTC
Move bugs against "cvs" version to "0.9.3" so we can remove the "cvs" version.