Bug 38512

Summary: [855GM] windows flicker
Product: xorg Reporter: krsengr
Component: Driver/intelAssignee: Default DRI bug account <dri-devel>
Status: RESOLVED FIXED QA Contact: Xorg Project Team <xorg-team>
Severity: major    
Priority: medium Keywords: regression
Version: unspecified   
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
Attachments:
Description Flags
Xorg log file when error occurs none

Description krsengr 2011-06-20 18:37:17 UTC
(forgive me, I'm new at Linux)

ISSUE:
-- Dell Latitude D505 with 855GM graphics
-- Loaded Open SuSE 11.4 w/KDE
-- Desktop looks fine but windows flicker badly or disappear when apps are opened or doing alt-tab.  Switching to another desktop and back stabilizes things a bit.
--  Colors fine, resolution fine.  Window flickers make driver unusable.

TROUBLESHOOTING STEPS
-- Reloaded again, used GNOME.  Same problem.
-- Checked SuSE release notes, altered many many settings.
-- Tried Intellegacy driver, didn't work at all.
-- Tried VESA driver (640x480), worked OK.
-- Tried building driver myself from xf86-video-intel-2.15.0.
-- Poorly built driver gave some errors, but worked the exact same way.

SOLUTION
-- Loaded SuSE 11.2, and graphics work great, no issues.Working module output from Xorg.0.log :

     Loading /usr/lib/xorg/modules//drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
        compiled for 1.6.5, module version = 2.9.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 5.0

Hope this helps!
Comment 1 Chris Wilson 2011-06-30 10:44:02 UTC
I've just picked up a Latitude D400, and don't see anything too terrible on upstream drivers, yet. But then again I have yet to install KDE on it.

Can you please attach the Xorg.log for the OpenSuSe packages and for your hand built driver?
Comment 2 krsengr 2011-07-04 20:51:20 UTC
Sorry, I lost all the old log files when I loaded Open SuSe 11.2.

On Thu, Jun 30, 2011 at 1:44 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=38512
>
> --- Comment #1 from Chris Wilson <chris@chris-wilson.co.uk> 2011-06-30
> 10:44:02 PDT ---
> I've just picked up a Latitude D400, and don't see anything too terrible on
> upstream drivers, yet. But then again I have yet to install KDE on it.
>
> Can you please attach the Xorg.log for the OpenSuSe packages and for your
> hand
> built driver?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 3 krsengr 2011-09-03 14:08:40 UTC
Created attachment 50878 [details]
Xorg log file when error occurs

This is from the opensuse LIVE DVD 11.4 with KDE.  THe error will also appear in GNOME.  I have other log files if needed.  Sorry for the delay in getting these.
Comment 4 Eugeni Dodonov 2011-09-08 15:56:35 UTC
This issue is affecting a hardware component which is not being actively worked on anymore.

Moving the assignee to the dri-devel list as contact, to give this issue a better coverage.
Comment 5 Chris Wilson 2012-05-12 05:32:03 UTC
Judging from the problem description, this is the 8xx pageflipping bug. Should be fixed in 3.5:

commit c2798b19bac2538393fc932bfbe59807a4734b3e
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sun Apr 22 21:13:57 2012 +0100

    drm/i915: i8xx interrupt handler
    
    gen2 hardware has some significant differences from the other interrupt
    routines that were glossed over and then forgotten about in the
    transition to KMS. Such as
    
    - 16bit IIR
    - PendingFlip status bit
    
    This patch reintroduces a handler specifically for gen2 for the purpose
    of handling pageflips correctly, simplifying code in the process.
    
    v2: Also fixup ring get/put irq to only access 16bit registers (Daniel)
    
    Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=24202
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=41793
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>