Bug 41793 - [865] Lots of [drm:intel_prepare_page_flip] *ERROR* Prepared flip multiple times messages
Summary: [865] Lots of [drm:intel_prepare_page_flip] *ERROR* Prepared flip multiple ti...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
: 43085 (view as bug list)
Depends on:
Blocks: 42991 44622
  Show dependency treegraph
 
Reported: 2011-10-14 07:42 UTC by Orion Poplawski
Modified: 2017-07-24 23:03 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg log (18.52 KB, text/x-log)
2011-10-14 07:42 UTC, Orion Poplawski
no flags Details
Specialise the interrupt handler on i8xx for working pageflips. (4.19 KB, patch)
2012-04-18 14:56 UTC, Chris Wilson
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Orion Poplawski 2011-10-14 07:42:48 UTC
Created attachment 52335 [details]
Xorg log

I get lots of the following:

Oct  4 10:01:44 athena kernel: [  792.591978] [drm:intel_prepare_page_flip]
*ERROR* Prepared flip multiple times

when logging into my KDE desktop with desktop effects enabled.  The display is
okay for the most part, some strangeness on window title bars.

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics
Controller (rev 02)

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.16.0-2.fc16.i686
mesa-dri-drivers-7.11-4.fc16.i686
kernel-PAE-3.1.0-0.rc8.git0.0.fc16.i686
Comment 1 Chris Wilson 2011-11-19 08:03:04 UTC
*** Bug 43085 has been marked as a duplicate of this bug. ***
Comment 2 Witold Baryluk 2012-01-21 00:30:46 UTC
This is regression. It was working (as well Gnome Shell effects) few months ago.

I reported identical report to Debian:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=656375

Same hardware. Almost same software (same kernel, same mesa, slightly newer driver).
Comment 3 Chris Wilson 2012-04-18 14:56:08 UTC
Created attachment 60284 [details] [review]
Specialise the interrupt handler on i8xx for working pageflips.
Comment 4 Chris Wilson 2012-04-24 02:08:37 UTC
commit 8fa2a569d3fb6ea78b83c6062b2f3aec528cc9e5
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sun Apr 22 21:13:57 2012 +0100

    drm/i915: i8xx interrupt handler
    
    gen2 hardware has some significant differences from the other interrupt
    routines that were glossed over and then forgotten about in the
    transition to KMS. Such as
    
    - 16bit IIR
    - PendingFlip status bit
    
    This patch reintroduces a handler specifically for gen2 for the purpose
    of handling pageflips correctly, simplifying code in the process.
    
    v2: Also fixup ring get/put irq to only access 16bit registers (Daniel)
    
    Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=24202
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=41793
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Comment 5 Florian Mickler 2012-07-01 03:34:40 UTC
A patch referencing this bug report has been merged in Linux v3.5-rc1:

commit c2798b19bac2538393fc932bfbe59807a4734b3e
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sun Apr 22 21:13:57 2012 +0100

    drm/i915: i8xx interrupt handler


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.