Bug 68037

Summary: TRAP_TPDMA - TP0: Unhandled ustatus 0x00000008 ; and other NV50 log spam errors
Product: xorg Reporter: dirkneukirchen
Component: Driver/nouveauAssignee: Nouveau Project <nouveau>
Status: NEEDINFO --- QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium CC: math.parent
Version: unspecified   
Hardware: x86 (IA32)   
OS: All   
Whiteboard:
i915 platform: i915 features:
Attachments:
Description Flags
dmesg with nouveau.debug=debug
none
dmesg: potential same error with glxgears on kernel 3.8.0
none
Xorg crashes after a while running glxgears. Debug messages from nouveau none

Description dirkneukirchen 2013-08-12 23:41:43 UTC
Created attachment 83990 [details]
dmesg with nouveau.debug=debug

Steps to reproduce:

- log in
- execute glxgears
- message appears

Hardware: 
- Dual Monitor Setup VGA+DVI
- Geforce 8200 (Onboard; Jetway JNC62K)
nouveau  [  DEVICE][0000:02:00.0] Chipset: MCP77/MCP78 (NVAA)
nouveau  [  DEVICE][0000:02:00.0] Family : NV50

example message:
nouveau E[  PGRAPH][0000:02:00.0] TRAP_TPDMA - TP0: Unhandled ustatus 0x00000008
nouveau E[  PGRAPH][0000:02:00.0]  TRAP
nouveau E[  PGRAPH][0000:02:00.0] ch 2 [0x0007b45000 Xorg[4836]] subc 7 class 0x8397 mthd 0x15e0 data 0x00000000
nouveau E[     PFB][0000:02:00.0] trapped write at 0x0020491500 on channel 0x00007b45 [Xorg[4836]] PGRAPH/PROP/RT0 reason: PAGE_NOT_PRESENT
nouveau E[   PFIFO][0000:02:00.0] DMA_PUSHER - ch 2 [Xorg[4836]] get 0x0020025494 put 0x0020025f28 ib_get 0x000000aa ib_put 0x000000c9 state 0x8000e684 (err: INVALID_CMD) push 0x00400040
nouveau E[  PGRAPH][0000:02:00.0] DATA_ERROR BEGIN_END_ACTIVE
nouveau E[  PGRAPH][0000:02:00.0]  DATA_ERROR
nouveau E[  PGRAPH][0000:02:00.0] ch 2 [0x0007b45000 Xorg[4836]] subc 7 class 0x8397 mthd 0x1360 data 0x00000001

Kernel versions affected (at least):
3.11-rc5
3.10.4
3.8.0-27 (Linux Mint 15)
and possible older versions - see https://bugs.freedesktop.org/show_bug.cgi?id=42479 for a similar message

potential related bugs: 
- https://bugs.freedesktop.org/show_bug.cgi?id=47191

Results of log messages might be somewhat random - maybe because of Video RAM sharing.
Comment 1 dirkneukirchen 2013-08-12 23:43:29 UTC
Created attachment 83991 [details]
dmesg: potential same error with glxgears on kernel 3.8.0

executing with a stock kernel results in similar error messages
Comment 2 dirkneukirchen 2013-08-15 06:14:32 UTC
Created attachment 84086 [details]
Xorg crashes after a while running glxgears. Debug messages from nouveau

previous crashes only changed Kernel.
This time i installed packages from xorg-edgers rebooted and ran glxgears.

After a while (opening browser, switch to virtual terminal and back)
system doesnt response and X is restarted

Attached log with debug messages from nouveau
Comment 3 dirkneukirchen 2013-08-15 17:30:53 UTC
forgot software versions:

latest log was with:
- Kernel 3.11-rc5
xorg-edgers:
libdrm-nouveau2 2.4.46+git20130702.c6d73cfe-0ubuntu0sarvatt~raring
libgl1-mesa-dri 9.2.0~git20130729+9.2.9b8ad643-0ubuntu0sarvatt~raring
xserver-xorg-core 2:1.13.4~git20130508+server-1.13-branch.10c42f57-0ubuntu0ricotz~raring
xserver-xorg-video-nouveau 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt~raring
Comment 4 Pierre Moreau 2015-02-19 10:31:25 UTC
There was some patches specifically for NVAA/AC cards that went into kernel 3.19. They solve a different issue, but it would still be worth to test it - a lot of other patches were merged since 3.11, which might also help with it.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.