Bug 42479 - piglit/glean/readPixSanity fails - dmesg PGRAPH - TRAP_TPDMA - TP0: Unhandled ustatus 0x00020000
Summary: piglit/glean/readPixSanity fails - dmesg PGRAPH - TRAP_TPDMA - TP0: Unhandled...
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-01 08:24 UTC by dirkneukirchen
Modified: 2013-08-19 11:23 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg with nonrelated errors removed (99.13 KB, text/plain)
2011-11-01 08:24 UTC, dirkneukirchen
no flags Details
piglet.glean.readPixSanity results file (145.10 KB, text/plain)
2011-11-01 08:27 UTC, dirkneukirchen
no flags Details
processed glean results via piglit-summary-html.py (61.50 KB, text/html)
2011-11-01 08:29 UTC, dirkneukirchen
no flags Details
lspci -vv output (13.59 KB, text/plain)
2011-11-01 08:30 UTC, dirkneukirchen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description dirkneukirchen 2011-11-01 08:24:29 UTC
Created attachment 53001 [details]
dmesg with nonrelated errors removed

System:

- Ubuntu Oneiric with xorg-edgers (
- piglit from git

Steps to reproduce:

1. running piglit
env PIGLIT_BUILD_DIR=Programming/piglit ./piglit-run.py tests/sanity.tests results/sanity.results

2. readPixSanity tests create dmesg
[ 7963.282652] [drm] nouveau 0000:02:00.0: PGRAPH - TRAP_TPDMA - TP0: Unhandled ustatus 0x00020000
[ 7963.282658] [drm] nouveau 0000:02:00.0: PGRAPH - TRAP
[ 7963.282665] [drm] nouveau 0000:02:00.0: PGRAPH - ch 4 (0x0007d60000) subc 5 class 0x8397 mthd 0x19d0 data 0x00000001

3. piglit/glean fails

uname -a
Linux tenchi-htpc 3.1.0-1-generic #1-Ubuntu SMP Tue Oct 18 21:46:02 UTC 2011 i686 athlon i386 GNU/Linux
Comment 1 dirkneukirchen 2011-11-01 08:27:22 UTC
Created attachment 53002 [details]
piglet.glean.readPixSanity results file
Comment 2 dirkneukirchen 2011-11-01 08:29:21 UTC
Created attachment 53003 [details]
processed glean results via piglit-summary-html.py
Comment 3 dirkneukirchen 2011-11-01 08:30:49 UTC
Created attachment 53004 [details]
lspci -vv output
Comment 4 Ilia Mirkin 2013-08-18 18:09:18 UTC
It appears that this bug report has laid dormant for quite a while. Sorry we haven't gotten to it. Since we fix bugs all the time, chances are pretty good that your issue has been fixed with the latest software. Please give it a shot. (Linux kernel 3.10.7, xf86-video-nouveau 1.0.9, mesa 9.1.6, or their git versions.) If upgrading to the latest isn't an option for you, your distro's bugzilla is probably the right destination for your bug report.

In an effort to clean up our bug list, we're pre-emptively closing all bugs that haven't seen updates since 2011. If the original issue remains, please make sure to provide fresh info, see http://nouveau.freedesktop.org/wiki/Bugs/ for what we need to see, and re-open this one.

Thanks,

The Nouveau Team
Comment 5 dirkneukirchen 2013-08-19 06:53:31 UTC
nouveau passes this test now

Linux 3.11-rc5 and
Linux 3.8.0-27-generic (Ubuntu kernel)
with current xorg-edgers of 20130729 (mesa ...) 20130702 (libdrm-nouveau) etc.

Hardware was:
Chipset: MCP77/MCP78 (NVAA)
Family : NV50

 piglit-run.py /usr/share/piglit/tests/sanity.tests results/sanity.results 
[Mon Aug 19 06:52:29 2013] ::  running :: glean/readPixSanity
[Mon Aug 19 06:56:10 2013] ::     pass :: glean/readPixSanity
[Mon Aug 19 06:56:10 2013] ::  running :: glean/basic
[Mon Aug 19 06:56:12 2013] ::     pass :: glean/basic

nouveau.debug=debug and dmesg has entries:
[342440.398336] nouveau D[  DEVICE][0000:02:00.0][0x80000080][f23fd840] illegal class 0xa06f
[342440.398340] nouveau D[  DEVICE][0000:02:00.0][0x80000080][f23fd840] illegal class 0x906f

I don't know if that is important.
Comment 6 Ilia Mirkin 2013-08-19 11:23:11 UTC
(In reply to comment #5)
> nouveau.debug=debug and dmesg has entries:
> [342440.398336] nouveau D[  DEVICE][0000:02:00.0][0x80000080][f23fd840]
> illegal class 0xa06f
> [342440.398340] nouveau D[  DEVICE][0000:02:00.0][0x80000080][f23fd840]
> illegal class 0x906f
> 
> I don't know if that is important.

Appears to be a side-effect of how nouveau_chan.c:nouveau_channel_ind works -- it goes down the list of channel classes until it finds one that works. Those are the nve0/nvc0 class ids (which nvaa obviously doesn't support).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.