Bug 99813

Summary: F1 2015 rendering broken at medium quality
Product: Mesa Reporter: Eero Tamminen <eero.t.tamminen>
Component: Drivers/DRI/i965Assignee: Intel 3D Bugs Mailing List <intel-3d-bugs>
Status: NEW --- QA Contact: Intel 3D Bugs Mailing List <intel-3d-bugs>
Severity: normal    
Priority: medium CC: jjardon
Version: git   
Hardware: Other   
OS: All   
i915 platform: i915 features:
Bug Depends on:    
Bug Blocks: 77449    
Attachments: Race track aerial view (before race start)
View from the car (at race start)
During benchmark run

Description Eero Tamminen 2017-02-14 14:17:08 UTC
Created attachment 129595 [details]
Race track aerial view (before race start)

Test setup:
- Ubuntu 16.04
- Today's Mesa Git
- Steam & F1 2015 game installed

- Start F1 2015 with the latest Mesa version
- From advanced graphics options, select "medium" quality
- Restart F1 2015 so that graphics options take effect
- Start Quick Race

Actual outcome:
- Most of the game graphics are missing, or white.  See attached screenshots

- Only warning I see, is Mesa SSO warning about things potentially not being GL ES 3.1 compatible, although game uses GL 4.5 context...
- With "high" quality, graphics are visible, but many screen elements flicker
- With Mesa 11.2 (i.e. GL 3.3), objects are visible with "medium" quality, but flicker like with Mesa git at "high" quality, and game is much more slower
- DiRT Showdown, which uses earlier 2.0 version of EGO engine instead of 3.0, looks fine

I can provide apitrace of the issue if needed.
Comment 1 Eero Tamminen 2017-02-14 14:17:51 UTC
Created attachment 129599 [details]
View from the car (at race start)
Comment 2 Kenneth Graunke 2017-02-14 22:33:12 UTC
Works for me...
Comment 3 Eero Tamminen 2017-02-15 11:12:26 UTC
I also tested "Low" quality advanced graphics setting, and it has the same problem as "Medium".

(In reply to Kenneth Graunke from comment #2)
> Works for me...

Interesting.  What HW & distro (X & kernel) you are using?

I assume you're using latest version of the game from Steam, and verified [1] that game actually uses latest Mesa git version?

[1] e.g. Mesa 11.2 worked better, and I've found that LD_LIBRARY_PATH doesn't work with all Steam versions & game setup scripts because some of them can add system paths before user defined ones.

I've checked what libraries program actually uses with:
  awk '{print $6}' /proc/PID/maps | sort -u

Nowadays I just "mount --bind" my own Mesa versions over system ones instead of using LD_LIBRARY_PATH.

I forgot to mention Video options.

I've tested these not to affect anything:
- At startup selecting season 2015
- Video mode options:
  - 1920x1080 resolution
  - fullscreen mode
  - Vsync off

"Ultra high" / "High" advanced gfx option + Video AA render "OKish", but overlay graphics are updated on screen maybe 10x more frequently than track & cars (= really slowly on SKL GT2).

Without AA, they have the same problems as Low & Medium.  Enabling AA for Low/Medium doesn't help.
Comment 4 Matt Turner 2017-03-23 23:42:36 UTC
Seems like an apitrace would be useful.
Comment 5 Eero Tamminen 2017-03-27 15:11:44 UTC
Tried this on SKL GT4e with latest Mesa and latest Ubuntu 16.04 updates and I cannot reproduce the issue with any quality level.

I'll try later whether I can still reproduce the issue on SKL GT2 (at least with older Mesa version).

In the meanwhile, I'll mail link to the apitrace.
Comment 6 Javier Jardón 2017-05-21 15:01:49 UTC
Same problem here with Arch:

- mesa 17.1.0
- llvm 4.0.0

GPU is:
- Intel Corporation Iris Graphics 540 [8086:1926]
Comment 7 Eero Tamminen 2017-05-22 07:32:37 UTC
(In reply to Javier Jardón from comment #6)
> Same problem here with Arch:
> - mesa 17.1.0
> - llvm 4.0.0
> GPU is:
> - Intel Corporation Iris Graphics 540 [8086:1926]

Interesting,  your device is SKL GT3e, and Mesa 17.1 was branched after I found out that I wasn't able to reproduce the issue on SKL GT4e (I still hadn't had time to re-test this on SKL GT2 with different Mesa versions).

Do you see the problem only in medium quality or also at other quality levels?
Comment 8 Eero Tamminen 2017-07-03 15:37:56 UTC
Created attachment 132410 [details]
During benchmark run

I can still reproduce part of the problem with SKL GT2, although it wasn't reproducible with SKL GT4e.

Issue isn't anymore quite as bad as it was originally.

One can now see what's on screen, it's just that the main game content gets to screen only at random intervals while the UI elements (ones visible in the "race start" screenshot) seem to be updated every frame.  One actually sees multiple overlapping versions of the same UI elements (e.g. of the track minimap in the new attachment).

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.