Bug 77449 - Tracker bug for all bugs related to Steam titles
Summary: Tracker bug for all bugs related to Steam titles
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 66067 68527 75911 76484 77596 79417 80018 86720 91969 92557 92755 92999 93475 93840 95308 98238 98239 98272 98693 98795 98848 98856 98996 99136 99656 99730 99762 99813 99923 99995 100019 100089 100166 100239 68690 72902 74700 76664 76749 76858 77207 77589 79373 79948 80419 80500 80584 83908 84155 84570 84663 86747 87076 87364 87389 88780 88781 89377 91342 92059 92944 93528 96602 96622 96762 97340 97890 98263 99194
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-14 20:31 UTC by Ian Romanick
Modified: 2017-03-22 16:59 UTC (History)
10 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Romanick 2014-04-14 20:31:06 UTC
As the summary says, this is a tracker bug for everything related to Steam and SteamOS.  I was going to accomplish this with a keyword, but those are not quite as generic as I had thought.
Comment 1 Kertesz Laszlo 2014-04-18 07:52:19 UTC
The worst bug i encountered is bug #77589:

[r600g] Source engine game stopped working (bisected)

Presumably all Source-based games fail to start, usually giving a black screen and keeping a CPU @100%. If Steam was launched from the console, there is no output related to the game engine initialization etc.

Seems that commit 70cf6639c331342619e65c46db925d115bf51920 introduced this.

Reproduced on RV770,  AMD Radeon HD 6570, HD 8570D, Radeon HD 7750, so its not r600g specific.

HL1 based mods seem to work (at least Day of Defeat does).
Comment 2 Alex Deucher 2014-04-18 13:22:21 UTC
(In reply to comment #1)
> The worst bug i encountered is bug #77589:
> 
> [r600g] Source engine game stopped working (bisected)
> 
> Presumably all Source-based games fail to start, usually giving a black
> screen and keeping a CPU @100%. If Steam was launched from the console,
> there is no output related to the game engine initialization etc.
> 
> Seems that commit 70cf6639c331342619e65c46db925d115bf51920 introduced this.
> 
> Reproduced on RV770,  AMD Radeon HD 6570, HD 8570D, Radeon HD 7750, so its
> not r600g specific.
> 
> HL1 based mods seem to work (at least Day of Defeat does).

It's fixed now.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.