Bug 10006 - pycairo-1.2.6 does not support automake >= 1.10
Summary: pycairo-1.2.6 does not support automake >= 1.10
Alias: None
Product: pycairo
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Steve Chaplin
QA Contact:
Depends on: 9566
  Show dependency treegraph
Reported: 2007-02-16 20:55 UTC by Michel Salim
Modified: 2007-04-06 01:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Michel Salim 2007-02-16 20:55:06 UTC
Pycairo's autogen.sh specifies a minimum version of automake and aclocal of 1.9, and performs string comparison against the installed version. This breaks with 1.10, since "1.10" < "1.9"
Comment 1 Steve Chaplin 2007-02-25 16:22:38 UTC
pycairo uses the cairo autogen.sh. The cairo bug has already been reported:
When its fixed pycairo can synchronise with cairo to gain the same fix.
Comment 2 Behdad Esfahbod 2007-04-03 13:58:50 UTC
I have updated cairo's autogen.sh to work.  It's copied from gnome's, ripping unneeded stuff.  Frele fre eto copy.
Comment 3 Steve Chaplin 2007-04-06 01:49:30 UTC
Synchronized autogen.sh with the new cairo autogen.sh
(I assume this fixes the problem. I don't have automake 1.10 installed so am unable to test it)

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.