Bug 100203 - [BDW] i915: GPU hang with intel_iommu=on
Summary: [BDW] i915: GPU hang with intel_iommu=on
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 100076 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-03-14 18:51 UTC by stsp2
Modified: 2017-08-01 22:20 UTC (History)
3 users (show)

See Also:
i915 platform: BDW
i915 features: GPU hang


Attachments
dmesg (77.60 KB, text/plain)
2017-03-14 18:51 UTC, stsp2
no flags Details
lspci (9.22 KB, text/plain)
2017-03-14 18:52 UTC, stsp2
no flags Details
/sys/class/drm/card0/error (37.34 KB, text/plain)
2017-03-14 18:53 UTC, stsp2
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description stsp2 2017-03-14 18:51:39 UTC
Created attachment 130221 [details]
dmesg

With intel_iommu=on in command line, GPU hangs at
boot, after which, the entire machine freeze happens.
I managed to retrieve logs by using "linux=single" -
it helps to avoid the full machine freeze sometimes
(maybe because X doesn't start then), but its still
a blank screen.

intel_iommu=on,igfx_off fixes the problem but I guess
this will not allow to pass-through the video card,
is this correct?
Comment 1 stsp2 2017-03-14 18:52:52 UTC
Created attachment 130222 [details]
lspci
Comment 2 stsp2 2017-03-14 18:53:33 UTC
Created attachment 130223 [details]
/sys/class/drm/card0/error
Comment 3 stsp2 2017-03-14 18:59:40 UTC
There are a few similar reports in this bugzilla,
but please note that my dmesg ends with Oops. So
probably it gives more info.
Comment 4 Elizabeth 2017-06-27 19:31:53 UTC
Adding tag into "Whiteboard" field - ReadyForDev
*Status is correct
*Platform is included
*Feature is included
*Priority and Severity correctly set
*Logs included
Comment 5 Elizabeth 2017-06-27 19:50:41 UTC
*** Bug 100076 has been marked as a duplicate of this bug. ***
Comment 6 Elizabeth 2017-07-31 20:01:59 UTC

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.