Bug 100209 - [KBL][drm] GPU HANG: ecode 9:0:0xe6ccd35a, reason: Hang on render ring, action: reset
Summary: [KBL][drm] GPU HANG: ecode 9:0:0xe6ccd35a, reason: Hang on render ring, actio...
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-15 04:51 UTC by James
Modified: 2017-09-07 20:26 UTC (History)
1 user (show)

See Also:
i915 platform: KBL
i915 features: GPU hang


Attachments
/sys/class/drm/card1/error dump (586.20 KB, text/plain)
2017-03-15 04:51 UTC, James
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description James 2017-03-15 04:51:37 UTC
Created attachment 130226 [details]
/sys/class/drm/card1/error dump

When trying to boot in Fedora 25 on an z270/i7700k using the iGPU I received these errors: I do have intel_iommu=on. With IOMMU off I do not recieve the errors, however I need IOMMU on to be able to pass GPUs to virtual machines for workloads. Please let me know if there is any other information I need to provide. Thanks!

[   20.225344] DMAR: DRHD: handling fault status reg 3
[   20.225351] DMAR: [DMA Read] Request device [00:02.0] fault addr 70002000 [fault reason 05] PTE Write access is not set
[   20.225366] DMAR: DRHD: handling fault status reg 3
[   20.225370] DMAR: [DMA Read] Request device [00:02.0] fault addr 70002000 [fault reason 05] PTE Write access is not set
[   20.225378] DMAR: DRHD: handling fault status reg 3
[   20.225381] DMAR: [DMA Read] Request device [00:02.0] fault addr 70002000 [fault reason 05] PTE Write access is not set
[   20.225385] DMAR: DRHD: handling fault status reg 3
[   20.225388] DMAR: [DMA Read] Request device [00:02.0] fault addr 70002000 [fault reason 05] PTE Write access is not set
[   20.225392] DMAR: DRHD: handling fault status reg 3
[   20.225395] DMAR: [DMA Read] Request device [00:02.0] fault addr 70003000 [fault reason 05] PTE Write access is not set
[   20.225403] DMAR: DRHD: handling fault status reg 3
[   20.225406] DMAR: [DMA Read] Request device [00:02.0] fault addr 70003000 [fault reason 05] PTE Write access is not set
[   20.225410] DMAR: DRHD: handling fault status reg 3
[   20.225413] DMAR: [DMA Read] Request device [00:02.0] fault addr 70003000 [fault reason 05] PTE Write access is not set
[   20.225421] DMAR: DRHD: handling fault status reg 3
[   20.225424] DMAR: [DMA Read] Request device [00:02.0] fault addr 70003000 [fault reason 05] PTE Write access is not set
[   20.225428] DMAR: DRHD: handling fault status reg 3
[   20.225431] DMAR: [DMA Read] Request device [00:02.0] fault addr 70003000 [fault reason 05] PTE Write access is not set
[   20.225440] DMAR: DRHD: handling fault status reg 3
[   20.225443] DMAR: [DMA Read] Request device [00:02.0] fault addr 70004000 [fault reason 05] PTE Write access is not set
[   20.225865] [drm] GPU HANG: ecode 9:0:0xe6ccd35a, reason: Hang on render ring, action: reset
[   20.225866] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[   20.225867] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[   20.225868] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[   20.225869] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[   20.225870] [drm] GPU crash dump saved to /sys/class/drm/card1/error
[   20.225928] drm/i915: Resetting chip after gpu hang
[   20.226369] [drm] RC6 on
[   20.243177] [drm] GuC firmware load skipped
[   32.703325] drm/i915: Resetting chip after gpu hang
[   32.703755] [drm] RC6 on
[   32.720449] [drm] GuC firmware load skipped
[   44.735330] drm/i915: Resetting chip after gpu hang
[   44.735747] [drm] RC6 on
[   44.752549] [drm] GuC firmware load skipped
Comment 1 Elizabeth 2017-06-27 19:24:40 UTC
Hello James,
Is the bug still present with the last kernel version? If so,could you please attach dmesg with drm.debug=0xe parameter on grub. Thank you.
Comment 2 Elizabeth 2017-08-31 19:52:13 UTC

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.