Bug 100212 - Implement vload_* and vstore_* to make Theano/libgpuarray working
Summary: Implement vload_* and vstore_* to make Theano/libgpuarray working
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 99553 100105
  Show dependency treegraph
 
Reported: 2017-03-15 11:48 UTC by Vedran Miletić
Modified: 2018-02-06 18:54 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vedran Miletić 2017-03-15 11:48:48 UTC
We miss at least vload_half and vstore_half_rtn.
Comment 1 Siarhei 2017-03-20 03:52:55 UTC
Vedran Miletic, are there any summary of required functions?
I've tried to use luxmark on opencl-mesa with this backend
and it also requires vload_half.
Comment 4 Jan Vesely 2017-09-14 20:06:52 UTC
(In reply to Vedran Miletić from comment #0)
> We miss at least vload_half and vstore_half_rtn.

vstore_half/vload_half is in libclc. I can't find vstore_half_rtn used in either blender-2.78 or 2.79.
Comment 5 Jan Vesely 2018-02-06 18:54:41 UTC
vstore_half_rtn was added in libclc r324374.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.