Bug 100216 - xdg-email: Must not url-encode subject for Thunderbird
Summary: xdg-email: Must not url-encode subject for Thunderbird
Status: RESOLVED MOVED
Alias: None
Product: Portland
Classification: Unclassified
Component: xdg-utils (show other bugs)
Version: 1.1.0 rc3
Hardware: All Linux (All)
: medium normal
Assignee: Portland Bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-15 16:00 UTC by h.goebel
Modified: 2019-02-16 13:38 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Scrrenshot of Thunderbird subject when running xdg-email --utf8 --subject "Hällö" (5.14 KB, image/png)
2017-03-15 16:00 UTC, h.goebel
Details
Screenshot as of 2018-06-20 (3.16 KB, image/png)
2018-06-20 08:28 UTC, h.goebel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description h.goebel 2017-03-15 16:00:03 UTC
Created attachment 130232 [details]
Scrrenshot of Thunderbird subject when running xdg-email --utf8 --subject "Hällö"

Creating a mail with Thunderbird using

   xdg-email --subject "Hällö"

or

  xdg-email --utf8 --subject "Hällö"

gives a subject of

  H%E4ll%F6

(see attached picture).

I would expect the Subject to be "Hällö".

Environment:
- Thunderbird 38.3.0
- de_DE.UTF-8  (any other UTF-8 locale should do)
Comment 1 Gabriel Corona 2018-05-09 19:03:22 UTC
Tried to reproduce this but it's working correctly. Can you still reproduce this?
Comment 2 h.goebel 2018-06-20 08:28:13 UTC
Created attachment 140244 [details]
Screenshot as of 2018-06-20

As of 2018-06-20 the behaviour as changed but is still wrong for both with and without `--utf-8`. See new screenshot. It looks like xdg-open passes a latin-1 character code.

* xdg-utils 1.1.3
* thunderbird 52.8.0
  - menu: view -> text encoding: "unicode"
  - preferences: Display -> Formatting -> Fints & Colors -> Advanced 
     -> Text Encoding -> Outgoing: Unicode (UTF-8)
* system's locale is set to UTF-8
Comment 3 GitLab Migration User 2019-02-16 13:38:43 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xdg/xdg-utils/issues/106.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.