Bug 100369 - [BAT][BSW] igt@kms_flip@basic-flip-vs-wf_vblank fails in CI
Summary: [BAT][BSW] igt@kms_flip@basic-flip-vs-wf_vblank fails in CI
Status: CLOSED DUPLICATE of bug 100368
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-24 09:27 UTC by Martin Peres
Modified: 2018-03-02 15:08 UTC (History)
1 user (show)

See Also:
i915 platform: BSW/CHT
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2017-03-24 09:27:42 UTC
The machine fi-bsw-n3050 produced a fail when running igt@kms_flip@basic-flip-vs-wf_vblank on CI_DRM_2392 and has not been seen for the past 3 runs.

Relevant hunk in the piglit logs:
(kms_flip:9897) DEBUG: flip ts/seq: last 723.172150/41316, current 723.355633/41327: elapsed=183483.0us expected=183484.1us +- 917.4us, error 0.0%
(kms_flip:9897) CRITICAL: Test assertion failure function check_state, file kms_flip.c:538:
(kms_flip:9897) CRITICAL: Failed assertion: es->current_seq == es->last_seq + o->seq_step
(kms_flip:9897) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_flip:9897) CRITICAL: unexpected flip seq 41327, expected 41326

Raw results: https://intel-gfx-ci.01.org/CI/CI_DRM_2392/fi-hsw-4770/igt@kms_flip@basic-flip-vs-wf_vblank.html
Comment 1 Martin Peres 2017-03-24 09:28:57 UTC
Selecting the platform and updating the importance.

Fixed link to the raw results: https://intel-gfx-ci.01.org/CI/CI_DRM_2392/fi-bsw-n3050/igt@kms_flip@basic-flip-vs-wf_vblank.html
Comment 2 Chris Wilson 2017-03-24 10:05:28 UTC
Note that the run this failed on was a KASAN test, i.e. the kernel was a bit slower than normal.
Comment 3 Martin Peres 2017-03-29 11:28:23 UTC
Dropping the priority, since it is only seen with KASAN. It needs to be fixed though!
Comment 4 Ricardo 2017-05-09 19:32:37 UTC
Adding tag into "Whiteboard" field - ReadyForDev
The bug still active
*Status is correct
*Platform is included
*Feature is included
*Priority and Severity correctly set
*Logs included
Comment 5 Elizabeth 2017-06-23 22:27:47 UTC
(In reply to Martin Peres from comment #3)
> Dropping the priority, since it is only seen with KASAN. It needs to be
> fixed though!

Hello,
It seems that this bugs need more time, so I'm changing to NEEDINFO. Thank you.
Comment 6 Elizabeth 2017-10-11 16:30:45 UTC
No updates on this case. According to https://intel-gfx-ci.01.org/tree/drm-tip/fi-bsw-n3050.html, the test haven't failed on a while, and there is no track of the issue on https://intel-gfx-ci.01.org/cibuglog/.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.