Bug 100383 - [i915][BYT] Black screen in mainstream kernel 4.11.rc3 on Toshiba LX0W-C64
Summary: [i915][BYT] Black screen in mainstream kernel 4.11.rc3 on Toshiba LX0W-C64
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Denis
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-25 07:47 UTC by Denis
Modified: 2017-09-27 17:06 UTC (History)
1 user (show)

See Also:
i915 platform: BSW/CHT
i915 features: display/DSI


Attachments
dmesg from kernel 4.11.0-rc3 with drm-intel-next-2017-03-20 (212.60 KB, text/plain)
2017-03-25 07:47 UTC, Denis
no flags Details
dmesg from kernel 4.11.0-rc3 with kernel params from 96571 (359.35 KB, text/plain)
2017-03-29 20:20 UTC, Denis
no flags Details
Dmesg from 4.11.0-994 with drm-intel-nightly/2017-03-31 (452.64 KB, text/x-log)
2017-03-31 08:56 UTC, Denis
no flags Details
Dmesg from drm-tip 2017-04-16 (186.75 KB, text/plain)
2017-04-17 15:42 UTC, Denis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis 2017-03-25 07:47:52 UTC
Created attachment 130446 [details]
dmesg from kernel 4.11.0-rc3 with drm-intel-next-2017-03-20

The screen is going black after switching to inteldrmfb. I`ve tested kernel 4.11.0-rc3 and 4.11.0-rc3 with drm-intel-next-2017-03-20, result is same. With kernel from Linuxium there is still black screen, but I can control brightness blindly (there is folder '/sys/class/backlight/intel_backlight', when in 4.11.0-rc3 in folder /sys/class/backlight there are 8 folders from acpi_video0 to acpi_video7). Kernel 4.8.x which goes with Ubuntu 16.10 is working fine, but there isn`t brightness control. I`ve also tested latest Arch linux with Gnome DE on wayland, same issue (Black screen even on TTY`s, without loading DE).
Architecture: x86_64
Kernel: 4.11.0-041100rc3-generic
Linux distribution: Ubuntu 16.10
Machine or mother board model: Toshiba Satellite Click 10 (LX0W-C64 model), Cherry trail cpu, X5-Z8300
Dispay connector: DSI-1, as Xrandr says.
Xrandr --verbose: http://pastebin.com/KP7dnMjz
Comment 2 Jani Nikula 2017-03-27 19:01:24 UTC
Please reopen if changing the kernel config as described in bug 96571 does not help.

*** This bug has been marked as a duplicate of bug 96571 ***
Comment 3 Denis 2017-03-29 20:20:27 UTC
Created attachment 130552 [details]
dmesg from kernel 4.11.0-rc3 with kernel params from 96571
Comment 4 Denis 2017-03-29 20:21:39 UTC
It still won`t work with those kernel parameters. Dmesg: https://bugs.freedesktop.org/attachment.cgi?id=130552
Comment 5 Jani Nikula 2017-03-30 07:08:38 UTC
Please also try drm-tip branch of https://cgit.freedesktop.org/drm/drm-tip, there are some fixes that haven't made their way to v4.11-rc.
Comment 6 Denis 2017-03-31 08:54:25 UTC
Result with mainline 2017-03-31 Ubuntu kernel build is same, black screen and "*ERROR* Failed to own the pwm chip" in dmesg.
Comment 7 Denis 2017-03-31 08:56:22 UTC
Created attachment 130612 [details]
Dmesg from 4.11.0-994 with drm-intel-nightly/2017-03-31
Comment 8 russianneuromancer 2017-03-31 16:55:20 UTC
Please try this http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/2017-03-31/ and report results.

It helps me with Dell Venue 8 Pro 5855.
Comment 9 russianneuromancer 2017-03-31 17:16:48 UTC
For some reason this build boot for me only with "drm.debug=0x1e log_buf_len=1M" kernel options. Without it tablet hang in the middle of boot process and then poweroff.
Comment 10 russianneuromancer 2017-04-01 07:47:16 UTC
I just noticed that you already tested 2017-03-31 build and it's doesn't help you. So your issue is different from mine. Sorry for noise.
Comment 11 Denis 2017-04-17 15:42:32 UTC
Created attachment 130877 [details]
Dmesg from drm-tip 2017-04-16

I`ve built Ubuntu kernel with latest drm and config options from bug 96571. PWM error is gone but the screen is still black.
Comment 12 russianneuromancer 2017-06-16 05:53:20 UTC
Denis, is there no changes with current Linux 4.12 and current drm-tip?
Comment 13 Elizabeth 2017-06-23 22:00:29 UTC
(In reply to russianneuromancer from comment #12)
> Denis, is there no changes with current Linux 4.12 and current drm-tip?

Changing status to NEEDINFO. Thanks.
Comment 14 Elizabeth 2017-08-24 21:51:05 UTC
Hello Denis, no new cases since April have been reported, is this still reproducible? Thank you.
Comment 15 Elizabeth 2017-09-27 17:06:32 UTC
(In reply to Elizabeth from comment #14)
> Hello Denis, no new cases since April have been reported, is this still
> reproducible? Thank you.
Hello, closing due to no new sights of this problem reported since April, assuming fixed in newer kernel versions. If problem arise again please file a new bug with HW and SW information and relevant logs. Thank you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.