Bug 100562 - u_debug_stack.c:59: undefined reference to `_Ux86_64_getcontext'
Summary: u_debug_stack.c:59: undefined reference to `_Ux86_64_getcontext'
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-04-04 18:57 UTC by Vinson Lee
Modified: 2017-04-05 00:21 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2017-04-04 18:57:58 UTC
mesa: 6ca46c3d779b06d09bcb6b09177e2d5fa6f43488 (master 17.1.0-devel)

  CXXLD    libGL.la
../../../../src/gallium/auxiliary/.libs/libgallium.a(u_debug_stack.o): In function `debug_backtrace_capture':
src/gallium/auxiliary/util/u_debug_stack.c:59: undefined reference to `_Ux86_64_getcontext'
src/gallium/auxiliary/util/u_debug_stack.c:60: undefined reference to `_ULx86_64_init_local'
src/gallium/auxiliary/util/u_debug_stack.c:62: undefined reference to `_ULx86_64_step'
src/gallium/auxiliary/util/u_debug_stack.c:71: undefined reference to `_ULx86_64_get_proc_info'
src/gallium/auxiliary/util/u_debug_stack.c:73: undefined reference to `_ULx86_64_get_proc_name'
src/gallium/auxiliary/util/u_debug_stack.c:65: undefined reference to `_ULx86_64_step'
Comment 1 Vinson Lee 2017-04-04 21:23:43 UTC
70c272004f727457e852ba5f2498754b07a7d995 is the first bad commit
commit 70c272004f727457e852ba5f2498754b07a7d995
Author: Rob Clark <robdclark@gmail.com>
Date:   Fri Mar 24 16:07:03 2017 -0400

    gallium/util: libunwind support
    
    It's kinda sad that (a) we don't have debug_backtrace support on !X86
    and that (b) we re-invent our own crude backtrace support in the first
    place.  If available, use libunwind instead.  The backtrace format is
    based on what xserver and weston use, since it is nice not to have to
    figure out a different format.
    
    Signed-off-by: Rob Clark <robdclark@gmail.com>
    Acked-by: Nicolai Hähnle <nicolai.haehnle@amd.com>

:100644 100644 70885fb9a6bf801157d36a8a628b2e2e1dc15d52 016e38fb5998e485332feed42679b1974ef382e9 M	configure.ac
:040000 040000 5e2d0e742d0496433ed77efb911edc429248835a a0d0cdd211a94ef127f855ac5cd6bf5ffad19540 M	src
bisect run success
Comment 2 Vinson Lee 2017-04-05 00:21:10 UTC
commit c161a104629ad49dc6a4f7d1fe82e87fc08121fe
Author: Vinson Lee <vlee@freedesktop.org>
Date:   Tue Apr 4 14:52:39 2017 -0700

    libgl-xlib: Link with libunwind.
    
    Fix linking error.
    
      CXXLD    libGL.la
    ../../../../src/gallium/auxiliary/.libs/libgallium.a(u_debug_stack.o): In function `debug_backtrace_capture':
    src/gallium/auxiliary/util/u_debug_stack.c:59: undefined reference to `_Ux86_64_getcontext'
    src/gallium/auxiliary/util/u_debug_stack.c:60: undefined reference to `_ULx86_64_init_local'
    src/gallium/auxiliary/util/u_debug_stack.c:62: undefined reference to `_ULx86_64_step'
    src/gallium/auxiliary/util/u_debug_stack.c:71: undefined reference to `_ULx86_64_get_proc_info'
    src/gallium/auxiliary/util/u_debug_stack.c:73: undefined reference to `_ULx86_64_get_proc_name'
    src/gallium/auxiliary/util/u_debug_stack.c:65: undefined reference to `_ULx86_64_step'
    
    Fixes: 70c272004f72 ("gallium/util: libunwind support")
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=100562
    Signed-off-by: Vinson Lee <vlee@freedesktop.org>
    Reviewed-by: Rob Clark <robdclark@gmail.com>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.