Bug 100617 - [ILK][Regression bisected] Gnome Shell slow animations
Summary: [ILK][Regression bisected] Gnome Shell slow animations
Status: RESOLVED WORKSFORME
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2017-04-08 02:57 UTC by groucho
Modified: 2019-08-17 01:45 UTC (History)
1 user (show)

See Also:
i915 platform: ILK
i915 features: display/Other


Attachments
dmesg.txt (62.81 KB, text/plain)
2017-04-10 13:12 UTC, groucho
no flags Details
Xorg.0.log (20.30 KB, text/x-log)
2017-04-10 13:12 UTC, groucho
no flags Details
dmesg with drm.debug=0xe (106.46 KB, text/plain)
2017-04-10 15:20 UTC, groucho
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description groucho 2017-04-08 02:57:17 UTC
Hi,
I have installed Debian Stretch on a Thinkpad X201 (ironlake) and Gnome Shell's animations aren't smooth anymore (30fps max, and lag easily especially on an external monitor).

I have tried uxa and sna dri2/dri3, modesetting, wayland, with similar results.
I have also checked Fedora.


I was previously using Debian Jessie and the animations were a lot smoother (60fps max, though only with uxa/dri2).


I have made a bisect on Debian Jessie and have found that the animations aren't smooth anymore after 
commit 6db906ea8188cd7f731e5ef7391115ee8f5c17c8
uxa/dri2: Reimplement triple buffer support

Unfortunately I failed to test the old driver on Debian Stretch.

So I don't know if it is a Gnome or a driver issue.

Or maybe some driver settings might fix it ?
Comment 1 Jari Tahvanainen 2017-04-10 07:07:50 UTC
Groucho, please attach the full dmesg and Xorg.0.log all the way from boot.
Comment 2 groucho 2017-04-10 13:12:13 UTC
Created attachment 130776 [details]
dmesg.txt
Comment 3 groucho 2017-04-10 13:12:35 UTC
Created attachment 130777 [details]
Xorg.0.log
Comment 4 groucho 2017-04-10 13:33:06 UTC
I have attached dmesg and Xorg.0.log from debian 8 jessie with uxa/dri2 (dri3 disabled) and the latest backported driver (after the commit).
With the default drivers, the overview animation is smooth.


To sum it up :

smooth animations (60fps) :
- debian 8 jessie with uxa and dri2 (default)

non smooth animations (under 30fps) :
- debian 8 jessie with any other settings (sna for example) and the default driver
- debian 8 jessie with any settings (even uxa dri2) and the backported driver (after the commit)
- debian 9 stretch, any settings (wayland seems different : it looks like 60fps with just one window, but the fps drop with more windows)
- fedora 25, same as debian 9



It would be great to have the smoothness back with at least uxa/dri2. Or even better, with all the settings.
Comment 5 groucho 2017-04-10 15:20:42 UTC
Created attachment 130780 [details]
dmesg with drm.debug=0xe
Comment 6 Elizabeth 2017-06-22 17:57:04 UTC
Adding tag into "Whiteboard" field - ReadyForDev
*Status is correct
*Platform is included
*Feature is included
*Priority and Severity correctly set
*Logs included
Comment 7 groucho 2017-06-22 22:13:35 UTC
In case it is relevant, I also made some tests with gnome shell perf tool.

Here are the results before the commit:

# Frames rate when going to the overview, 10 alpha-transparent windows open
overviewFps10Alpha 57.1958508496
# Frames rate when going to the overview, 10 maximized windows open
overviewFps10Maximized 55.6326022944
# Frames rate when going to the overview, 10 windows open
overviewFps10Windows 57.4456144692
# Frames rate when going to the overview, 5 alpha-transparent windows open
overviewFps5Alpha 59.5006703742
# Frames rate when going to the overview, 5 maximized windows open
overviewFps5Maximized 63.1220148547
# Frames rate when going to the overview, 5 windows open
overviewFps5Windows 59.9046318261
# Frame rate when going to the overview, first time
overviewFpsFirst 60.7995136039
# Frames rate when going to the overview, second time
overviewFpsSubsequent 61.0242306879


And these are the results after:

# Frames rate when going to the overview, 10 alpha-transparent windows open
overviewFps10Alpha 23.271418431739114
# Frames rate when going to the overview, 10 maximized windows open
overviewFps10Maximized 24.078399268016664
# Frames rate when going to the overview, 10 windows open
overviewFps10Windows 23.188853890896443
# Frames rate when going to the overview, 5 alpha-transparent windows open
overviewFps5Alpha 28.9440387684725
# Frames rate when going to the overview, 5 maximized windows open
overviewFps5Maximized 29.45074363127669
# Frames rate when going to the overview, 5 windows open
overviewFps5Windows 30.20155764533556
# Frame rate when going to the overview, first time
overviewFpsFirst 33.18856796070474
# Frames rate when going to the overview, second time
overviewFpsSubsequent 36.14858514437745



Although 30fps may sound good, Gnome often has performance hits and animations drop below 15fps.
It feels really slow compared to the previous situation : Gnome was dropping from 60fps to ~30fps.


I also want to correct my comment 4 about Wayland, it was not 60fps with a single Window. The animations look the same as Xorg.
Comment 8 Jani Saarinen 2018-03-29 07:11:20 UTC
First of all. Sorry about spam.
This is mass update for our bugs. 

Sorry if you feel this annoying but with this trying to understand if bug still valid or not.
If bug investigation still in progress, please ignore this and I apologize!

If you think this is not anymore valid, please comment to the bug that can be closed.
If you haven't tested with our latest pre-upstream tree(drm-tip), can you do that also to see if issue is valid there still and if you cannot see issue there, please comment to the bug.
Comment 9 Jani Saarinen 2018-04-25 06:41:38 UTC
Closing, please re-open is issue still exists.
Comment 10 groucho 2018-04-25 14:45:49 UTC
I have tested drm-tip from 2018-04-25.
The situation hasn't changed.


I guess I should have opened it as soon as the regression was introduced, unfortunately I was using Debian at the time. The machine is old now, and I imagine it is going to have less and less attention from the developers.


I still don't know why the frame rate is halved. Is it the drm or gnome-shell/mutter/clutter? I wish I could help, but I am not sure how to debug this.

I only know that my experience with Gnome was very good with Debian Jessie and UXA (hence the bisection). So I assume the hardware is capable enough.
KDE Plasma doesn't have this issue at all, in any mode (modesetting, UXA, SNA...).

I also don't have this issue on a Sandy Bridge. Only on my Ironlake.
Comment 11 groucho 2019-08-17 01:45:34 UTC
I have tested gnome-shell and mutter with the latest performance patches.
gnome-shell-perf-tool is reporting results that are close to the ones I had with the old UXA driver.

So I guess I can close this bug report.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.