Bug 100678 - OpenChrome V0.6 shows garbled graphics when switching to tty consoles
Summary: OpenChrome V0.6 shows garbled graphics when switching to tty consoles
Status: RESOLVED WORKSFORME
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/openchrome (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Kevin Brace
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-13 22:19 UTC by Marty
Modified: 2019-02-10 16:41 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marty 2017-04-13 22:19:02 UTC
Hi Kevin,

After compiling and installing OpenChrome V0.6 (according to your tutorial) I have got the problem that the tty consoles don't work anymore. It looks like the display gets wrong (too high?) resolution commands. When I press Ctrl-Alt-F1 the screen seems to slowly "fade out". It is always possible to get back to a working X-Screen with Ctrl-Alt-F7.

My system:
Fujitsu Siemens Amilo Li 1705
VIA VN896 chipset
lubuntu 14.04 (upgraded to 14.04.5, but I didn't use a point release, so it is not a HWE version)

Regards,
Martin
Comment 1 Kevin Brace 2017-04-15 07:23:37 UTC
Hi Marty,

You can keep this bug report and Bug 100679 separate.
In some ways, the root cause is ultimately the same (i.e., OpenChrome DDX is not properly mode setting the FP for your particular FP hardware configuration), but if you have to upload data, you can upload it for Bug 100679.
    If I were to give one advise, you can also attach a separate monitor if you wanted to run the via_regs_dump utility after the FP gets messed up.
I did fix many dual monitor issues during the past two releases (Version 0.5 and 0.6), so you should be able to use it without issues.
Installing ARandR from Synaptic can be very helpful during this debug process.
ARandR allows you to move the view port of the screen to certain coordinates.
For example, you can assign FP as your top screen and VGA as your bottom screen.
If you use 32-bit color mode (default), you are limited to 2044 dots for the X total resolution.
The only way to overcome this is to use 16-bit color mode, and this will allow you to have two monitors side by side (X total resolution goes up to around 4088 dots if I remember it correctly.).
Comment 2 Kevin Brace 2019-01-11 00:59:16 UTC
Marty, can you try out OpenChrome DDX Version 0.6.181?

https://cgit.freedesktop.org/openchrome/xf86-video-openchrome/commit/?id=03b085dc6da11e3dc5bd3d41934247659eb4cdc2

I put in several fixes to deal with VT switching, particularly after standby resume.
If the fix solves the issue, can you close the bug?
Comment 3 Eric 2019-01-11 03:15:03 UTC
Try to update to 0.6.181, as this has helped alot.

You can also try the kernel option:

nofb

Which I have found necessary on multiple machines to get the tty consoles to work properly.  

This is something to add to the grub kernel line when you boot by hitting 'e'. 
On syslinux systems, such as knoppix, add this to the 'boot:' prompt (ie: knoppix nofb) 
--------------------------------------------
On Fri, 1/11/19,  <bugzilla-daemon@freedesktop.org> wrote:

 Subject: [openchrome-devel] [Bug 100678] OpenChrome V0.6 shows garbled graphics when switching to tty consoles
 To: openchrome-devel@lists.freedesktop.org
 Date: Friday, January 11, 2019, 12:59 AM
 
 
       
         
             Comment
 # 2
               on bug
 100678
               from  Kevin Brace
 
         Marty, can you try out OpenChrome DDX Version
 0.6.181?
 
 https://cgit.freedesktop.org/openchrome/xf86-video-openchrome/commit/?id=03b085dc6da11e3dc5bd3d41934247659eb4cdc2
 
 I put in several fixes to deal with VT switching,
 particularly after standby
 resume.
 If the fix solves the issue, can you close the bug?
         
       
 
 
       
       You are receiving this mail
 because:
 
       You are on the CC list for the
 bug.
    
 _______________________________________________
 openchrome-devel mailing list
 openchrome-devel@lists.freedesktop.org
 https://lists.freedesktop.org/mailman/listinfo/openchrome-devel
 
 -----Inline Attachment Follows-----
Comment 4 Marty 2019-01-27 16:30:59 UTC
Hi Kevin and Eric,

I tried DDX Version 0.6.182 but it didn't change anything. On the consoles I still get a very disturbed image, as if the synchronization is wrong. I also added nofb to the boot parameters, but still the same.

I use that old Notebook not very often anymore. And as I seem to have little special hardware please feel free to close the bug.

Cheers,
Marty
Comment 5 Marty 2019-01-27 16:47:32 UTC
A further comment:

I can make tty consoles work when I don't use
GRUB_TERMINAL=console
in the Grub2 configuration file.

I enabled that option because otherwise I get a problem in the Grub Boot Menu: The highlighted option moves only on every second press on the up- or down arrow key. But then it moves 2 steps at once.

Marty
Comment 6 Eric 2019-02-03 00:50:51 UTC
Try this as a last resort: add this line to the kernel boot in addition to nofb

modprobe.blacklist=viafb,vt8623fb

So in total you would add:

nofb modprobe.blacklist=viafb,vt8623fb

This is what I have to add to get Knoppix running from a virgin image.

P.S. In case you can't copy/paste it, note that it's: nofb<space>modprobe<dot>blacklist<equals>viafb<comma>vt8623fb

You can:

cat /proc/cmdline

to make sure you got it from a terminal when the system is up.

--------------------------------------------
On Sun, 1/27/19,  <bugzilla-daemon@freedesktop.org> wrote:

 Subject: [openchrome-devel] [Bug 100678] OpenChrome V0.6 shows garbled graphics when switching to tty consoles
 To: openchrome-devel@lists.freedesktop.org
 Date: Sunday, January 27, 2019, 4:30 PM
 
 
       
         
             Comment
 # 4
               on bug
 100678
               from  Marty
 
         Hi Kevin and Eric,
 
 I tried DDX Version 0.6.182 but it didn't change
 anything. On the consoles I
 still get a very disturbed image, as if the synchronization
 is wrong. I also
 added nofb to the boot parameters, but still the same.
 
 I use that old Notebook not very often anymore. And as I
 seem to have little
 special hardware please feel free to close the bug.
 
 Cheers,
 Marty
         
       
 
 
       
       You are receiving this mail
 because:
 
       You are on the CC list for the
 bug.
    
 _______________________________________________
 openchrome-devel mailing list
 openchrome-devel@lists.freedesktop.org
 https://lists.freedesktop.org/mailman/listinfo/openchrome-devel
 
 -----Inline Attachment Follows-----
Comment 7 Marty 2019-02-10 16:41:58 UTC
Hi Eric,

I tried it but it didn't change anything.

I am fine with how it works currently:
-> tty terminals work (at least when I enable graphical grub)
-> standby/resume works

The only side effect I have with the current DDX is a somehow 16 bit color behaviour (Bug 101395), but this isn't a big problem for me because in most applications I don't even recognize it.

Best regards,
Martin


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.