Bug 100695 - Texture artifacts in Deus Ex: Mankind Divided
Summary: Texture artifacts in Deus Ex: Mankind Divided
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-16 17:37 UTC by Hadrien Nilsson
Modified: 2017-04-25 20:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Main menu screen with an unreadable title (326.35 KB, image/jpeg)
2017-04-16 17:37 UTC, Hadrien Nilsson
Details
Loading screen glitches (1.23 MB, image/png)
2017-04-22 21:44 UTC, Hadrien Nilsson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hadrien Nilsson 2017-04-16 17:37:14 UTC
Created attachment 130861 [details]
Main menu screen with an unreadable title

Hi,

I've got glitches in Deus Ex: Mankind Divided that appeared some days ago. See the screenshot were the title is unreadable.

OS: Ubuntu 17.04
Linux kernel version: 4.10.0-19-generic
cpu: Intel i7-6700K
gpu: Amd RX 480
Mesa version: 1:17.1~git170417001000.9f0dd85~z~padoka0
Comment 1 Michel Dänzer 2017-04-17 07:39:51 UTC
Could be a duplicate of bug 100681.
Comment 2 Hadrien Nilsson 2017-04-18 19:48:50 UTC
(In reply to Michel Dänzer from comment #1)
> Could be a duplicate of bug 100681.

Probably, radv also gives me glitches in The Talos Principle.

Today I updated Mesa to version 1:17.2~git170417160400.ba6c451~z~padoka0 and the glitches are still there. The llvm SVN revision stays at r300374.

I built the llvm trunk but I have no idea how to ask Mesa to use the build result (are .so or lib.a used?). If you have any tutorial to run a specific llvm version with Mesa I would be interested.
Comment 3 Michel Dänzer 2017-04-19 03:52:41 UTC
Until bug 100681 is fixed, updating to newer snapshots won't help if it's caused by the same problem. The most likely culprit so far is LLVM r300023.
Comment 4 Michel Dänzer 2017-04-21 00:45:44 UTC
Bug 100681 was fixed by LLVM SVN r300791, how about this?
Comment 5 Hadrien Nilsson 2017-04-22 13:41:13 UTC
(In reply to Michel Dänzer from comment #4)
> Bug 100681 was fixed by LLVM SVN r300791, how about this?

I got an update of the padoka package today. It ships with llvm-5.0 r301038 but unfortunately the problem is still there :(
Comment 6 network723 2017-04-22 19:53:21 UTC
I can't reproduce this with opensuse + RX480 + Mesa-git 17.2 (d1608d6982) + llvm 5.0 revision 300864 + linux 4.10.11
Comment 7 Hadrien Nilsson 2017-04-22 21:44:53 UTC
Created attachment 130984 [details]
Loading screen glitches

Other screenshot showing glitches
Comment 8 Hadrien Nilsson 2017-04-22 21:53:53 UTC
Some in-game bad textures disappeared. The Talos Principle is fixed too. I think those glitches were actually related to bug 100681. The textures looked dirty, but they were not complete garbage as seen in the screenshots attached to this bug. So now I think it is a different problem.

So far I have only seen the glitch on user interface textures.

I am still learning to build my own version of Mesa with a specific version of LLVM in order to find the bad revision.
Comment 9 Hadrien Nilsson 2017-04-25 20:33:56 UTC
I uninstalled padoka packages and reinstalled plain mesa 17.0.3 from Ubuntu 17.04.

I then reinstalled padoka and the problem is gone.

I will probably never know what happened. Anyway, I'm closing the bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.