Bug 1007 - Hangs during server startup
Summary: Hangs during server startup
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: git
Hardware: Other Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 351
  Show dependency treegraph
 
Reported: 2004-08-07 13:31 UTC by Sjoerd Simons
Modified: 2004-08-24 00:31 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Move tmp_mode = tmp_mode->next ; out of the if, so it always advances (789 bytes, patch)
2004-08-11 11:13 UTC, Sjoerd Simons
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Sjoerd Simons 2004-08-07 13:31:20 UTC
During Xorg startup on my powerbook G4 (Radeon  9600 M10) the server hangs just
using 100% cpu.

After some digging i found it hangs in the loop that starts on line 1347 of
radeon_driver.c (cvs revision 1.15). Moving the tmp_mode = tmp_mode->next; out
of the if () {} fixes the hanging..

Unfortunately it still doesn't give the nice X start screen.
Comment 1 Sjoerd Simons 2004-08-11 11:13:03 UTC
Created attachment 607 [details] [review]
Move tmp_mode = tmp_mode->next ; out of the if, so it always advances
Comment 2 Alex Deucher 2004-08-19 05:50:43 UTC
You may want to check cvs.  I thought this patch was already included in a
larger one already applied.
Comment 3 Sjoerd Simons 2004-08-19 12:24:18 UTC
Just checked CVS, the problem is definitely still there.
Comment 4 Michel Dänzer 2004-08-21 08:24:16 UTC
The fix is correct, please apply Kevin.
Comment 5 Kevin E. Martin 2004-08-24 17:31:08 UTC
Thanks for the patch.
It has been checked in.
Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.