Bug 100789 - Mesa (Padoka Pkppa), Textures become corrupt in counterstrike 1.6 and in steam overlay after indeterminate amount of time
Summary: Mesa (Padoka Pkppa), Textures become corrupt in counterstrike 1.6 and in stea...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 19.0
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-25 21:13 UTC by calexil
Modified: 2019-09-18 20:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
screen 1 (315.74 KB, image/jpeg)
2017-04-25 21:13 UTC, calexil
Details
screen 2 (211.59 KB, image/jpeg)
2019-05-06 20:10 UTC, calexil
Details
screen 3 (317.17 KB, image/jpeg)
2019-05-06 20:11 UTC, calexil
Details
screen 4 (238.75 KB, image/jpeg)
2019-05-06 20:11 UTC, calexil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description calexil 2017-04-25 21:13:26 UTC
Created attachment 131024 [details]
screen 1

for more info see here:

https://github.com/ValveSoftware/halflife/issues/1794#issuecomment-296652022

My Setup:
Motherboard : MSI 970A-G46
Processor : AMD FX-8350 4Ghz Octocore
Cooling : Cooler Master Hyper 212 Evo
Memory : 16GB PNY-XLR8 DDR3 1600Mhz 9-9-9-27
Operating System : Linux Mint 18.1 Serena
Display : Asus 24in Lcd 1920x1080
Video Card : XFX Radeon R9 380X
Graphics Driver : Amdgpu+Mesa 17
Keyboard : Noppoo Lolita Spyder 104
Mouse : Mad Catz R.A.T.7 Gaming Mouse
Microphone :CAD U37 USB Studio Condenser
Webcam :Logitech UVC Camera 720p
HDD : WD Blue 1TB
SSD : OCZ-VERTEX3
PSU : Rosewill Photon 750
Streaming Output Info : Streaming with Open Broadcaster Software, 720p60fps 2.5Mbps
Comment 1 Michel Dänzer 2017-04-26 01:31:16 UTC
Is this a regression from older versions of Mesa? If so, can you bisect Mesa or at least narrow down the version where the problem first appeared?
Comment 2 calexil 2017-04-26 18:47:18 UTC
(In reply to Michel Dänzer from comment #1)
> Is this a regression from older versions of Mesa? If so, can you bisect Mesa
> or at least narrow down the version where the problem first appeared?

it's been happening for quite a while, since 13 ish
Comment 3 Timothy Arceri 2019-05-06 04:45:35 UTC
Is this still an issue in recent mesa?
Comment 4 calexil 2019-05-06 17:30:45 UTC
yes, in fact I was just playing cs 1.6 last night and it was happening.
Comment 5 calexil 2019-05-06 17:31:08 UTC
I'm on the padoka pkppa version of mesa and llvm
Comment 6 calexil 2019-05-06 20:10:58 UTC
Created attachment 144177 [details]
screen 2
Comment 7 calexil 2019-05-06 20:11:34 UTC
Created attachment 144178 [details]
screen 3
Comment 8 calexil 2019-05-06 20:11:52 UTC
Created attachment 144179 [details]
screen 4
Comment 9 Timothy Arceri 2019-07-09 06:06:07 UTC
I'm confused. Those new screen shots don't appear to have any problem. What are you trying to show?
Comment 10 calexil 2019-07-09 22:04:49 UTC
you don't see the blocked single colors where textures should be, for example in de_nuke at the ramp the guide rail should be a metal lattice, not a solid red block
Comment 11 GitLab Migration User 2019-09-18 20:26:00 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1010.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.