Bug 100790 - [REGRESSION] Civilization VI start screen rendered incorrectly with Mesa 17.1-rc2 on Skylake GT2
Summary: [REGRESSION] Civilization VI start screen rendered incorrectly with Mesa 17.1...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.1
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-25 23:06 UTC by Bernhard Rosenkraenzer
Modified: 2018-07-11 07:46 UTC (History)
8 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Garbled screen (247.33 KB, image/png)
2017-04-25 23:06 UTC, Bernhard Rosenkraenzer
Details
apitrace (2.76 MB, application/octet-stream)
2017-05-18 18:16 UTC, Thomas Krause
Details
Batch for misrendered draw call (41.68 KB, text/plain)
2017-05-19 05:16 UTC, Mark Janes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2017-04-25 23:06:44 UTC
Created attachment 131026 [details]
Garbled screen

The Civilization VI start screen (unfortunately, so far I haven't found a way to reproduce this using only open code) is displayed incorrectly (see attached screenshot) with Mesa 17.1-rc2.

Mesa 17.0.4 works well.

Graphics card is:
00:02.0 0300: 8086:191b (rev 06) (prog-if 00 [VGA controller])
        Subsystem: 1025:105b
        Flags: bus master, fast devsel, latency 0, IRQ 126
        Memory at 82000000 (64-bit, non-prefetchable) [size=16M]
        Memory at 90000000 (64-bit, prefetchable) [size=256M]
        I/O ports at b000 [size=64]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

Linux kernel 4.11-rc5, libdrm 2.4.80, latest released Xorg bits.
Comment 1 Kenneth Graunke 2017-04-27 22:01:51 UTC
Can you provide an apitrace that reproduces the problem?
Comment 2 Thomas Krause 2017-05-18 18:16:49 UTC
Created attachment 131409 [details]
apitrace

I recorded a trace of this (I see the same behaviour as the original reporter). 
While playing the game the blue colours are also present at a multiple of places. The trace is heavily trimmed because it would have been too big otherwise, but the last frame still contains the observed behaviour.

I'm using Mesa 17.1.0 from https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkppa/ and a Intel Kaby Lake integrated graphics. The problem occurred after the game itself was updated. Funny enough Mac OSX users are seeing this, too (http://steamcommunity.com/app/289070/discussions/0/340412628172881722/?ctp=53#c1319961618830923344)
Comment 3 Mark Janes 2017-05-19 04:57:46 UTC
With this trace, I see blue when using mesa 17.0.6.
Comment 4 Mark Janes 2017-05-19 05:02:50 UTC
Also, MacOS uses a completely different OpenGL driver (closed source, based on LLVM).  It seems likely to me that an application bug was introduced into Civilization.
Comment 5 Mark Janes 2017-05-19 05:16:56 UTC
Created attachment 131412 [details]
Batch for misrendered draw call

I've attached the batch submitted to the GPU that results in the blue text.  Perhaps Ken or Jason can figure out if there is anything in the texture state that is suspicious.
Comment 6 Thomas Krause 2017-10-27 16:30:00 UTC
This appears to be fixed in the 17.3.0-rc1 release (I used the Padoka Stable PPA https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkppa/ to install this version). Tested under Ubuntu 17.10 and an Intel HD Graphics 620.
Comment 7 phw 2017-12-29 16:34:55 UTC
Still experiencing the exactly same rendering issues with mesa 17.3.1 on Arch Linux.
Comment 8 Andriy Khulap 2018-01-30 10:49:02 UTC
Looks like I have the same hardware:
- Intel(R) HD Graphics 530 (Skylake GT2)  (0x191b)
- Ubuntu 16.04 LTS (Kernel 4.13.0-32-generic)

Tested the apitrace with the noted mesa versions and got contradictory results:
mesa-17.0.4 (git 367bafc7c153) - distorted (the same as attached picture).
mesa-17.0.6 (git 08abf3a2a2ca) - distorted.
mesa-17.3.1 (git 4f5e85e9e97d) - correct.
mesa master (git d0343bef6680) - correct.

Older versions (17.0.0 and 13.0.6) also shows distorted colors. So I'm not seeing regression. Anyway, this issue is fixed on my system.
Comment 9 Denis 2018-03-22 14:58:16 UTC
Hi. Had a chance to check 2 build version and looks like found commit where this bug was fixed. All information below:



Configuration:

Dual core Intel Core i7-7500U 	
Intel® HD Graphics 620 	
Kaby Lake

Kernel: 4.13.0-37-generic x86_64 (64 bit)
Distro: Ubuntu 16.04 xenial


Tested versions:

17.0.0 - reproduced
17.1.0-rc2 - reproduced
17.2.8 - reproduced
17.3.0-rc1 - not reproduced
17.3.0-rc4 - not reproduced
17.3.0 - not reproduced
18.1.0 - not reproduced

Bisected between mesa-17.2.8 and mesa-17.3.0-rc1
This issue was fixed with commit:

commit dffda6cbbbc1a8c2f7125db1b9cf15fbcdc8eb11
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date: Tue Jun 6 09:58:07 2017 -0700

i965: Use blorp instead of meta for PBO texture uploads

Reviewed-by: Topi Pohjolainen <topi.pohjolainen@intel.com>
Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
Comment 10 Vladimir Los 2018-04-02 14:52:20 UTC
(In reply to phw from comment #7)
> Still experiencing the exactly same rendering issues with mesa 17.3.1 on
> Arch Linux.

NOT reproduced

Mesa 17.3.1
kernel 4.14.30-1-MANJARO x86_64
Distro: Manjaro Linux 17.1.7 Hakoila 
Intel Core i5-3470 MCP
Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller driver: i915 v: kernel
Comment 11 Mark Janes 2018-07-10 15:35:43 UTC
This should have been closed when the fix was bisected.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.