Bug 100865 - Unigine Heaven 4 lockups GPU in wireframe mode
Summary: Unigine Heaven 4 lockups GPU in wireframe mode
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
Depends on:
Reported: 2017-04-28 11:46 UTC by Marc Dietrich
Modified: 2019-09-18 19:23 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

dmesg output (16.05 KB, text/plain)
2017-04-28 11:46 UTC, Marc Dietrich

Description Marc Dietrich 2017-04-28 11:46:26 UTC
Created attachment 131115 [details]
dmesg output

launched UH4 on RS880 / Kernel 4.10.10 with mesa git
demo runs well until you press "F2" in order to activate wireframe mode, which causes GPU lockups

tested mesa: 12, 13, 17, 17.1 and git - all same.
Comment 1 Dieter Nützel 2017-04-28 14:32:35 UTC
Hello Marc,

can you please verify, that it is a _combination_ of wireframe _and_ tessellation?
I've got that for ages with r600g, RV730 (HD 4650, 1GB, AGP) and NI/Turks XT (HD 6670, 2 GB PCIe). As 'Heaven' (UH4) start 'normally' with tessellation enabled and 'you' press 'F2' (enable wireframe) it could result in GPU lockup. So please start 'Heaven', press 'F3' (disable tessellation) and last press 'F2' (enable wireframe). This 'version' works fine for me. It seems to be a combination of both. But my systems mostly recover from the GPU lockup.
W'll try to get a new backtrace, soon.

Tessellation is so awfully _slow_ (hardware or 'only' software implemantation) that I think we have to look/point, there.

Bas (Radv) worked on radeonsi tessellation improvements.
See related links:


I ran all the time with MESA_GL_VERSION_OVERRIDE=4.1COMPAT and 'Heaven' show display corruption (missing parts), but wireframe works. If I toggle tessellation (F3) missing parts arise but without tessellation, as expected.
So for 'Heaven' I have to disable MESA_GL_VERSION_OVERRIDE and get the above boom (GPU lockup).

=> tessellation / wireframe correlation

'All' old and Mesa git, Kernel 4.11-rc8 (and former)

Comment 2 Marc Dietrich 2017-04-29 10:04:49 UTC
My card does not support tess and I also disabled it in the launcher. Also my card is only GL3.3.
Comment 3 Marc Dietrich 2017-04-29 16:54:34 UTC
I ran apitrace on heaven_x64 and now the thing doesn't crash anymore :-( So maybe commands come to fast in wireframe mode and need some fence/sync point?
Comment 4 GitLab Migration User 2019-09-18 19:23:04 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/600.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.