Bug 100953 - [ARUBA] Light shaders is very bright in GRID Autosport on Radeon 8470D
Summary: [ARUBA] Light shaders is very bright in GRID Autosport on Radeon 8470D
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: 17.1
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-06 01:01 UTC by russianneuromancer
Modified: 2019-09-18 19:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
GRID Autosport on Radeon 8470D (387.80 KB, image/png)
2017-05-06 01:01 UTC, russianneuromancer
Details
Bright track lights on PITCAIRN (1.32 MB, image/png)
2018-10-05 10:38 UTC, Heiko
Details
No bright track lights on POLARIS (1.32 MB, image/png)
2018-10-05 10:39 UTC, Heiko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description russianneuromancer 2017-05-06 01:01:22 UTC
Created attachment 131234 [details]
GRID Autosport on Radeon 8470D

Hello!
Please look into attached screenshot. 
This issue is not reproducible on Radeon HD 6650M.

Software:
Kubuntu 17.0 x86_64
Linux 4.10
Mesa: 17.1.0rc2
libdrm: 2.4.80
xserver-xorg-video-radeon: 7.9.0
xserver-xorg-core: 1.19.3

Hardware: 
AMD A6-6400K with Radeon HD 8470D (ARUBA)
Comment 1 Heiko 2018-10-05 10:37:20 UTC
I have a similar problem on PITCAIRN. For me it's not just bright car reflections but also bright track lights, making driving somewhat difficult. I've got an apitrace, though still need to upload it. But I'll attach some screenshots for now.

About the card:
OpenGL renderer string: AMD Radeon(TM) HD 8800 Series (PITCAIRN, DRM 3.26.0, 4.18.12-arch1-1-ARCH, LLVM 7.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.2.1
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL version string: 4.4 (Compatibility Profile) Mesa 18.2.1
OpenGL shading language version string: 4.40
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

The apitrace renders correctly on this POLARIS with nearly identical software:
OpenGL renderer string: AMD Radeon (TM) RX 480 Graphics (POLARIS10, DRM 3.26.0, 4.18.11-arch1-1-ARCH, LLVM 7.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.2.1
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL version string: 4.4 (Compatibility Profile) Mesa 18.2.1
OpenGL shading language version string: 4.40
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
Comment 2 Heiko 2018-10-05 10:38:20 UTC
Created attachment 141912 [details]
Bright track lights on PITCAIRN
Comment 3 Heiko 2018-10-05 10:39:00 UTC
Created attachment 141913 [details]
No bright track lights on POLARIS
Comment 4 Heiko 2018-10-05 10:42:10 UTC
Darn, I just noticed that these aren't track lights, but flags. That matches the graphics settings: If setting rendering option "CLOTH" to "High", the issue appears. If setting it to "Low", the issue disappears.
Comment 5 Heiko 2018-10-05 11:06:00 UTC
The apitrace can be found under https://www.dropbox.com/s/283tyeu4eqbc20r/GridAutosport.trace.xz

This is '-benchmarkAttract' with graphics preset "Low" and "CLOTH" on "High".

As mentioned before: Renders fine on POLARIS, exhibits 'glowing flags' on PITCAIRN
Comment 6 GitLab Migration User 2019-09-18 19:23:10 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/601.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.