Bug 100992 - vblank wait timed out on crtc 0 after screen lock on Dell Latitude e6220
Summary: vblank wait timed out on crtc 0 after screen lock on Dell Latitude e6220
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
Depends on:
Reported: 2017-05-10 19:40 UTC by Thomas Nilefalk
Modified: 2017-07-27 16:52 UTC (History)
1 user (show)

See Also:
i915 platform: SNB
i915 features: display/atomic


Description Thomas Nilefalk 2017-05-10 19:40:53 UTC
After a screen lock, the screen hangs, with the following stack dump in dmesg:

[46276.425098] WARNING: CPU: 0 PID: 4082 at /build/linux-FyIZxz/linux-4.4.0/drivers/gpu/d
[46276.425103] vblank wait timed out on crtc 0
[46276.425107] Modules linked in: rfcomm arc4 md4 nls_utf8 cifs fscache bnep dell_wmi spa_smm_hwmon wl(POE) snd_hda_codec_hdmi irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulr cryptd snd_hda_intel uvcvideo cdc_ncm snd_hda_codec usbnet videobuf2_vmalloc mii videoboydev media btrtl btbcm snd_seq_midi btintel snd_seq_midi_event bluetooth snd_rawmidi inp
[46276.425219]  dell_smo8800 mac_hid parport_pc ppdev lp parport autofs4 hid_generic usbhpci libahci sdhci ptp pps_core wmi fjes video
[46276.425266] CPU: 0 PID: 4082 Comm: Xorg Tainted: P        W  OE   4.4.0-77-generic #98
[46276.425270] Hardware name: Dell Inc. Latitude E6220/0R97MN, BIOS A12 06/28/2013
[46276.425274]  0000000000000286 0000000070ffd816 ffff8800c385bb08 ffffffff813f8493
[46276.425282]  ffff8800c385bb50 ffffffffc009db38 ffff8800c385bb40 ffffffff81081302
[46276.425288]  ffff8800356c4000 0000000000000000 0000000000000000 000000000002cc9d
[46276.425295] Call Trace:
[46276.425307]  [<ffffffff813f8493>] dump_stack+0x63/0x90
[46276.425318]  [<ffffffff81081302>] warn_slowpath_common+0x82/0xc0
[46276.425325]  [<ffffffff8108139c>] warn_slowpath_fmt+0x5c/0x80
[46276.425337]  [<ffffffff810c3da5>] ? finish_wait+0x55/0x70
[46276.425375]  [<ffffffffc006d2b5>] drm_wait_one_vblank+0x1b5/0x1c0 [drm]
[46276.425386]  [<ffffffff810c4240>] ? wake_atomic_t_function+0x60/0x60
[46276.425471]  [<ffffffffc0235e3a>] intel_atomic_commit+0x43a/0x6f0 [i915]
[46276.425519]  [<ffffffffc0087037>] drm_atomic_commit+0x37/0x60 [drm]
[46276.425545]  [<ffffffffc018fdc6>] drm_atomic_helper_set_config+0x76/0xb0 [drm_kms_help
[46276.425581]  [<ffffffffc0075e12>] drm_mode_set_config_internal+0x62/0x100 [drm]
[46276.425614]  [<ffffffffc007a46c>] drm_mode_setcrtc+0x3cc/0x4f0 [drm]
[46276.425642]  [<ffffffffc006b722>] drm_ioctl+0x152/0x540 [drm]
[46276.425672]  [<ffffffffc007a0a0>] ? drm_mode_setplane+0x1b0/0x1b0 [drm]
[46276.425681]  [<ffffffff81222c6f>] do_vfs_ioctl+0x29f/0x490
[46276.425689]  [<ffffffff8108e5a1>] ? __set_task_blocked+0x41/0xa0
[46276.425696]  [<ffffffff81090f36>] ? __set_current_blocked+0x36/0x60
[46276.425702]  [<ffffffff81222ed9>] SyS_ioctl+0x79/0x90
[46276.425712]  [<ffffffff8183b972>] entry_SYSCALL_64_fastpath+0x16/0x71
[46276.425717] ---[ end trace 6929fd69fa421ae3 ]---

I've seen multiple bug reports with similar effect, but the workaround has been "video=SVIDEO-1:d" as boot parameters, but this does not affect my case. Also, the other reports, such as  bug 93782, includes 'intel_tv_detect' which mine does not.

I originally filed this here:https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1689651, where I've filed many logs.

But will try to build drm-tip and make sure it still is there (although bug 93782 seems to indicate that it is), and report back here.
Comment 1 Thomas Nilefalk 2017-05-10 19:56:26 UTC
This always happens after a screen lock, making the machine unusable since there is no remedy except to reboot.

This is on a Dell Latitude e6220 with
- 4.4.0-77-generic
- 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

(one thing that seems a bit strange is that the e6220 uses Intel HD Graphics 3000 as a part of its Sandy Bridge according to https://www.notebookcheck.net/Dell-Latitude-E6220-Laptop-Review.63744.0.html, but the logs refer to i915, is that normal?)
Comment 2 Thomas Nilefalk 2017-05-11 15:54:25 UTC
I've confirmed that this problem does not occur with a 4.2.0-040200-generic kernel.
Comment 3 Thomas Nilefalk 2017-05-16 19:42:50 UTC
I've also tried kernel 4.12.0-041200rc1 and it seems to not exhibit this problem.
Comment 4 Ricardo 2017-05-23 19:34:04 UTC
if the issue is not visible in newer kernel its because there has been work done around atomic that may have solved your issue.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.