Bug 101037 - nouveau: crash when starting chrome
Summary: nouveau: crash when starting chrome
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-14 08:51 UTC by Michal Suchanek
Modified: 2019-10-14 13:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
kernel log piieces showiing the error (23.18 KB, text/plain)
2017-05-14 08:59 UTC, Michal Suchanek
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Suchanek 2017-05-14 08:51:21 UTC
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G98 [Quadro NVS 295] [10de:06fd] (rev a1)
Linux 4.10.0-trunk-amd64 #1 SMP Debian 4.10.7-1~exp1 (2017-03-30) x86_64 
libdrm-nouveau2 2.4.80-1
libgl1-mesa-dri 17.0.4-1
xserver-xorg-video-nouveau 1:1.0.15-1

May 14 09:34:36 iscsi kernel: [  482.205629] BUG: unable to handle kernel NULL pointer dereference at 0000000000000021
May 14 09:34:36 iscsi kernel: [  482.205629] BUG: unable to handle kernel NULL pointer dereference at 0000000000000021
May 14 09:34:36 iscsi kernel: [  482.205654] IP: dma_fence_wait_timeout+0x30/0xf0
May 14 09:34:36 iscsi kernel: [  482.205654] IP: dma_fence_wait_timeout+0x30/0xf0
May 14 09:34:36 iscsi kernel: [  482.205659] PGD 0 
May 14 09:34:36 iscsi kernel: [  482.205659] PGD 0 
May 14 09:34:36 iscsi kernel: [  482.205766] CPU: 1 PID: 1696 Comm: InputThread Tainted: G           OE   4.10.0-trunk-amd64 #1 Debian 4.10.7-1~exp1
May 14 09:34:36 iscsi kernel: [  482.205772] Hardware name:                  /DQ45CB, BIOS CBQ4510H.86A.0133.2011.0810.1010 08/10/2011
May 14 09:34:36 iscsi kernel: [  482.205777] task: ffff8a4d2c13afc0 task.stack: ffffb8c2416e0000
May 14 09:34:36 iscsi kernel: [  482.205781] RIP: 0010:dma_fence_wait_timeout+0x30/0xf0
May 14 09:34:36 iscsi kernel: [  482.205785] RSP: 0018:ffffb8c2416e3aa0 EFLAGS: 00010206
May 14 09:34:36 iscsi kernel: [  482.205789] RAX: 0000000000000001 RBX: ffff8a4c9a817480 RCX: ffffffffc07cffa0
May 14 09:34:36 iscsi kernel: [  482.205794] RDX: 7fffffffffffffff RSI: 0000000000000001 RDI: ffff8a4d2c27c600
May 14 09:34:36 iscsi kernel: [  482.205798] RBP: ffff8a4d2c27c600 R08: ffff8a4d2c3e9000 R09: 0000000000000000
May 14 09:34:36 iscsi kernel: [  482.205802] R10: ffff8a4d302763a8 R11: ffff8a4d314bb600 R12: 0000000000000001
May 14 09:34:36 iscsi kernel: [  482.205807] R13: 7fffffffffffffff R14: 0000000000000001 R15: 0000000000000001
May 14 09:34:36 iscsi kernel: [  482.205811] FS:  00007f341c83e700(0000) GS:ffff8a4d3bc80000(0000) knlGS:0000000000000000
May 14 09:34:36 iscsi kernel: [  482.205819] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
May 14 09:34:36 iscsi kernel: [  482.205823] CR2: 0000000000000021 CR3: 000000022c2bc000 CR4: 00000000000406e0
May 14 09:34:36 iscsi kernel: [  482.205828] Call Trace:
May 14 09:34:36 iscsi kernel: [  482.205843]  ? drm_atomic_helper_wait_for_fences+0x48/0x130 [drm_kms_helper]
May 14 09:34:36 iscsi kernel: [  482.205895]  ? nv50_disp_atomic_commit+0x18e/0x290 [nouveau]
May 14 09:34:36 iscsi kernel: [  482.205902]  ? drm_atomic_helper_update_plane+0xeb/0x150 [drm_kms_helper]
May 14 09:34:36 iscsi kernel: [  482.205928]  ? __setplane_internal+0x1d9/0x2a0 [drm]
May 14 09:34:36 iscsi kernel: [  482.205939]  ? drm_mode_cursor_universal+0x11c/0x200 [drm]
May 14 09:34:36 iscsi kernel: [  482.205950]  ? drm_mode_cursor_common+0x80/0x170 [drm]
May 14 09:34:36 iscsi kernel: [  482.205961]  ? drm_mode_cursor_ioctl+0x54/0x70 [drm]
May 14 09:34:36 iscsi kernel: [  482.205973]  ? drm_ioctl+0x1ea/0x470 [drm]
May 14 09:34:36 iscsi kernel: [  482.205978]  ? __schedule+0x23b/0x6f0
May 14 09:34:36 iscsi kernel: [  482.205989]  ? drm_mode_setplane+0x1a0/0x1a0 [drm]
May 14 09:34:36 iscsi kernel: [  482.205994]  ? _copy_to_user+0x4d/0x60
May 14 09:34:36 iscsi kernel: [  482.206022]  ? nouveau_drm_ioctl+0x66/0xc0 [nouveau]
May 14 09:34:36 iscsi kernel: [  482.206027]  ? do_vfs_ioctl+0x9f/0x600
May 14 09:34:36 iscsi kernel: [  482.206032]  ? __check_object_size+0xfb/0x1d9
May 14 09:34:36 iscsi kernel: [  482.206035]  ? SyS_ioctl+0x74/0x80
May 14 09:34:36 iscsi kernel: [  482.206039]  ? system_call_fast_compare_end+0xc/0x9b
May 14 09:34:36 iscsi kernel: [  482.206043] Code: 48 85 d2 41 55 41 54 55 53 0f 88 ab 00 00 00 48 89 fd 41 89 f4 49 89 d5 66 66 66 66 90 48 8b 45 08 41 0f b6 f4 4c 89 ea 48 89 ef <ff> 50 20 49 89 c4 66 66 66 66 90 5b 4c 89 e0 5d 41 5c 41 5d c3 
May 14 09:34:36 iscsi kernel: [  482.206069] RIP: dma_fence_wait_timeout+0x30/0xf0 RSP: ffffb8c2416e3aa0
Comment 1 Michal Suchanek 2017-05-14 08:59:53 UTC
Created attachment 131345 [details]
kernel log piieces showiing the error
Comment 2 Martin Peres 2019-10-14 13:20:17 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.