Bug 101093 - i915: screen goes dark on modeswitch during boot (Failed to own the pwm chip)
Summary: i915: screen goes dark on modeswitch during boot (Failed to own the pwm chip)
Status: CLOSED DUPLICATE of bug 96571
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-19 06:09 UTC by sassmann
Modified: 2017-07-07 22:56 UTC (History)
1 user (show)

See Also:
i915 platform: BYT
i915 features: display/backlight


Attachments
dmesg with debug enabled (184.28 KB, text/plain)
2017-05-19 06:09 UTC, sassmann
no flags Details
dmesg 4.12-rc3 display on (169.14 KB, text/plain)
2017-05-31 15:20 UTC, sassmann
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description sassmann 2017-05-19 06:09:40 UTC
Created attachment 131413 [details]
dmesg with debug enabled

With 4.12-rc1 the screen goes dark during boot when attempting to modeswitch. I assume the backlight is turned off. Still worked with kernel 4.11. This is on a baytrail tablet.
Comment 1 Jani Nikula 2017-05-30 12:22:03 UTC
Bisect would really be helpful here.
Comment 2 sassmann 2017-05-31 09:57:37 UTC
Indeed it would, but doing a full bisect takes way too long to compile and test. If you have a list of commits that went into 4.12-rc1 and might be relevant to test I can do a few builds and try those.
Comment 3 sassmann 2017-05-31 15:20:08 UTC
Created attachment 131605 [details]
dmesg 4.12-rc3 display on

I tried the 4.12-rc3 to check if anything has changed. Screen still goes dark most of the time. However maybe 1 in 5 boots the screen stays on with full brightness. So this might be a race. Attaching another dmesg of a successful boot with screen staying on.
Comment 4 Jani Nikula 2017-06-02 09:22:48 UTC
Did your kernel config change? Possibly dupe of bug 96571. I believe that might manifest itself as a race too.
Comment 5 sassmann 2017-06-02 09:36:21 UTC
kernel config stayed the same, no change there.
Any way for me to confirm if this is indeed a dupe of bug 96571?
I have
CONFIG_PWM_LPSS=m
CONFIG_PWM_LPSS_PCI=m
CONFIG_PWM_LPSS_PLATFORM=m

Also any patches I could test on top of 4.12? I see a lot of patch references in the other bz but not sure what's relevant.
Comment 6 Jani Nikula 2017-06-02 10:04:14 UTC
Set config options

>CONFIG_PWM=y
>CONFIG_PWM_CRC=y
>CONFIG_I2C_DESIGNWARE_PLATFORM=y
>CONFIG_I2C_DESIGNWARE_PCI=y
>CONFIG_INTEL_SOC_PMIC=y
>CONFIG_DRM_I915=m

and see if it helps.
Comment 7 sassmann 2017-06-02 11:24:55 UTC
The only difference to my config was that I had
CONFIG_I2C_DESIGNWARE_PLATFORM=m
CONFIG_I2C_DESIGNWARE_PCI=m
instead of =y.
However changing those to =y didn't make a difference.

Would any intel-gpu-tools output be useful?
Comment 8 Jani Nikula 2017-07-04 13:47:16 UTC
Seeing your comment in bug 96571, can we assume this is a dupe?
Comment 9 sassmann 2017-07-04 15:57:25 UTC
Yes, correct.
Comment 10 Elizabeth 2017-07-04 19:55:23 UTC
(In reply to sassmann from comment #9)
> Yes, correct.

Marking as duplicated. Please keep following the case on 96571 . Thank you.

*** This bug has been marked as a duplicate of bug 96571 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.