Bug 101236 - [IGT] [BDW] some gem_exec_whisper failed causing gpu hung! (vbe_init() failed with -22)
Summary: [IGT] [BDW] some gem_exec_whisper failed causing gpu hung! (vbe_init() failed...
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-30 16:11 UTC by Humberto Israel Perez Rodriguez
Modified: 2017-09-07 20:24 UTC (History)
1 user (show)

See Also:
i915 platform: BDW
i915 features: GEM/execlists


Attachments
dmesg.log (88.20 KB, text/plain)
2017-05-30 16:11 UTC, Humberto Israel Perez Rodriguez
no flags Details
kern.log (285.58 KB, text/plain)
2017-05-30 16:11 UTC, Humberto Israel Perez Rodriguez
no flags Details
fds-chain_test_output (67.22 KB, text/plain)
2017-08-24 16:11 UTC, Elizabeth
no flags Details
blt-fds-forked_test_output (20.58 KB, text/plain)
2017-08-24 16:12 UTC, Elizabeth
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Humberto Israel Perez Rodriguez 2017-05-30 16:11:25 UTC
Created attachment 131574 [details]
dmesg.log

The following test cases causes gpu hung on BDW with latest configuration

Test cases
=======================================
igt@gem_exec_whisper@fds-chain
igt@gem_exec_whisper@blt-fds-forked

Test output
=======================================
(gem_exec_whisper:1445) igt-aux-CRITICAL: Test assertion failure function sig_abort, file igt_aux.c:443:
(gem_exec_whisper:1445) igt-aux-CRITICAL: Failed assertion: !"GPU hung"
Stack trace:
  #0 [__igt_fail_assert+0x101]
  #1 [sig_abort+0x3a]
  #2 [killpg+0x40]
  #3 [__wait+0x1e]
  #4 [igt_waitchildren+0x68]
  #5 [whisper+0x1f9]
  #6 [__real_main532+0x2e6]
  #7 [main+0x33]
  #8 [__libc_start_main+0xf1]
  #9 [_start+0x29]
  #10 [<unknown>+0x29]
Subtest blt-fds-forked failed.
**** DEBUG ****
(gem_exec_whisper:1445) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_exec_whisper:1445) DEBUG: Test requirement passed: gem_has_ring(fd, engine)
(gem_exec_whisper:1445) DEBUG: Test requirement passed: gem_can_store_dword(fd, engine)
(gem_exec_whisper:1445) DEBUG: Test requirement passed: nengine
(gem_exec_whisper:1445) DEBUG: Test requirement passed: gen >= 6
(gem_exec_whisper:1445) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_exec_whisper:1445) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_exec_whisper:1445) igt-aux-CRITICAL: Test assertion failure function sig_abort, file igt_aux.c:443:
(gem_exec_whisper:1445) igt-aux-CRITICAL: Failed assertion: !"GPU hung"
****  END  ****
Subtest blt-fds-forked: FAIL (8.173s)
(gem_exec_whisper:1445) igt-core-DEBUG: Exiting with status code 99



Software versions
=======================================
architecture                : x86_64
os version                  : Ubuntu 16.10
os codename                 : yakkety
kernel driver               : i915
bios revision               : 5.6
bios release date           : 05/29/2015

Component: drm
    tag: libdrm-2.4.80-18-gce9e3ba
    commit: ce9e3ba6e2cc65e1e9e6e05a5f326c4dd25ab2c4

Component: cairo
    tag: 1.15.4-22-g0fd0fd0
    commit: 0fd0fd0ae9ad8cfb177bb844091de98c0235917e

Component: intel-gpu-tools
    tag: intel-gpu-tools-1.18-211-g00ce341
    commit: 00ce341b95c718611689ded8ccec45086186c5b7

Component: piglit
    tag: piglit-v1
    commit: ebbb9c5dcc6a637884d54e06eb430a8c14993413

	
Kernel version
=========================================
commit 75397b60fe84eb5125a78a5ee304def86b761994
Author:     Chris Wilson <chris@chris-wilson.co.uk>
AuthorDate: Tue May 30 12:56:32 2017 +0100
Commit:     Chris Wilson <chris@chris-wilson.co.uk>
CommitDate: Tue May 30 12:56:32 2017 +0100

    drm-tip: 2017y-05m-30d-11h-55m-42s UTC integration manifest
	
	
Hardware
==========================================
platform                   : BDW
motherboard id             : NUC5i7RYB
form factor                : Desktop
cpu family                 : Core i7
cpu family id              : 6
cpu information            : Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz
gpu card                   : Intel Corporation Iris Graphics 6100 (rev 09) (prog-if 00 [VGA controller])
memory ram                 : 7.72 GB
max memory ram             : 16 GB
cpu thread                 : 4
cpu core                   : 2
cpu model                  : 61
cpu stepping               : 4
socket                     : Socket BGA1168
signature                  : Type 0, Family 6, Model 61, Stepping 4
hard drive                 : 447GiB (480GB)
current cd clock frequency : 337500 kHz
maximum cd clock frequency : 540000 kHz
displays connected         : HDMI-A-1 DP-1

kernel parameters
=============================================
quiet drm.debug=0xe auto panic=1 nmi_watchdog=panic resume=/dev/sda3 fastboot


Attachments
=============================================
dmesg.log
kern.log

Relevant dmesg messages :
=============================================
kern  :err   : [Tue May 30 06:08:21 2017] uvesafb: Getting VBE info block failed (eax=0x4f00, err=1)
kern  :err   : [Tue May 30 06:08:21 2017] uvesafb: vbe_init() failed with -22
Comment 1 Humberto Israel Perez Rodriguez 2017-05-30 16:11:56 UTC
Created attachment 131575 [details]
kern.log
Comment 2 Chris Wilson 2017-05-30 16:23:29 UTC
Where is the output from the test in the attached logs? Where is the GPU error state?
Comment 3 Ricardo 2017-05-30 17:02:37 UTC
Humberto, please try to also add information key like the i915 feature... and I think based on Chris comment the logs are not correct
Comment 4 Humberto Israel Perez Rodriguez 2017-07-19 19:37:19 UTC
(In reply to Chris Wilson from comment #2)
> Where is the output from the test in the attached logs? Where is the GPU
> error state?

the output from the test is in the description of this bug, the both tests never ends, and GPU error state shows "No error state collected"


Test output
=======================================
(gem_exec_whisper:1445) igt-aux-CRITICAL: Test assertion failure function sig_abort, file igt_aux.c:443:
(gem_exec_whisper:1445) igt-aux-CRITICAL: Failed assertion: !"GPU hung"
Stack trace:
  #0 [__igt_fail_assert+0x101]
  #1 [sig_abort+0x3a]
  #2 [killpg+0x40]
  #3 [__wait+0x1e]
  #4 [igt_waitchildren+0x68]
  #5 [whisper+0x1f9]
  #6 [__real_main532+0x2e6]
  #7 [main+0x33]
  #8 [__libc_start_main+0xf1]
  #9 [_start+0x29]
  #10 [<unknown>+0x29]
Subtest blt-fds-forked failed.
**** DEBUG ****
(gem_exec_whisper:1445) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_exec_whisper:1445) DEBUG: Test requirement passed: gem_has_ring(fd, engine)
(gem_exec_whisper:1445) DEBUG: Test requirement passed: gem_can_store_dword(fd, engine)
(gem_exec_whisper:1445) DEBUG: Test requirement passed: nengine
(gem_exec_whisper:1445) DEBUG: Test requirement passed: gen >= 6
(gem_exec_whisper:1445) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_exec_whisper:1445) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_exec_whisper:1445) igt-aux-CRITICAL: Test assertion failure function sig_abort, file igt_aux.c:443:
(gem_exec_whisper:1445) igt-aux-CRITICAL: Failed assertion: !"GPU hung"
****  END  ****
Subtest blt-fds-forked: FAIL (8.173s)
(gem_exec_whisper:1445) igt-core-DEBUG: Exiting with status code 99
Comment 5 Chris Wilson 2017-07-28 15:51:25 UTC
DMAR is also enabled, please retest with intel_iommu=igfx_off.
Comment 6 Elizabeth 2017-08-24 16:11:22 UTC
Created attachment 133756 [details]
fds-chain_test_output
Comment 7 Elizabeth 2017-08-24 16:12:07 UTC
Created attachment 133757 [details]
blt-fds-forked_test_output
Comment 8 Elizabeth 2017-08-24 16:17:04 UTC
With intel_iommu=igfx_off the tests appear as SUCCESS.

======================================
        Graphic stack
======================================

======================================
             Software
======================================
kernel version              : 4.13.0-rc6-drm-tip-ww34-commit-ebd0ddf+
hostname                    : BDW-2-NUC5i7RYB
architecture                : x86_64
os version                  : Ubuntu 16.10
os codename                 : yakkety
kernel driver               : i915
bios revision               : 5.6
bios release date           : 05/29/2015
hardware acceleration       : disabled
swap partition              : enabled on (/dev/sda3)

======================================
        Graphic drivers
======================================
grep: /opt/X11R7/var/log/Xorg.0.log: No such file or directory
libdrm                      : 2.4.82
cairo                       : 1.15.7
intel-gpu-tools (tag)       : intel-gpu-tools-1.19-197-g42b42c9
intel-gpu-tools (commit)    : 42b42c9

======================================
             Hardware
======================================
platform                   : Broadwell
motherboard id             : NUC5i7RYB
form factor                : Desktop
cpu family                 : Core i7
cpu family id              : 6
cpu information            : Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz
gpu card                   : Intel Corporation Iris Graphics 6100 (rev 09) (prog-if 00 [VGA controller])
memory ram                 : 7.68 GB
max memory ram             : 16 GB
cpu thread                 : 4
cpu core                   : 2
cpu model                  : 61
cpu stepping               : 4
socket                     : Socket BGA1168
signature                  : Type 0, Family 6, Model 61, Stepping 4
hard drive                 : 447GiB (480GB)
current cd clock frequency : 337500 kHz
maximum cd clock frequency : 540000 kHz
displays connected         : HDMI-A-1 DP-1

======================================
             Firmware
======================================

======================================
             kernel parameters
======================================
quiet drm.debug=0xe auto panic=1 nmi_watchdog=panic resume=/dev/sda3 fastboot intel_iommu=igfx_off
Comment 9 Chris Wilson 2017-08-24 16:24:03 UTC

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.