Bug 101238 - [IGT] [BDW] gem_render_copy_redux subtest normal/interruptible Test assertion failure function
Summary: [IGT] [BDW] gem_render_copy_redux subtest normal/interruptible Test assertion...
Status: CLOSED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Humberto Israel Perez Rodriguez
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-30 20:06 UTC by Humberto Israel Perez Rodriguez
Modified: 2017-09-07 20:24 UTC (History)
1 user (show)

See Also:
i915 platform: BDW
i915 features: display/Other


Attachments
dmesg.log (96.20 KB, text/plain)
2017-05-30 20:06 UTC, Humberto Israel Perez Rodriguez
no flags Details
kern.log (307.39 KB, text/plain)
2017-05-30 20:06 UTC, Humberto Israel Perez Rodriguez
no flags Details
interruptible_test_output (637 bytes, text/plain)
2017-08-24 16:23 UTC, Elizabeth
no flags Details
normal_test_output (623 bytes, text/plain)
2017-08-24 16:23 UTC, Elizabeth
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Humberto Israel Perez Rodriguez 2017-05-30 20:06:15 UTC
Created attachment 131578 [details]
dmesg.log

The following test cases fail on BDW with latest configuration

Test cases
=======================================
igt@gem_render_copy_redux@normal
igt@gem_render_copy_redux@interruptible


test output
=======================================
IGT-Version: 1.18-g00ce341 (x86_64) (Linux: 4.12.0-rc3-drm-tip-ww22-commit-75397b6+ x86_64)
(gem_render_copy_redux:1397) drmtest-DEBUG: Test requirement passed: !(fd<0)
(gem_render_copy_redux:1397) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(gem_render_copy_redux:1397) DEBUG: Test requirement passed: data->render_copy
(gem_render_copy_redux:1397) igt-core-DEBUG: Starting subtest: normal
(gem_render_copy_redux:1397) CRITICAL: Test assertion failure function scratch_buf_check, file gem_render_copy_redux.c:129:
(gem_render_copy_redux:1397) CRITICAL: Failed assertion: val == color
(gem_render_copy_redux:1397) CRITICAL: Expected 0xffff00ff, found 0xfff0ff00 at (502,502)
Stack trace:
  #0 [__igt_fail_assert+0x101]
  #1 [scratch_buf_check.isra.0+0x72]
  #2 [copy+0xdb]
  #3 [main+0xfb]
  #4 [__libc_start_main+0xf1]
  #5 [_start+0x29]
  #6 [<unknown>+0x29]
Subtest normal failed.
**** DEBUG ****
(gem_render_copy_redux:1397) CRITICAL: Test assertion failure function scratch_buf_check, file gem_render_copy_redux.c:129:
(gem_render_copy_redux:1397) CRITICAL: Failed assertion: val == color
(gem_render_copy_redux:1397) CRITICAL: Expected 0xffff00ff, found 0xfff0ff00 at (502,502)
****  END  ****
Subtest normal: FAIL (0.023s)
(gem_render_copy_redux:1397) igt-core-DEBUG: Exiting with status code 99
(gem_render_copy_redux:1397) igt-debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'

Software versions
=======================================
architecture                : x86_64
os version                  : Ubuntu 16.10
os codename                 : yakkety
kernel driver               : i915
bios revision               : 5.6
bios release date           : 05/29/2015

Component: drm
    tag: libdrm-2.4.80-18-gce9e3ba
    commit: ce9e3ba6e2cc65e1e9e6e05a5f326c4dd25ab2c4

Component: cairo
    tag: 1.15.4-22-g0fd0fd0
    commit: 0fd0fd0ae9ad8cfb177bb844091de98c0235917e

Component: intel-gpu-tools
    tag: intel-gpu-tools-1.18-211-g00ce341
    commit: 00ce341b95c718611689ded8ccec45086186c5b7

Component: piglit
    tag: piglit-v1
    commit: ebbb9c5dcc6a637884d54e06eb430a8c14993413

	
Kernel version
=========================================
commit 75397b60fe84eb5125a78a5ee304def86b761994
Author:     Chris Wilson <chris@chris-wilson.co.uk>
AuthorDate: Tue May 30 12:56:32 2017 +0100
Commit:     Chris Wilson <chris@chris-wilson.co.uk>
CommitDate: Tue May 30 12:56:32 2017 +0100

    drm-tip: 2017y-05m-30d-11h-55m-42s UTC integration manifest
	
	
Hardware
==========================================
platform                   : BDW
motherboard id             : NUC5i7RYB
form factor                : Desktop
cpu family                 : Core i7
cpu family id              : 6
cpu information            : Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz
gpu card                   : Intel Corporation Iris Graphics 6100 (rev 09) (prog-if 00 [VGA controller])
memory ram                 : 7.72 GB
max memory ram             : 16 GB
cpu thread                 : 4
cpu core                   : 2
cpu model                  : 61
cpu stepping               : 4
socket                     : Socket BGA1168
signature                  : Type 0, Family 6, Model 61, Stepping 4
hard drive                 : 447GiB (480GB)
current cd clock frequency : 337500 kHz
maximum cd clock frequency : 540000 kHz
displays connected         : HDMI-A-1 DP-1


kernel parameters
=============================================
quiet drm.debug=0xe auto panic=1 nmi_watchdog=panic resume=/dev/sda3 fastboot

attachments
=============================================
dmesg.log
kern.log

Relevant dmesg messages
=============================================
kern  :err   : [Tue May 30 10:02:38 2017] uvesafb: Getting VBE info block failed (eax=0x4f00, err=1)
kern  :err   : [Tue May 30 10:02:38 2017] uvesafb: vbe_init() failed with -22
kern  :err   : [Tue May 30 10:04:32 2017] DMAR: DRHD: handling fault status reg 3
kern  :err   : [Tue May 30 10:04:32 2017] DMAR: [DMA Read] Request device [00:02.0] fault addr fff89000 [fault reason 05] PTE Write access is not set
Comment 1 Humberto Israel Perez Rodriguez 2017-05-30 20:06:25 UTC
Created attachment 131579 [details]
kern.log
Comment 2 Chris Wilson 2017-05-31 14:26:01 UTC
And again with intel_iommu=igfx_off ?
Comment 3 Elizabeth 2017-08-24 16:22:44 UTC
With intel_iommu=igfx_off the tests appear as SUCCESS.

======================================
        Graphic stack
======================================

======================================
             Software
======================================
kernel version              : 4.13.0-rc6-drm-tip-ww34-commit-ebd0ddf+
hostname                    : BDW-2-NUC5i7RYB
architecture                : x86_64
os version                  : Ubuntu 16.10
os codename                 : yakkety
kernel driver               : i915
bios revision               : 5.6
bios release date           : 05/29/2015
hardware acceleration       : disabled
swap partition              : enabled on (/dev/sda3)

======================================
        Graphic drivers
======================================
grep: /opt/X11R7/var/log/Xorg.0.log: No such file or directory
libdrm                      : 2.4.82
cairo                       : 1.15.7
intel-gpu-tools (tag)       : intel-gpu-tools-1.19-197-g42b42c9
intel-gpu-tools (commit)    : 42b42c9

======================================
             Hardware
======================================
platform                   : Broadwell
motherboard id             : NUC5i7RYB
form factor                : Desktop
cpu family                 : Core i7
cpu family id              : 6
cpu information            : Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz
gpu card                   : Intel Corporation Iris Graphics 6100 (rev 09) (prog-if 00 [VGA controller])
memory ram                 : 7.68 GB
max memory ram             : 16 GB
cpu thread                 : 4
cpu core                   : 2
cpu model                  : 61
cpu stepping               : 4
socket                     : Socket BGA1168
signature                  : Type 0, Family 6, Model 61, Stepping 4
hard drive                 : 447GiB (480GB)
current cd clock frequency : 337500 kHz
maximum cd clock frequency : 540000 kHz
displays connected         : HDMI-A-1 DP-1

======================================
             Firmware
======================================

======================================
             kernel parameters
======================================
quiet drm.debug=0xe auto panic=1 nmi_watchdog=panic resume=/dev/sda3 fastboot intel_iommu=igfx_off
Comment 4 Elizabeth 2017-08-24 16:23:18 UTC
Created attachment 133758 [details]
interruptible_test_output
Comment 5 Elizabeth 2017-08-24 16:23:42 UTC
Created attachment 133759 [details]
normal_test_output
Comment 6 Chris Wilson 2017-08-24 16:24:58 UTC

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.