Bug 101388 (davidjohn) - [BAT][GLK] *ERROR* The master control interrupt lied (DE PORT)!
Summary: [BAT][GLK] *ERROR* The master control interrupt lied (DE PORT)!
Status: CLOSED FIXED
Alias: davidjohn
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: highest critical
Assignee: Martin Peres
QA Contact: Intel GFX Bugs mailing list
URL: https://www.myfxbook.com/members/fore...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-12 10:46 UTC by Martin Peres
Modified: 2019-09-02 14:47 UTC (History)
2 users (show)

See Also:
i915 platform: GLK
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2017-06-12 10:46:46 UTC
When running igt@gem_exec_suspend@basic-s3 on lab-glk-2a, I get the following dmesg message:
[drm:gen8_irq_handler [i915]] ERROR The master control interrupt lied (DE PORT)!

A little after, in dmesg, we got the following messages:
[  276.426500] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 4: a600000000020408
[  276.426506] mce: [Hardware Error]: TSC 0 ADDR fef4c9a0 
[  276.426524] mce: [Hardware Error]: PROCESSOR 0:706a0 TIME 1496041922 SOCKET 0 APIC 0 microcode 18
Comment 1 Elizabeth 2017-06-12 20:54:57 UTC
Hello Martin. Could you please add the complete information of the Hardware an Software that you're using, and the steps to replicate the bug. Also if you could attach the dmesg and kern.log would be really helpful. Thanks.
Comment 2 Martin Peres 2017-06-13 08:13:48 UTC
(In reply to elizabethx.de.la.torre.mena from comment #1)
> Hello Martin. Could you please add the complete information of the Hardware
> an Software that you're using, and the steps to replicate the bug. Also if
> you could attach the dmesg and kern.log would be really helpful. Thanks.

Hey Elizabeth,

Here is all the information about the HW I can post (this is still a pre-production machine):
fi-glk-2a	Intel Gemini Lake RVP	Gemini Lake		eDP (DP,HDMI)

As for dmesg, I  do not have access to it, for some reason. I will ask internally if I can get a backup.

Anyway, the platform maintainer is also part of the same office as I am, so he has full access to the machine.
Comment 3 Ander Conselvan de Oliveira 2017-06-15 08:54:10 UTC
I'm not sure if the mce errors are related. I tried to reproduce this bug, but got only the machine checks, without the drm error.

Martin, were you able to reproduce this more than once?
Comment 4 Martin Peres 2017-06-15 09:35:26 UTC
(In reply to Ander Conselvan de Oliveira from comment #3)
> I'm not sure if the mce errors are related. I tried to reproduce this bug,
> but got only the machine checks, without the drm error.
> 
> Martin, were you able to reproduce this more than once?

No, just once...

There are other issues that got hidden by this bug though...
Comment 5 Martin Peres 2017-06-15 11:40:02 UTC
(In reply to Martin Peres from comment #4)
> (In reply to Ander Conselvan de Oliveira from comment #3)
> > I'm not sure if the mce errors are related. I tried to reproduce this bug,
> > but got only the machine checks, without the drm error.
> > 
> > Martin, were you able to reproduce this more than once?
> 
> No, just once...
> 
> There are other issues that got hidden by this bug though...

This is the error that got hidden:
[drm:skl_check_pipe_max_pixel_rate [i915]] *ERROR* Max supported pixel clock with scaling exceeded

It was seen on CI_DRM_2680/81/82 and nothing since, so I will not file a bug for it.
Comment 6 Ander Conselvan de Oliveira 2017-06-16 12:01:13 UTC
(In reply to Martin Peres from comment #5)
> (In reply to Martin Peres from comment #4)
> > There are other issues that got hidden by this bug though...
> 
> [drm:skl_check_pipe_max_pixel_rate [i915]] *ERROR* Max supported pixel clock
> with scaling exceeded
> 
> It was seen on CI_DRM_2680/81/82 and nothing since, so I will not file a bug
> for it.

I believe that was fixed in

commit 789f35d70c33b5c3809907d586f080c62ada7365
Author: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
Date:   Thu Jun 1 12:34:13 2017 +0200

    drm/i915/glk: Fix dotclock calculation in skl_check_pipe_max_pixel_rate

so no need to file a bug for it.
Comment 7 Elizabeth 2017-06-16 22:17:13 UTC
Could you please share the status on this bug. Is it still unfixed? Thank you.
Comment 8 Martin Peres 2017-06-17 16:09:51 UTC
(In reply to elizabethx.de.la.torre.mena from comment #7)
> Could you please share the status on this bug. Is it still unfixed? Thank
> you.

The status of the bug is:
 - Seems to be a real issue, as it happened twice
 - No idea how to reproduce the problem again
 - No idea if the bug has been fixed by something else

So, for this sort of bugs, the solution is: Wait and see!
Comment 9 Elizabeth 2017-06-28 15:40:41 UTC
(In reply to Martin Peres from comment #8)
> (In reply to elizabethx.de.la.torre.mena from comment #7)
> > Could you please share the status on this bug. Is it still unfixed? Thank
> > you.
> 
> The status of the bug is:
>  - Seems to be a real issue, as it happened twice
>  - No idea how to reproduce the problem again
>  - No idea if the bug has been fixed by something else
> 
> So, for this sort of bugs, the solution is: Wait and see!

Hello everyone,
It seems that this bug is going to need some time to fix, so I'm going to change the status to NEEDINFO. Once there is more information to advance on this case, please change to REOPEN.
Thanks.
Comment 10 Jari Tahvanainen 2017-07-03 08:20:17 UTC
Martin - the last failure is on 2017-06-01, so could we assume this as fixed (or worksforme...)?
Comment 11 Martin Peres 2017-07-05 10:00:36 UTC
(In reply to Jari Tahvanainen from comment #10)
> Martin - the last failure is on 2017-06-01, so could we assume this as fixed
> (or worksforme...)?

Yes, this used to be quite reproducible, so let's close it now.
Comment 12 thanos17997@gmail.com (Spammer; Account disabled) 2019-04-12 07:27:39 UTC
There are the update to all web users online looking here http://fileexplorerwindows.com and seen the windows explorer windows 10 best app for the save to all file.
Comment 13 Antoniacummins 2019-04-18 06:31:05 UTC
All suitable. Its a placing in unc0ver. simply toggle it on and hit jailbreak. It must popup a messgae if successful that says some thing along the lines off “efficiently restored root record device” or https://24hwritemyessay.com/application-essays-writing some thing. Then try to jailbreak once more
Comment 14 Natasha aiken 2019-04-20 07:55:01 UTC
Assignment Writing Service mission conveyance, advanced substance the executives (site, online life, and so forth.), venture the board, pamphlet creation, and joint effort. https://www.assignmentglobe.com
Comment 15 qjc38049@cndps.com 2019-05-25 08:10:33 UTC
This information is really good. Thanks for sharing this valuable information. Wonderful and helpful information. Keep up the good work. Thank you for this wonderful work. <a href="https://www.ccc.com/">https://www.ccc.com/</a>
Comment 16 qjc38049@cndps.com 2019-05-25 08:11:01 UTC
This information is really good. Thanks for sharing this valuable information. Wonderful and helpful information. Keep up the good work. Thank you for this wonderful work. <a href="https://www.oysmarto.website/">https://www.oysmarto.website/</a>

<a href="https://straighttalkcustomerservicephone.blogspot.com/">https://straighttalkcustomerservicephone.blogspot.com/</a>
Comment 17 tuh31343 2019-06-05 18:58:56 UTC
such a knowledgeable nice information to us. This is very helpful info. Keep up the good work. I simply couldn't leave your website before suggesting https://www.pc9x.com/straight-talk-data-cap-reset/
Comment 18 davidjohn 2019-06-19 11:41:07 UTC
Your blogs further more each else volume is so entertaining further serviceable It appoints me befall retreat encore. I will instantly grab your rss feed to stay informed of any updates. https://www.fiverr.com/mubeenshahjahan/make-80-dofollow-blog-comments-on-high-da-pa-manually
Comment 19 Olivia Onil 2019-07-19 14:31:08 UTC
Hello! I have found useful information which can help many people. Here is one https://exclusivepapers.net/ This service can help you with the writing papers of different kinds like essay and dissertations. Also, there are a lot of interesting articles with the tutorials on how o write papers quick avoiding lots of mistakes.
Comment 20 Usama 2019-08-17 09:13:46 UTC
I have found the information useful and i have shared with my friends to read it. https://www.2dollaressay.com
Comment 21 John Wick 2019-08-26 14:11:28 UTC
Well, it's been quite some time since my last post, but I'm happy to report that Forex Fury continues to dominate the markets in 2018. This system is the most productive robot I have ever used, and I continue to use it on a daily basis with every single trading account that I own (currently 5 accounts). https://www.myfxbook.com/members/forexfuryreal
Comment 22 John Wick 2019-09-02 14:47:14 UTC
Forex Steam is a 100% automated trading solution. With over 25 years of experience in the Forex market our team has put together a system that provides long term growth in a low risk environment.

https://www.youtube.com/watch?v=-qMI4eVn1e0


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.