Bug 101411 - [SKL] GPU hang in Starbound
Summary: [SKL] GPU hang in Starbound
Status: CLOSED DUPLICATE of bug 101402
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-13 19:59 UTC by leozinho29_eu
Modified: 2017-06-15 13:12 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
error (13.73 KB, application/x-bzip)
2017-06-13 19:59 UTC, leozinho29_eu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description leozinho29_eu 2017-06-13 19:59:29 UTC
Created attachment 131931 [details]
error

Hello

When opening Starbound, after the initial loading screen, when the main menu should appear, the computer freezes and, after it returns to function, the game crashes. 

When the game is opened from the terminal, a message can be seen in the moment the game crashes:
intel_do_flush_locked failed: Input/output error

After this freeze and crash, some messages appear on dmesg:

[ 1868.754963] [drm] GPU HANG: ecode 9:0:0x85dffffb, in starbound [5869], reason: Hang on render ring, action: reset
[ 1868.754964] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 1868.754965] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 1868.754966] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 1868.754966] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 1868.754967] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 1868.755030] drm/i915: Resetting chip after gpu hang
[ 1868.755197] [drm] RC6 on
[ 1868.770399] [drm] GuC firmware load skipped
[ 1876.750371] drm/i915: Resetting chip after gpu hang
[ 1876.750473] [drm] RC6 on
[ 1876.764402] [drm] GuC firmware load skipped
[ 1890.798070] drm/i915: Resetting chip after gpu hang
[ 1890.798216] [drm] RC6 on
[ 1890.813528] [drm] GuC firmware load skipped
[ 1898.797893] drm/i915: Resetting chip after gpu hang
[ 1898.798138] [drm] RC6 on
[ 1898.815332] [drm] GuC firmware load skipped
[ 1906.797768] drm/i915: Resetting chip after gpu hang
[ 1906.797894] [drm] RC6 on
[ 1906.811883] [drm] GuC firmware load skipped

Every time the game is opened this problem happens. The only way to make this not happen is to open it from terminal with the option LIBGL_ALWAYS_SOFTWARE=1, but then the performance is terrible, because then it is used software rendering.

Information from glxinfo:

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2) (0x1916)
    Version: 12.0.6
    Accelerated: yes
    Video memory: 3072MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)
OpenGL core profile version string: 4.3 (Core Profile) Mesa 12.0.6
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile 

Specifications:

Processor: Intel Core i3-6100U;
Video: Intel HD Graphics 520;
Architecture: amd64
Mesa: 12.0.6;
libdrm: 2.4.70-1
Kernel version: 4.11.4-041104-generic from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.11.4/ This happened with generic (4.4), generic-hwe (4.8) and generic hwe-edge (4.10) too.
Distribution: Xubuntu 16.04.2 amd64
Machine: Lenovo Ideapad 310-14ISK (LENOVO 80UG/Toronto 4A2, BIOS 0XCN42WW 04/21/2017)

Steps to reproduce:
1) Open the game Starbound;
2) Wait the loading;
3) Note how the entire system freezes when the main menu should appear;
4) Crash.

Additional info:

I am not sure this can be helpful, but from the game logs, it hangs when the following message appears:
[Info] detected supported OpenGL texture size 8192, using atlasNumCells 256

Apparently, https://bugs.freedesktop.org/show_bug.cgi?id=101402 is the same problem.

I will try to test with Xubuntu 17.04 to see if on the newer version this bug exists.

Thank you.
Comment 1 leozinho29_eu 2017-06-14 02:10:47 UTC
Hi

I have installed Xubuntu 17.04, which has mesa version 17.0.3, and this error is not happening. So looks like the problem is with Ubuntu 16.04 with mesa 12.0.6.

Should I ask Ubuntu maintainers to upgrade mesa's version in Xenial?

Thank you.
Comment 2 Elizabeth 2017-06-14 17:46:00 UTC
Hello, could you please attach the logs without being compressed.
Seeing that you didn't have the same trouble on Xubuntu, could you please try the following steps: 
First, clone or download from https://cgit.freedesktop.org/mesa/mesa/ the same version of mesa that you used on Xubuntu, then do a git checkout to that version, and finally follow the steps in the building guide: https://01.org/linuxgraphics/documentation/build-guide-0
After this, try to reproduce the problem again and share us the results.
Thank you.
Comment 3 Elizabeth 2017-06-14 19:16:48 UTC
I forget to mention once you provide more information, please change the tag from "NEEDINFO" to "REOPEN". Thank you.
Comment 4 Chris Wilson 2017-06-15 12:53:00 UTC
(In reply to leozinho29_eu from comment #0) 
> Apparently, https://bugs.freedesktop.org/show_bug.cgi?id=101402 is the same
> problem.

The error state looks similar enough that I am going to dupe and add your comments there.

*** This bug has been marked as a duplicate of bug 101402 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.