Bug 101443 - TF2 segfault at 0 ip 00000000f4dbed6e sp 00000000ffcb99c0 error 6in i965_dri.so[
Summary: TF2 segfault at 0 ip 00000000f4dbed6e sp 00000000ffcb99c0 error 6in i965_dri.so[
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-15 10:54 UTC by coolo1mc
Modified: 2019-09-25 19:02 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
another trace (1.77 MB, application/octet-stream)
2017-07-01 08:29 UTC, coolo1mc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description coolo1mc 2017-06-15 10:54:13 UTC
[16328.004973] hl2_linux[5309]: segfault at 0 ip 00000000f4dbed6e sp 00000000ffcb99c0 error 6in i965_dri.so[f4948000+764000]
[16558.447699] hl2_linux[27730]: segfault at 0 ip 00000000f4d20d6e sp 00000000ff8536f0 error 6 in i965_dri.so[f48aa000+764000]
[17030.145622] hl2_linux[32524]: segfault at 0 ip 00000000f4db0971 sp 00000000ffde96f0 error 6 in i965_dri.so[f4950000+764000]   

This is now happening whenever the game loads a level. I cannot find any more output, this is just from dmesg.
Comment 1 Matt Turner 2017-06-15 21:33:15 UTC
Provide the Mesa version? Or really, any useful information?
Comment 2 coolo1mc 2017-06-15 22:40:02 UTC
mesa-intel-dri-17.1.2
xf86-video-intel-2.99.917.56
Not really sure what you need
Comment 3 coolo1mc 2017-06-16 12:50:20 UTC
I have narrowed this down to when HDR is set to disabled, the issue goes away entirely when it is set to Bloom or Full.
Comment 4 Matt Turner 2017-06-16 14:08:32 UTC
Thank you. That is great.

Could you capture an apitrace that reproduces the issue? See https://github.com/apitrace/apitrace/blob/master/docs/USAGE.markdown

For Steam games, you can capture traces as described here: https://bugs.freedesktop.org/show_bug.cgi?id=80419#c22
Comment 5 coolo1mc 2017-06-19 01:32:27 UTC
(In reply to Matt Turner from comment #4)
> Thank you. That is great.
> 
> Could you capture an apitrace that reproduces the issue? See
> https://github.com/apitrace/apitrace/blob/master/docs/USAGE.markdown
> 
> For Steam games, you can capture traces as described here:
> https://bugs.freedesktop.org/show_bug.cgi?id=80419#c22
https://ufile.io/ahcr7
Theres the trace, ~277MB
Not sure if this is what you wanted, but it crashes when replayed...
Comment 6 coolo1mc 2017-07-01 08:29:26 UTC
Created attachment 132382 [details]
another trace
Comment 7 Robert 2017-11-03 22:31:21 UTC
Ubuntu 17.10
Mesa 17.2.2
Intel HD 620
Dell XPS 13 9360 w/ Kabylake

hl2_linux[20200]: segfault at 0 ip 00000000f52d24f9 sp 00000000ff807e90 error 6 in i965_dri.so[f4ece000+8d4000]

This is with 2XMSAA and 2X Anistropic Filtering enabled, because if I disable those two settings, it leads to a separate, quicker crash.  That is being tracked elsewhere.
Comment 8 Robert 2017-11-03 22:44:07 UTC
Not sure if related, I notice both crash for me the same way and involve error 6, but I also see this:

MatQueue0[22234]: segfault at 0 ip 00000000f7e88dcc sp 0000000004eb29d8 error 6 in libc-2.26.so[f7d4c000+1cf000]

If it is not related, I can submit another bug.
Comment 9 Denis 2018-06-06 09:49:13 UTC
hello!
I re-checked this issue and seems that it is not reproducable anymore.
From what I found - that this crash was actual up to 17.2.8 mesa version (including it) and not actual for 18.0.1 and higher.

Also, Robert, I played a lot with video settings for the game (Anistropic Filtering, bloom, etc..) and time to time cought crashes by memory. But this is known issue as I found, so... not a case.

Latest mesa 18.2.0 works fine (about 30-40 minutes of gameplay didn't lead to crash).
Comment 10 GitLab Migration User 2019-09-25 19:02:42 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1600.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.